


buttonFile Help Contents
Hints On Using Help 

Procedures
Alphabetic Listing 

Chapter Listing 

Reference Information
The   button  File Screen   

Menu Commands 

Keyboard and Mouse Shortcuts 

Terms and Definitions 

Error Messages 





The OK button
Choose the OK button when you are satisfied that all the dialog box's options are correct and you 
want to proceed.



The Cancel button
Choose the Cancel button to abort the operation/dialog and return to the previous area of the program
or dialog box.



The Help button
Choose the Help button to see context sensitive help on the how to use the dialog box.



How To Use Dialog Boxes
Below is a dialog box with all of the dialog elements labeled.

Click on an element for an explanation of its function



list box
A list box provides a list of options to choose from. If a list box contains more options than can be 
displayed on screen at once, you use the scroll bar on the right side of list box to scroll through the 

list. Clicking on the arrows at either end of the scroll bar, or pressing  or 

 to scrolls the list one option at a time. Clicking above or below the scroll box , or pressing 

 or 

 scrolls one box full of options at a time. Click and drag the scroll box to move to that relative 
location in the list. For example, dragging the scroll box half way down the scroll bar moves to the middle 
of the list; dragging to the bottom of the scroll bar gets you to the end of the list.

Double-click on an option to chooses it, or move the highlight to the desired option and press .



drop-down list box
Some list boxes initially appear as one line with a down-arrow button on the right. This kind of list box 

is called a drop-down list box. Clicking on the button, or pressing  + 

 pulls down the list. Once a drop-down list is pulled down, it functions identically to standard list boxes.
You can also scroll through the list's options without pulling the list down using the 

 and 

 keys.



check box
Check boxes are on/off options. When a check box option is active, an X appears in the box. Click in 
the check box once to turn it on, click it again to turn it off. You can also turn a check box on and off by

holding down  and pressing the letter that is underlined in the check box's name.
Check boxes can also be gray in addition to checked or empty. A gray check box indicates an ambiguous 
status. For example, if you a selected group of frames in the report designer has a mixed set of attributes 
(for example, some frames are bold only, others are bold and italic, some underlined, and some have no 
attributes) some or all of the Font Style check boxes will be filled with gray. As long as you leave the Font 
Style check boxes gray, the original styles will be retained. If you check any of the check boxes (x in the 
box), that attribute will be set for all of the selected group when you choose OK. Likewise, clearing a 
check box (neither x nor gray), turns the attribute off for all of the members of the selected group.



command buttons
Command buttons are the rectangular buttons in a dialog box used to initiate an action. The OK and 
Cancel buttons found in most dialog boxes are typical examples. Any command button with text 
followed by (...) leads to an additional dialog box which requires further information to complete that 
action. Any command button that is gray or dimmed isnt currently available, and requires some action 
in the current dialog box before it will become active. Typically, selecting, opening or naming a file is 
the required action to make a dimmed button active.



option buttons
Option buttons indicate a set of mutually exclusive options. You can only select one option from the 
set. When an option is selected, its button is filled with a black dot. Select an option button by clicking 

on it. You can also select an option button by holding down  key and pressing the letter that is 
underlined in the option buttons name.



spin boxes
Spin boxes are a special kind of text box that only accept a limited set of input values. A spin box 
consists of a text box with a pair arrow buttons on the right. You can type a new value directly into the 
text box, click the up arrow button to increase the value, or click the down arrow button to decrease 
the value. 



text box
Text boxes allow you to type in information. If the cursor is not currently active in the desired text box, 
either click in the text box with the mouse, or press TAB or SHIFT-TAB until the cursor moves to the 
desired text box. 

In some cases, default text may appear highlighted in the box. If you start typing immediately, the 
highlighted text will deleted and replaced by what you typed. If you want to edit the highlighted text, 
you need to first move the cursor to the point you want to begin inserting text using the mouse or 

cursor movement keys ( , 

, or 

), before you start typing you changes.
All text boxes have a limit to the number of characters you can type into them. Some text boxes scroll to 
the left, allowing you to enter text that is longer than the box dimensions, others do not scroll. Either way, 
buttonFile beeps when you reach the limit of the text box to tell you that no more characters can be typed 
in.



scroll bar





Error/Information Messages
Listed below are various buttonFile messages, explanations, and recommended actions.

A copy of buttonFile is already running.
Only one session of buttonFile can be running at a time. You tried to start buttonFile from 
Program Manager or File Manager after buttonFile was already running. buttonFile 
automatically switches to the current session--choose OK to clear the message.

ACCESS DENIED: Wrong Password
The deck you are trying to open has been password protected and cannot be opened 
until you provide the correct password.

Active modem not detected on Communications Port. Use the Phone Dialer 
option on the Configure menu to select the correct modem port. Also, make 
sure your modem is on.

Check to make sure your modem is properly connected and turned on. Make sure that 
you have selected the correct port using the Phone Dialer option on the Configure menu.

Available phone line not detected. Make sure your phone is not off the hook.
buttonFile cannot access a phone line when dialing. Make sure your phone handset is on 
the hook before you start dialing. If you are using a PBX system (office phone system, 
where you need to dial a number to access an outside line), make sure you have the 
proper line access code in the Get Outside line text box of the dialog box accessed using 
the Phone Dialer option on the Configure menu.

buttonFile can't import CRD files with bitmaps or objects.
buttonFile does not support bitmaps or OLE objects. The Cardfile file you are trying to 
import contains bitmaps or OLE objects.

buttonFile is unable to find the printer driver: printername Check your WIN.INI 
file for errors in the DEVICE= statement.    You may need to use SETUP to 
reinstall your printer or CONTROL PANEL to select one.

This error message will display if you do not have a default printer specified using the 
Printers option on the Windows Control Panel. This will generally only occur if no printer 
was installed when installing Windows, or if you have removed all printer drivers. Use the 
Printers option on the Windows Control Panel to select or add your printer.

This error message can also occur if the current printer driver is damaged. Try reinstalling
the printer using the Printers option on the Windows Control Panel. 

Can't Create Memo File filename
The memo file (.DBT) for the dBase file you are trying to export cannot be created. There 
may be too many files open--try closing some files and try again. If you are on a network, 
you may not have permission to create a file in the current directory--try exporting to a 
directory on your local drive. Also, there may not be enough available disk space--try 
deleting unnecessary files and try again. If the problem persists after taking the above 
into consideration, this may be due to a hardware or disk error.

Can't merge active card deck into itself.
You have attempted to use the Merge option on the File menu to merge a deck into itself. 
buttonFile only allows you to merge two separate decks.

Can't Open File filename



The file you are trying to import cannot be opened. This is usually due to hardware or disk
errors.

Can't Open Memo File filename
buttonFile cant open memo file (.DBT) for the dBase file you are trying to import. This is 
usually due to hardware or disk errors.

Can't open the deck deckname
The deck named in the message cannot be opened for processing. There can be several 
reasons for this:
The file is use by someone else on your system (if you are using a network).
Your system has hardware or disk errors.
The FILES= statement in your CONFIG.SYS file is too small. Generally this should not be a 

problem because Windows configures this number appropriately when it is installed. However, increasing 
this number and rebooting your system may make a difference. Also, closing files in other applications 
may make a difference.

Cant add frame(s) maximum Card Data Length of 4000 will be exceeded
The total data length of the fixed length portion of a buttonFile deck (all standard data 
boxes and the first 10 characters of a notes box) cannot be more than 4000 characters 
long. You are either trying to add a new frame or paste a frame or frames after this 
maximum has been reached. If you want to add additional data box frames, you must 
shorten the data lengths of current data box frames before proceeding.

Cant Create File filename
The file you are trying to export cannot be created. There may be too many files open--try
closing some files and try again. If you are on a network, you may not have permission to 
create a file in the current directory--try exporting to a directory on your local drive. Also, 
there may not be enough available disk space--try deleting unnecessary files and try 
again. If the problem persists after taking the above into consideration, this may be due to
a hardware or disk error.

Cannot create Windows Timer. Try exiting other programs.
The Windows environment has insufficient memory to perform the timed operation. 
Closing other programs should free up memory.

Cannot save deck while overlapping exists.
There are at least two frames in your deck design that are overlapping each other. Or 
there are frames that are overlapping the card border. buttonFile shades overlapping 
frames to indicate their status. You must eliminate any overlapping before you will be 
allowed to save your deck design.

Cannot save report while overlapping exists
The report you are trying to save has overlapping elements. Either two or more frames 
overlap, or there is a frame overlapping or outside of the form border. Any overlapping 
frames are shaded dark blue. You must eliminate all overlapping frames before you can 
save your report.

Cannot specify third level sort without a second level sort.
You have specified a data box for a Level 3 sort, but have not specified a Level 2 data 
box. You must specify a Level 2 data box before you will be allowed to continue.

Cannot use same data box on two index levels at once.
You have requested to sort the same data box on two levels. You must choose a different 



data box before you can continue.

Close error
buttonFile was not able to properly close the file. Check for disk hardware failure.

Communications environment error
This error will only occur in a network environment. A network error has occurred on the 
workstation, file server, or connection to the network has been lost. Try logging on to the 
network again, or check with your network administrator for assistance.

Compilation Date: date

This message displays when you press  + 

. The date indicated is when the copy of buttonFile you are using was produced.

deckname has been modified.    Do you want to save modifications before 
closing?

This message displays if you close the program before you have saved the modifications 
made to the specified deck. If you choose Yes, the changes will be saved. If you choose 
No, the changes will not be saved and will be lost.

deckname has not been saved.    Do you want to save it before closing?
This message displays if you close the program before you have saved the specified 
deck. If you choose Yes, the Save dialog box will display for you to save the deck. If you 
choose No, the deck will not be saved and will be lost.

Different key number (key number switched from last operation)
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Directory error
buttonFile is unable to locate the deck file in the directory it was originally saved. You may
have deleted or renamed the directory.

Disk is full
The disk is full and the deck file cannot be written to. Erase any unnecessary files to free 
disk space.

Do not forget the password! Encrypted card decks cannot be recovered 
without the password.

Reminder message--do not forget your password! If you choose the Data Encryption 
option and you lose or forget your password, it is not possible to recover your data.

Duplicate key in file
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Error opening Communications Port (number)
This message can be triggered by various hardware problems and system conflicts. 
Make sure that your configuration settings are properly setup using the Phone Dialer 
option on the Configure menu. You may also need to refer to your modem documentation
and check the Ports settings on the Windows Control Panel. If the problem persists, note 
the number in parenthesis and contact ButtonWare technical support for further 



information.

Error writing to cache
An error has occurred while reading or writing to disk. This could indicate either a 
damaged file or disk hardware failure.

Expansion error
This error should only occur if you are accessing a deck that is located on a network drive
and there was a disk hardware failure. Check with your network administrator.

Extended file error
This error should only occur if you are accessing a deck that is located on a network drive
and the file is extended over more than one drive. Check with your network administrator 
for assistance.

File filename is not in Word Perfect format
The file you are trying to import is not a valid WordPerfect 5.1 Secondary Merge file. 
buttonFile only supports WordPerfect version 5.1 Secondary Merge files. If the file was 
produced using an earlier version of WordPerfect and you have WordPerfect 5.1, you can

load the file and convert it to 5.1 format using  + 

. Refer to your WordPerfect documentation for details. It is also possible that the file is not a 
WordPerfect file at all, or that the file has been damaged.

File is not .CRD format
The file you are attempting to import as a Windows Cardfile file is not in a valid format. 
Either the file is damaged, or it was not produced by Windows Cardfile.

filename is not a DBF file.
You indicated that the file you are trying to import is a dBase file using the List Files of 
Type list box. Either this file is not a valid dBase file or it is damaged.

File is not open
buttonFile cannot read or write to the file.

File not found
buttonFile cannot read or write to the file.

File table is full
You have attempted to open too many deck files at once. Close some of your deck files.

General File Error
An unknown error has occurred in your data file. Try restoring a backup copy of the file.

Handle table is full
You have attempted to open too many deck files at once. Close some of your deck files.

I/O Error. Possibly a damaged file
An error has occurred while reading or writing to disk. This could indicate either a 
damaged file or a disk error.

Incomplete accelerated access
This error can occur there was an abnormal program termination (hanging or loss of 



power) while performing a Merge, Replace All, or Import operation.

Incomplete index
The decks index may be damaged due to program interruption while the index was being 
built. Try rebuilding the index using the Index option on the Configure menu.

Insufficient disk space to complete operation.
There is not enough available disk space to complete this operation. Delete any 
unnecessary files and try this operation again.

Insufficient Memory
There is not enough memory available to perform the requested operation. Try closing 
other applications and try again.

Invalid file extension.
You have used an invalid file extension for the file you are trying to save. If you do not 
include a file extension (just the first part of the file name), buttonFile will save using the 
appropriate default file extension.

Invalid key length
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Invalid key number
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Invalid positioning
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Invalid record length
The 4096 character (4K) maximum record size has been exceeded. The deck file may be
damaged. Try restoring a current backup copy.

Key was not found
The index may be damaged. Try rebuilding the index using the Index option on the 
Configure menu.

Memo Read Error, File filename
The memo file (.DBT) for the dBase file you are trying to import cannot be read. The file 
may be damaged or it may be sitting on a bad spot on the disk. Copy a backup of the file 
and try importing again.

Memo Write Error, File filename
The memo file (.DBT) for the dBase file you are trying to export cannot be written to disk. 
There may not be enough available disk space--try deleting unnecessary files and try 
again. If the problem persists, this may be due to a hardware or disk error.

Not a Btrieve file
The deck file is damaged or was overwritten by a foreign file format. Replace the deck file
with its most recent backup.

Not enough memory to open Communications Port. Try exiting some 



applications.
The Windows environment does not have enough memory available to access the 
communications port for dialing. Closing other applications should correct this.

One or more names are blank or duplicates, Do you want them changed 
automatically?

There are blank or duplicate names in your deck design. If you choose Yes, buttonFile will
automatically assign unique names to each data box--you can change the names later 
using the Redefine option on the File menu, if you wish. If you choose No, you will be 
returned to the deck designer so that you can correct the problem yourself.

Out of Memory
The Windows environment does not have enough memory to perform the requested 
operation. Closing other programs usually corrects this.

Password cannot be empty.
You must have at least one character for the password.

Permission error
This error will only occur if you are trying to access buttonFile files from a network drive. 
You do not have sufficient network rights (permissions) in the current directory to open 
the file. Check with your network administrator if you require access rights for this 
directory.

Pre-Image I/O error
This error could occur if buttonFile was unable to finish a disk writing operation due to 
power loss or abnormal program termination. Restore a recent backup copy of the deck.

This error can also occur if buttonFile is unable to open a decks .PRE file due to 
insufficient disk space. Deleting unnecessary files may make a difference.

Pre-Image open error
This error could occur if buttonFile was unable to finish a disk writing operation due to 
power loss or abnormal program termination. Restore a recent backup copy of the deck.

This error can also occur if buttonFile is unable to open a decks .PRE file due to 
insufficient disk space. Deleting unnecessary files may make a difference.

Read Error, File filename
The file you are trying to import cannot be read. The file may be damaged or it may be 
sitting on a bad spot on the disk. Copy a backup of the file and try importing again.

Requested Communications Port does not exist.
The communications port that buttonFile was configured for is not available. These 
settings may have been configured for a different machine. Check the Phone Dialer 
configuration settings using the Phone Dialer option on the Configure menu to make sure 
buttonFile is properly set up to work on your machine.

Requested Communications Port is not available.
There is a problem accessing the communications port. This might be due to a hardware 
problem. Make sure your modem is properly connected and turned on. This message can
also be caused by choosing the wrong port when using the Phone Dialer option on the 
Configure menu. Double-check your configuration settings to make sure that you have 
selected the correct port.



Save current report design before quitting?
You are closing the Report Designer window before the current report design has been 
saved. Choose Yes to display the Save Report dialog box to save this report. Choose No 
to discard this report design.

Save current report design before starting a new one?
You are closing the Report Designer window before the current report design has been 
saved. Choose Yes to display the Save Report dialog box to save this report. Choose No 
to discard this report design.

Session is no longer valid
This error will only occur in a network environment. A network error has occurred on the 
workstation, file server, or connection to the network has been lost. Try logging on to the 
network again, or check with your network administrator for assistance.

That phone does not answer.
A connection has been made when dialing, but there is no answer.

That phone is busy.
A connection has been made when dialing but the line is busy.

The maximum number of data box frames (40) has already been used.
A buttonFile deck cannot have more than 40 data boxes (including up to one notes box). 
You cannot add any additional data boxes to your deck design.

The maximum number of note frames (1) has already been used.
A buttonFile can only have one notes box and your deck design already has a notes box. 
You are probably attempting to paste a copy of a notes box using the Edit menu.

The maximum number of text frames (40) has already been used.
A buttonFile deck cannot have more than 40 text frames. You cannot add any additional 
text frames to your deck design.

The printer's pages size doesn't match the report's page size. Do you want 
buttonFile to change the printer's page size before printing? 

The form for the report you are printing doesnt match the page size currently set on your 
printer. If you choose Yes, buttonFile will change the printers page size. If you choose No,
buttonFile will print the report on the current page size--data may be lost or may not be 
properly aligned.

The requested deck is already in use.
You attempted to open a deck when it is already open. Pull down the Window menu to 
view the names all decks currently open.

This deck cannot be saved because it does not contain any data boxes. 
Discard the deck design?

You are closing the deck designer window after defining text frames, but no data box 
frames. If you choose OK, the current deck design will be lost. If you choose Cancel, you 
will be returned to the deck designer--if you add at least one data box, you can save the 
deck design.

This file already exists, Replace existing file?
You have either entered a file name that is identical to a pre-existing file name, or you 



selected a pre-existing file name from the File Name list box. If you choose Yes to 
continue the pre-existing file will be lost permanently

This file may be damaged.    I might be able to fix it if you have a file with an 
identical Template.

There is some information stored at the beginning of a deck that defines its structure. 
buttonFile has attempted to read this information from the deck you are trying to open 
and detected that it is damaged. If this is the full extent of the damage to the deck, 
buttonFile can fix the problem by copying this information from a deck with a matching 
structure. If you choose Yes to continue, you can choose which deck to copy this 
information from. 

Warning: This operation is irreversible. If you choose a deck that does not have an 
identical design, your deck may be damaged even further. You should choose No, if you 
do not have a current backup of this deck.

This report already exists. Replace existing report?
You are trying to save the current report to the name of a pre-existing report. Choose OK 
if you want to replace the old report with the new one. Choose Cancel, if you do not want 
to lose the old report, then enter a new name for the report.

Unable to create a temporary file for the design deletion process.    Perhaps 
there is not enough room on your disk drive?

When deleting a report, buttonFile creates a temporary file that will allow you to recover 
accidentally deleted reports. This message displays if there is insufficient disk space to 
create the temporary file. Deleting unnecessary files should correct the problem.

Unable to Create/Open Phone Log File.
buttonFile cannot create a phone log file. Usually this is due to a lack of available disk 
space, in this case, deleting unnecessary files should correct the problem. It can also be 
caused by hardware problems or disk errors.

Unable to Log Call. No Active Deck.
You chose the Log This Call option when no deck is open. A phone log is always saved to
the same name as the active deck.

Unrecoverable error
An unrecoverable error has occurred. Replace the deck file with its most recent backup.

Variable page error
buttonFile could not read all or part of a Notes box--as much data a possible will be 
provided. This usually indicates damage to the deck file. You may want to replace the 
deck file with its most recent backup.

Warning...The printer doesn't support this report's pages size. Continue 
printing?

The form for the report you are printing is not supported by the current printer. The report 
may have originally been set up for another printer, or you may have defined a custom 
form that will not fit on this printer. If you choose OK, buttonFile will print the report on the 
current page size--data may be lost or may not be properly aligned. If you choose Cancel,
you will be returned to the Print dialog box. You can then choose a different printer that 
does support the report's page size using the Printer Setup button, or you can return to 
the Report Designer and modify the reports form to one that is supported by the current 
printer.



Write Error, File filename
The file you are trying to export cannot be written to disk. There may not be enough 
available disk space -- try deleting unnecessary files and try again. If the problem 
persists, this may be due to a hardware or disk error.

You cannot paste data box frames when redefining. Adding data box frames 
using any method is not allowed when redefining

This message will display if you attempt to copy and paste data box frames while using 
the Redefine option on the File menu. You cannot cut, delete, or paste data box frames 
while redefining.

You must provide a phone number to dial. Select from the list provided, or 
type one.

You have attempted to dial with no phone number displayed in the Phone Number text 
box. The current card may have no phone number data. See Using the Phone Dialer for 
details on how to use the phone dialing features.



This file may be damaged.    I might be able to fix it if you have a file 
with an identical Template.

There is some information stored at the beginning of a deck that defines its structure. 
buttonFile has attempted to read this information from the deck you are trying to open 
and detected that it is damaged. If this is the full extent of the damage to the deck, 
buttonFile can fix the problem by copying this information from a deck with a matching 
structure. If you choose Yes to continue, you can choose which deck to copy this 
information from. 

Warning: This operation is irreversible. If you choose a deck that does not have an 
identical design, your deck may be damaged even further. You should choose No, if you 
do not have a current backup of this deck.





Keyboard and Mouse Shortcuts
Keyboard Shortcuts, Menu Options, and Button Bar Buttons
If you are not using a mouse, you can access the same functions that are available on the button bar 
using menu options and keyboard shortcuts.

Click on an item below to for a list of the shortcuts:
All   button  File Windows   
Deck Windows 
Deck Design Windows 
Report Design Windows 



All buttonFile Windows
All of buttonFile's windows (deck, deck design, and report design) have functions in common. Listed 
below are the shortcut keystrokes and associated menu picks which can be used in any buttonFile 
window.

Shortcut
Keystrokes

Menu
Equivalent
Toggle focus between work area

and menu bar

 + Edit menu:
Copy

Help menu:
Contents

 + File menu:
Exit buttonFile

 + Window menu:
Tile Horizontal

 + Window menu:
Tile Vertical

 + Move to previous child window

 + Move to next child window

Toggle GROUP selection mode

 + Toggle ITEM selection mode

Toggle focus between work area
and menu bar

 + Edit menu:
Paste

 + Edit menu:
Cut

 + Edit menu:
Undo

Deck Windows
Listed below are the shortcut keystrokes and associated menu picks which can be used in a deck 
window :

Shortcut
Keystrokes

Button Bar
Button

Menu
Equivalent

(none) File menu:
New

 +  + 
letter (none)

Search menu
(Table View):

Next Card



Search menu
(Table View):

Previous Card
(none) Toggle focus between work 

area and menu bar

 + Card menu:
Add

 + (none) Card menu:
Delete

 + (none) Search menu:
Navigate--Last Card

 + Search menu:
Find

Phone menu:
Dial

 + (none) Card menu:
Undelete

 + (none) Card menu:
Delete

(none) View menu:
Card/Table toggle.

 + (none) Search menu:
Navigate--First Card

 + (none) Configure menu:
Index

 + Search menu:
Find Next

 + File menu:
Open

Search menu
(Card View):

Navigate--Next Card 
Search menu
(Table View):

Navigate--Next Windowful 

 + Search menu
(Card View):

Navigate--Next Windowful
Search menu
(Card View):

Navigate--Previous Card 
Search menu
(Table View):

Navigate--Previous 
Windowful 

 + Search menu



(Card View):
Navigate--Previous 
Windowful

 + File menu:
Print Report

 + (none) Search menu:
Replace

 + File menu:
Save

 + (none) Card menu:
Duplicate

 + (none) Edit menu:
Smart Paste

Deck Design Windows
Listed below are the shortcut keystrokes and associated menu picks which can be used in a deck 
design window .

Shortcut
Keystrokes

Button Bar
Button

Menu
Equivalent

(none) Move frame(s)

 + (none) Resize frame

 + Tools menu:
Frame Attributes--alignment 
toggle

 + Tools:
Add Data Box

 + File menu:
Open

 + Tools menu:
Add Notes Box

 + File menu:
Save

 + Tools menu:
Add Text

Accessing Button Bar Text and List Boxes with the Keyboard
When you are in a Deck Design, text boxes, list boxes and other objects appear on the button bar to 
the right of the standard buttons. These objects change depending on what type of frame is selected. 
Modifying these objects' attributes on the button bar is the same as using the frame's Attributes dialog
box.

If you do not have a mouse, you can move the cursor or highlight to button bar text and list boxes by 

pressing  + the underlined letter in the object's title.
The following table lists each of the keyboard shortcuts to access button bar objects in the deck 
design window:

Keys
Frame
Type Button Bar Object



 + Data Box
Notes Box

Name list box

 + Data Box
Notes Box

Phone check box

 + Data Box
Notes Box

Show Name check box

 + Text Box Text text box

Report Design Window
Listed below are the shortcut keystrokes and associated menu picks which can be used in report 
design window .

Shortcut
Keystrokes

Button Bar
Button

Menu
Equivalent

(none) Tools menu:
Add System Data

(none) Move frame(s)

 + (none) Resize frame

 + Tools menu:
Frame Attributes--
alignment toggle

 + Tools menu:
Frame Attributes--box 
type toggle

 + Tools menu:
Frame Attributes--bold 
toggle

 + Tools:
Add Data Box

 + Tools menu:
Change Form

 + Tools menu:
Frame Attributes--Italic 
toggle

 + Tools menu:
Add Line or Box

 + (none) File menu:
Open Report

 + File menu:
Print Report

 + File menu:
Save Report

 + Tools menu:
Add Text

 + Tools menu:
Frame Attributes--



underline toggle

Accessing Button Bar Text and List Boxes with the Keyboard
When you are in a Report Design Window, text boxes, list boxes and other objects appear on the 
button bar to the right of the standard buttons. These objects change depending on what type of 
frame is selected. Modifying these objects' attributes on the button bar is the same as using the 
frame's Attributes dialog box.

If you do not have a mouse, you can move the cursor or highlight to button bar text and list boxes by 

pressing  + the underlined letter in the object's title.
The following table lists each of the keyboard shortcuts to access button bar objects in the report 
designer:

Keys
Frame
Type Button Bar Object

 + Data Box
Notes Box

Name list box

 + Line/Box Corner Radius list box

 + Line/Box Fill Pattern list box

 + Line/Box Line Style list box

 + Text Box Text text box





Menu Commands
The menu bar is located at the top of the buttonFile main application window. The menu bar has a pull
down menu for each of the options listed across it. All of buttonFile's functions can be accessed from 
the menu bar and it's pull-down menus. Depending upon what type of window is currently active, the 
menu bar expands or contracts to provide the appropriate menu items for that window.

Click on a window type below to learn more about the menu commands available in that 
window:

Deck Window 

Deck Design Window 

Report Design Window 

You can access buttonFile's various menus either by clicking on them with the mouse pointer, or by 

pressing  + letter, where letter is the underlined letter in the menu's title. For example, to open 
the File menu using the keyboard, press 

 + 

.
Some menu options have special formatting which indicates how they function:

Grayed out or dimmed option
An additional action is required before this option will become active. The menu's heading
provides a good clue as to what is required. For example, the dimmed File menu options 
become active once a file is opened.

Ellipsis (...) after a menu option
A dialog box requiring additional information to complete the action displays when you 
choose these menu options.

A key combination after a menu option (e.g.CTRL+O)
Indicates the accelerator key--a key combination which allows you to perform this menu 
option without using the menu.

A triangle at the right side of a menu option
Choosing this option displays an additional menu.

A check mark in front of a menu option
Indicates an on/off option. When the check mark is present the option is turned on. 
Choosing the option again removes the check mark and turns the option off.



Deck Menu Bar
Click on a menu item to learn more about that menu's available commands

See also...

Menu Commands 



Deck Design Menu Bar
Click on a menu item to learn more about that menu's available commands

See also...

Menu Commands 



Report Design Menu Bar
Click on a menu item to learn more about that menu's available commands

See also...

Menu Commands 



The File Menu
Click on a menu item to find out more about what it does



The File Menu in the Report Designer
Click on a menu item to find out more about what it does

Related Topics...

The Button Bars 



The Edit Menu
Click on a menu item to find out more about what it does



The Tools Menu in the Deck Designer
Click on a menu item to find out more about what it does



The Tools Menu in the Report Designer
Click on a menu item to find out more about what it does



The Card Menu
Click on a menu item to find out more about what it does



The View Menu
Click on a menu item to find out more about what it does



The Search Menu
Click on a menu item to find out more about what it does



The Configure Menu
Click on a menu item to find out more about what it does



The Configure Menu in the Report Designer
Click on a menu item to find out more about what it does



The Phone Menu
Click on a menu item to find out more about what it does



The Window Menu
Click on a menu item to find out more about what it does



The Help Menu
Click on a menu item to find out more about what it does



Help Contents

Clicking on this menu item or pressing  brings up this help file and takes you to the main menu. 
To go to the Contents menu at any time while viewing buttonFile's help, choose the Contents button 
on the help file's button bar.



About buttonFile
Clicking on this menu item displays the About buttonFile dialog box. This dialog box contains your 
registration information, and also some additional information about buttonFile.



The System Menu
Click on a menu item to find out more about what it does



Switch To
Choosing the Switch To option on a window's system menu brings up the Windows Program Manager
Task List. This menu option is one way to switch between buttonFile and other Windows applications.





Welcome to buttonFile
buttonFile does for your computer what the Rolodex® did for your desk. Quickly. Easily. Better! 
Create mailing lists, team rosters, phone directories, inventory records, or a catalog of your favorite 
recipes. There's almost no limit to what you can store. And buttonFile lets you do it with the touch of a 
button--a handy button bar puts your most common activities just a mouse-click away.

Youre up and running instantly! Don't worry--there's no need to program or be familiar with databases.
buttonFile is ready to go with over a dozen pre-defined templates and reports: Business Contacts, 
Home Inventory, Credit Cards, Software Library, Personnel Records, Recipes, Rolodex Cards, Video 
Library, and more! Just choose the one you want to use, and start entering your data.

If you don't see what you're looking for, you can easily customize an existing template or create an 
entirely new file from scratch. Place fields. Add helpful text. Configure colors. Choose fonts. Move and
adjust all you want. All by clicking your mouse instead of programming!

Print like a professional! Print Mailing labels, Rolodex® cards, Envelopes, Reports, Lists, Rosters and
Catalogs. Just click with your mouse to put data where you want it. Then print! Choose from more 
than 80 predefined forms including most Avery and Dennison laser and tractor-fed forms, or create 
your own. You select the fonts and styles. You can even include lines and boxes for truly professional 
looking output. Print all records, just one, or a subset.

Find just what you're looking for! Browse through your data one card or one screenful at a time. Use 
the index buttons on the button bar to jump to the beginning of a group. Or search for specific pieces 
of data. You can find records that fall within a range. Or even perform sounds-like searches. And you 
use plain English instead of complicated formulas and symbols.

buttonFile is the perfect Windows companion program. Transfer information to other programs using 
the most common file formats. Quickly paste an address from your mailing list into a letter in your 
word processor. You can merge two decks together to combine information. And buttonFile will even 
dial a phone number for you. 

buttonFile is a great stand-alone personal database, and the perfect companion to almost any other 
Windows program.

Related Topics...

button  File's Requirements   

Checking the Contents of Your Package 

Installing   button  File   



Requesting Technical Support
The Technical Support Information card included with this package contains up-to-date phone 
numbers, operating hours, and other information to assist you in obtaining technical support.

We provide 30 days of free phone support after you register your copy of buttonFile. The 30-day free 
support period begins on the date of your first call and ends 30 days following. To receive technical 
support during your 30-day free support period, call (206) 454-2629.

After your 30-day free support period ends, options for obtaining technical support include:

Pay-as-you-go Phone Support: 1-900-454-8000

Yearly Support Plan: call (206) 454-0479 for information.

CompuServe Information Service: ButtonWare is located in Section 1 of the PCVENA forum. Just 
type go PCVENA at the ! prompt. Regular connect charges apply when using CompuServe. 

Electronic Bulletin Board Support: (206) 454-7879

Refer to the Technical Support Information card included with this package for further details on any 
of the technical support options listed above.

Related Topics...
button  File's Requirements   

Installing   button  File   

Requesting Customer Service 



Requesting Customer Service
ButtonWares Customer Service department exists to serve you. If you have any non-technical 
questions or comments about your package or registration, please contact us.

To reach our Customer Service department, call 206-454-0479 Monday through Friday between 8:00 
a.m. and 5:00 p.m. (Pacific time). If you prefer, you can write a letter and mail it to ButtonWare 
Customer Service, P.O. Box 96058, Bellevue, WA 98009-9818 or fax it to us at 206-454-1838. 

Related Topics...

Checking the Contents of Your package 

Requesting Technical Support 



Checking the Contents of Your Package
Before installing buttonFile, we recommend you check the contents of your package. Your package 
should contain the following materials:

buttonFile User Guide (this book)

License Agreement envelope containing: 5 1/4" disks (Disk One & Disk Two), and 3 1/2" disks 
(Disk One & Disk Two).

NOTE: Upgrade packages purchased from ButtonWare contain one set of the requested 
disk size, unless you requested both sizes. Retail upgrade packages contain one set of 
the size indicated on the package, and contain a Disk Exchange Card that you can return
to ButtonWare, if you require the other disk size.

Registration card (Unless you purchased this package from ButtonWare, in which case you are 
automatically registered.) 

Technical Support    Information

If any item is missing or damaged, contact your buttonFile dealer immediately. Or, if you purchased 
this product directly from ButtonWare, call our Customer Service    department at 206-454-0479. 



buttonFile's Requirements
buttonFile is designed to work on 286 (AT-class) or higher computers running Windows 3.0 or higher. 
Your computer must be able to run Windows in Standard Mode or 386 Extended Mode. In order to 
use buttonFile, your computer must have the following:

MS-DOS or PC-DOS 3.1 or later

Windows 3.0 (or higher) installed

At least 1MB RAM (more is recommended) 

A minimum of 2MB available disk storage

A EGA, VGA, SVGA, or Hercules graphics card, compatible monitor and appropriate Windows 
driver installed

Listed below are additional hardware items which are not required to use buttonFile, but are highly 
recommended:

A printer supported by Windows (dot matrix, laser, ink jet, or PostScript)

A mouse supported by Windows

A Hayes compatible modem (required to dial phone numbers)
Related Topics...
Installing   button  File   



Installing buttonFile
Before you begin using buttonFile, you must install it to a hard drive or to a network drive. buttonFile 
includes an installation program designed to make this step quick and easy. The installation process 
normally takes about 5 minutes.

You can start the installation program either with Windows already running from the Program 
Manager or the File Manager, or from the DOS command line when starting Windows. After the 
installation program is running, the procedures are the same no matter which method you used to 
start it.

To install buttonFile
1. Turn on your computer.

2. Insert the buttonFile disk into the appropriate drive (drive A or drive B).

Using Program Manager
1. Choose Run from the Program Manager File Menu.

2. Type a:setup in the text box, where a is the drive you inserted the buttonFile disk
into. Change this to b if you inserted the buttonFile disk into drive B.

3. Choose OK.

Using File Manager
1. Click on the appropriate drive icon: Click on A if you inserted the buttonFile disk in

drive A; click on B if you inserted the buttonFile disk in drive B.

2. Double-click on the drive letter in the Directory Tree window to open the file 
window (This step is not required when using the Windows 3.1 File Manager).

3. Double-click on the file named SETUP.EXE.

From the DOS command line
1. Type: win a:setup. Change a to b if    you inserted the buttonFile disk in drive B.

2. Press .
Continuing the Installation Process

1. After starting the installation program, the Welcome dialog box is displayed. 
Choose Continue to continue with the installation.

2. The following dialog box asks you to "Please enter the desired location for 
buttonFile. Choose Continue to accept the installation default, or enter the drive 
and path of your choice and choose Continue.

3. The following dialog box asks you to enter your name and, if applicable, your 
company's name. Choose Continue after you have done so.

4. The following dialog box asks you to confirm the name and company name you 
entered. Choose Continue if you are satisfied.

At this point, a box informs you as each file is decompressed. The bar at the bottom of 
the box indicates the progress. When all the files are installed, you are returned to the 
Windows Program Manager. The buttonFile program icon is in the buttonFile program 
group window. The installation is now complete.

Related Topics...

button  File's Requirements   

Confirming Installation 



Un-installing   button  File   



Un-installing buttonFile 
If you need to remove buttonFile from your system, you should be aware of the following:

The SETUP program creates a buttonFile group and program icons--you can delete these from 
the Program Manager.

If you are running Windows 3.0, the WINHELP.EXE file was copied to your \WINDOWS directory. 
This file can be deleted, but leaving it will not cause adverse affects.

If you are running Windows 3.0, COMMDLG.DLL and SHELL.DLL files were copied to your \
WINDOWS\SYSTEM directory. These files can be deleted, but leaving them will not cause adverse 
affects.

If it was not previously installed by another Windows application, the CTL3D.DLL file was copied 
to your \WINDOWS\SYSTEM directory. You should only delete this file if you are sure there are no other 
applications on your system which use it. If you are unsure, leaving this file will not cause adverse affects.

The following line is added in the [EXTENSIONS] section of the WIN.INI file:

BTN=c:\butnfile\butnfile.exe ^.BTN

The drive and directory will be different, if you installed to a drive or directory other than 
the defaults provided by the install program. You can remove this line, or leave it with out 
adverse affects.

The SETUP program creates a BUTTON.INI file in the \WINDOWS directory. You can delete this 
file, but leaving it will not cause adverse affects.

The following files are copied into the \BUTNFILE directory:

BUTNFILE.EXE
BUTNFILE.HLP
BUTNWARE.DLL
WBTRCALL.DLL
MUSCROLL.DLL
READ.ME
SOFTWARE.BTN

Deleting these files and the directory completes the removal of buttonFile from your system. 

Related Topics...

Installing   button  File   

Confirming Installation 



Confirming Installation 
After the Installation program is finished, start buttonFile to ensure that the installation process was 
successful.

Double-click on the  icon or make sure the name buttonFile under the icon is highlighted and 
press 

. The application window should appear.
If the buttonFile screen is not displayed, first check to make sure your computer has the minimum 
requirements to run buttonFile.    Then re-install the program following the instructions above. If after re-
installing the program, you still cannot successfully start and exit buttonFile, please call our Technical 
Support department at 206-454-2629.
Related Topics...
button  File's Requirements   
Installing   button  File   
Un-installing   button  File   



Registering Your Copy of buttonFile
Before you start using buttonFile, there is one final thing to doregister your copy.    When you register 
your copy of buttonFile, you are placed on our mailing list and will receive notifications of updates, 
new products, and special offers available only to registered users. In addition, when you register 
your copy of buttonFile, you are eligible for 30 days of free technical support.

NOTE: You do not need to register buttonFile, if you purchased this package directly from 
ButtonWare--you are automatically registered when your order is processed.

To register
...by mail

Fill out the registration card included in your package and mail it to us.

...by fax

Fill out the registration card and fax it to ButtonWare at 206-454-1838.

...by phone

Call 1-800-JBUTTON (1-800-528-8866) or 206-454-0479.

Related Topics...

Checking the Contents of Your Package 

Requesting Customer Service 



Converting from TakeNote 1.0
Because buttonFile and TakeNote use different file formats and file names, they can coexist on your 
system. With a minimal conversion, deck files can be exchanged between both programs.

Converting TakeNote decks to   button  File decks   
Converting   button  File decks to TakeNote decks   



Converting TakeNote Decks to buttonFile decks
To convert a TakeNote deck to a buttonFile deck

1. Choose Open from the File menu.

The Open dialog box displays.

2. Choose TakeNote (TN) from the List Files of Type list box.

Any TakeNote deck files in the current directory are shown in the File Name list 
box. If necessary, change drives or directories using the Drives and/or Directories
list boxes.

3. Choose a TakeNote deck from the File Name list box.

A new buttonFile deck containing all of the TakeNote deck's information is created--the 
original TakeNote deck is unchanged. Use the Save option on the File menu to save the 
new buttonFile deck.

Related Topics...

Converting   button  File decks to TakeNote decks   



Converting buttonFile decks to TakeNote decks
To convert a buttonFile deck to a TakeNote deck 

1. Choose Open from the File menu.

The Open dialog box displays.

2. Choose the buttonFile deck you want to convert from the File Name list box.

3. Choose Save As from the File menu.

The Save As dialog box displays.

4. Choose TakeNote (TN) from the List File of Type list box.

5. Type the name for the converted deck in the File Name text box.

6. Choose OK.

A copy of the buttonFile deck is saved as a TakeNote deck under the name entered in 
step 5.

Related Topics...
Converting TakeNote decks to   button  File decks   





Starting and Exiting buttonFile
Starting   button  File   

Exiting   button  File   



Starting buttonFile
You can start buttonFile three different ways:

Starting buttonFile from the Program Manager
1. Open the buttonFile group window.

2. Double-click on the  icon.

Starting buttonFile from the File Manager
1. Go to the subdirectory window where buttonFile is installed. If you accepted the 

default when installing buttonFile, this will be the \BUTNFILE subdirectory.

2. Double-click on the BUTNFILE.EXE file name.

Starting buttonFile from the DOS prompt
1. Type: cd \butnfile 

2. Press .
3. Type: win butnfile.exe

4. Press .

This assumes that buttonFile is installed in the \BUTNFILE subdirectory. If you installed 
buttonFile in another subdirectory, substitute that sub directory's name.

Or...

If buttonFile is installed in a subdirectory that is part of the DOS PATH= statement in your 
AUTOEXEC.BAT file, you can start buttonFile from the DOS prompt by indicating the full 
path name. (Refer to your DOS manual for information on the AUTOEXEC.BAT file and 
the DOS PATH= statement.)

1. Type: win c:\butnfile\butnfile.exe

2. Press .

Related Topics...

Exiting   button  File   

Working With Application Windows 



Exiting buttonFile
To exit buttonFile

Double-click on the Control Menu button in the upper left corner of buttonFile's main application 
window. 

 

Choose Exit from buttonFile's File menu. 
Or...

Press 

 + 

. 

buttonFile remembers which files you have open when you exit the program. This way, you can start 
buttonFile and have files ready to use without using the Open option on the File menu. 

Related Topics...

Closing All Windows And Icons 

Closing Windows 

Opening a Deck 

Starting   button  File   



Edit Menu Options
You can cut, copy, and paste data a number of different ways when using buttonFile. In all cases, you
must first select the information you want to copy, and then either cut or copy it to the Windows 
clipboard. Once the information is on the clipboard, you can paste it to other cards, decks, or 
applications.

buttonFile lets you select text to copy in the standard Windows fashion: 

By clicking to place the cursor and then holding and dragging. 

By placing the cursor with the arrow keys and then holding down 

 and using the 

 keys or other navigation keys to highlight the desired area. 

Once you have selected the information, you can choose the Cut or Copy from the Edit menu, or use 
the appropriate accelerator keys.

buttonFile also provides additional selection methods for situations where you want to copy more than
one thing (data from several data boxes, or several frames when designing decks or reports) using 
either the mouse or the keyboard. buttonFile lets you select multiple data using one of two methods: 
group selection or item selection. These methods work when editing data in cards, and also when 
designing new decks and reports.

GO TO:
Group Selection 

Item Selection 

Related Topics...

Working With Frames 

Using the Edit Menu 



Group Selection
Selecting a Group

Group selection with a selection frame lets you choose multiple data much like a paint or drawing 
program by dragging a box around the desired items. Clicking and holding just outside of a data box or 
frame anchors the corner of the selection frame . When you release the mouse, all the enclosed fields will
display in inverse color to indicate they are selected.

Or...

Alternatively, you can select a group of items by holding down 

 and clicking on the item in one corner and then clicking on the item diagonally opposite the first item
that will enclose all desired items.

You can also select a group using only the keyboard by moving to a corner item and pressing 

 to toggle group selection on which will highlight that item. Using any navigation keys (

, 

, 

) highlights and selects additional items.

Related Topics...
Item Selection 

Working With Frames 

Using the Edit Menu 



Item Selection
Item selection lets you choose multiple items from any location on a card or report form. 

Selecting an Item

Hold down 

 and then click on each item you want to select with the mouse cursor.

You can select a group using only the keyboard by moving to an item and pressing 

 + 

 to toggle item selection on which will highlight that item. Using any navigation key (

, 

, 

, etc.) moves to additional items, then pressing 

 adds the current item to the selection.

Related Topics...
Group Selection 

Working With Frames 

Using the Edit Menu 



Working with Application Windows
Opening   button  File Windows   

Making Windows Active 

Closing Windows 

Moving Windows 

Resizing Windows 

Maximizing A Window 

Minimizing A Window 

Restoring A Window Or Icon 

Tiling Windows 

Cascading Windows 

Arranging Icons 

Closing All Windows And Icons 

Customizing The Work Area For Daily Use 



Opening buttonFile Windows
You can open as many windows within buttonFile's work space as you want within the limits of 
available memory.

Opening a deck window
1. Choose Open from the File menu.

2. Choose a file from the Files list box.

3. Repeat for each deck you want open in buttonFile's work space.

If you are using Window 3.1, you can also open decks by dragging and dropping from the File 
Manager.

Opening a deck window by dragging and dropping
1. Open a directory window in the File Manager (refer to your Windows 

documentation for details).

2. Click and hold on a deck file name (this will be a file with a .BTN extension).

3. Drag the file over the buttonFile application window, or minimized icon.

4. Release the mouse button.

The deck file is opened in buttonFile's workspace.

5. Repeat steps 2 through 4 to open additional deck windows.

Related Topics...

Closing Windows 

Making Windows Active 

Restoring A Window Or Icon 

Opening a Deck 

Designing Your Own Decks 

Introduction to Report Designing and Printing 



Making Windows Active
When a window is active, its title bar will appear colored or darker depending on your Windows color 
settings. It will be topmost in the work area if your deck windows overlap, just like group windows in 
the Windows Program Manager.

To make a window active

Click anywhere in the window. 
Or...

Press 

 + 

 until the desired window is active. 
Or...
1. Choose the Window menu.
2. Choose the desired window from the list on the bottom half of the menu. The current window will 
have a checkmark next to it.

Related Topics...

Maximizing A Window 

Opening Application Windows 

Restoring A Window Or Icon 



Closing Windows
You can close windows at any time. Each open window requires a certain amount of memory. If you 
approach the limits of your systems memory, you may have to close some windows before you can 
open any new ones.

To close a window

Double-click on the Control menu icon in the upper left corner of the window. 

 
(Dont click on the main buttonFile application window Control menu. This will close all windows 

and exit the program!) 

1. If the window you want to close isn't active, press  + 

 until it is.

2. Choose Close on the File menu. Or press  + 

 to close the window.

If you are closing a design window and you haven't saved your work, a dialog box will 
display asking you if you want to save your work before closing.

Related Topics...

Closing All Windows And Icons 

Minimizing A Window 



Moving Windows
You can move windows within buttonFile's work space at any time, using either the mouse or the 
keyboard.

To move a window

Click on the desired window's title bar and drag it to the desired location. 
Or...

1. If the desired window isn't active, press  + 

 until it is.

2. Press  + 

 to open its Control menu.
3. Choose Move.

4. Move the window outline to the desired location using the  keys.

5. Press .

Related Topics...

Arranging Icons 

Cascading Windows 

Customizing The Work Area For Daily Use 

Maximizing A Window 

Minimizing A Window 

Resizing Windows 

Restoring A Window Or Icon 

Tiling Windows 



Resizing Windows
You can resize a window at any point to make more or less of its contents visible, or to make it easier 
to work with.

To resize a window
1. Point at a window border or corner, until the cursor turns into a double-ended 

arrow. 
2. Click and drag the window outline to the desired dimensions.
3. Release the mouse button. 
Or...

1. If the desired deck window isn't active, press  + 

 until it is.

2. Press  + 

 to open its Control menu.
3. Choose Size. 

4. Change the window outline to the desired dimensions using the  keys.

5. Press .

Related Topics...

Arranging Icons 

Cascading Windows 

Customizing The Work Area For Daily Use 

Maximizing A Window 

Minimizing A Window 

Moving Windows 

Restoring A Window Or Icon 

Tiling Windows 



Maximizing a Window
You can expand a child window so that it fills the entire buttonFile work space. This is referred to as 
maximizing the window. You can also maximize the main buttonFile application window so that it fills 
your entire Windows screen.

To maximize a window

Double-click on the Maximize button in the upper right corner of the window. 

Or...

1. If the desired window isn't active, press  + 

 until it is.

2. Press  + 

 to open its Control menu.
3. Choose Maximize. 

Related Topics...

Arranging Icons 

Customizing The Work Area For Daily Use 

Making Windows Active 

Minimizing A Window 

Restoring A Window Or Icon 



Minimizing A Window
You can reduce any child window to an icon on the buttonFile work space. This is called minimizing. 
This allows you to have several windows available, without cluttering the work area with overlapping 
or hidden windows.

To minimize a window

Click on the Minimize button 

 in the upper right-hand corner of the window. 
Or...

1. If the desired window isn't active, press  + 

 until it is.

2. Press  + 

 to open its Control menu.
3. Choose Minimize. 

Arranging Icons 

Closing All Windows And Icons 

Closing Windows 

Customizing The Work Area For Daily Use 

Making Windows Active 

Maximizing A Window 

Restoring A Window Or Icon 



Restoring a Window or Icon
Restoring a window or icon returns the window to its previous state. When a child window is 
minimized, buttonFile remembers whether the window was fully maximized or, if the window was not 
maximized, the size and location of the window within the work space is remembered. Also, if a 
window is maximized, the original size and location of the window is remembered. And, if an icon is 
maximized, the location of the icon is remembered.

To restore a window icon to its original state

Double-click on the desired window's icon. 
Or... 

1. Press  + 

 until the desired window's icon is highlighted.

2. Press  + 

 to open its Control menu.
3. Choose Restore. 

To restore a maximized window to its original state

 Choose Restore from the window's Control menu.
Or...

Click on the Restore button in the upper right-hand corner of the window. 

Related Topics...
Arranging Icons 

Maximizing A Window 

Minimizing A Window 



Tiling Windows
There are two commands on the Window menu that let you tile the child windows in buttonFile's work 
space. Tiling rearranges and resizes all open windows so that they entirely fill the work space with no 
overlapping. The Tile Vertical option arranges the tiled windows vertically (top to bottom). The Tile 
Horizontal option arranges the tiled windows horizontally (right to left). If all windows are open (not 
minimized as icons), the entire work space will be filled. If any windows are minimized (icons), a 
space is left at the bottom of the work space and icons are arranged in a row in that space. All 
windows, open or minimized will be visible.

To tile windows

Choose Tile Vertical or Tile Horizontal from the Window menu.
Or...

Press 

 + 

 to tile vertically, or 

 + 

 to tile horizontally.

All open windows are tiled, and any window icons are lined up across the bottom of the 
work space.

Related Topics...
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Moving Windows 
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Cascading Windows
The Cascade option on the Window menu resizes and stacks all open windows in the work space so 
that every window's title bar is visible. Any window icons are arranged at the bottom of the work 
space. All windows, open or mimimized will be visible.

To cascade windows

Choose Cascade from the Window menu.

All open windows stack in the work space, and any window icons line up across the 
bottom of the work space.

Related Topics...

Customizing The Work Area For Daily Use 

Moving Windows 

Resizing Windows 

Restoring A Window Or Icon 

Tiling Windows 



Arranging Icons
An icon displays in buttonFile's work space when you minimize a child window. buttonFile displays a 
different icon for each window type: Deck, Deck Designer, and Report Designer. Here is an example 
of each of the three icons:

 

 

The Arrange Icons option on the Window menu lines up any window icons from left to right across the
bottom of the work space. If necessary, additional rows of icons are made above the first row. If a 
window is active when the Arrange Icons command is issued, the window remains topmost and icons 
are arranged behind it, if necessary. 

To arrange window icons

Choose Arrange Icons from the Window menu.

All window icons line up across the bottom of the work space, additional rows are made 
above the first row, if necessary.

Related Topics...

Customizing The Work Area For Daily Use 

Minimizing A Window 



Closing All Windows and Icons
The Close All option on the Window menu closes all open windows and icons. You will be prompted to
save any unsaved work.

To close all windows and window icons
1. Choose Close All from the Window menu.

2. Answer the prompt to save any unsaved work, if necessary.

All windows and icons are closed.

Related Topics...
Closing Windows 

Opening Application Windows 



Customizing the Work Area for Daily Use
When you exit buttonFile the size and location of any open deck windows are memorized. Also, the 
names of any deck icons are stored. The next time you start buttonFile, all previously open deck 
windows are restored to their original locations, and any deck icons are placed in a row at the bottom 
of the work space. This feature lets you store your work space organization. Before closing buttonFile,
use any of the options listed below to organize your work space. Then the next time you start 
buttonFile, all the decks you were previously working with will be ready to use.

Related Topics...

Arranging Icons 

Cascading Windows 

Maximizing A Window 

Minimizing A Window 

Moving Windows 

Resizing Windows 

Restoring A Window Or Icon 

Tiling Windows 





Creating Decks with Templates
Creating decks with templates is simple! Choose the template you want and you're ready to add data!
buttonFile comes supplied with pre-defined templates for a wide variety of applications, so this may 
be the only method you ever need to use.

buttonFile comes supplied with a large variety of templates set up for typical applications. There are 
several different formats for name, address and phone number information. Plus, there are templates 
for keeping track of your video, music and book collections, home inventory, recipes, and more. 
buttonFile also includes some generic templates that can be used with any data.

Be sure you take a look at the template definitions    before you add a lot of data to a new deck--make 
sure that the template you choose will fit your needs. While there are methods to transfer the data 
from one template type to another, it is much simpler to choose the appropriate template from the 
start.

Creating a deck using a template

1. Choose New from the File menu, or click  on the button bar.
The New Card Deck dialog box displays.

2. Select the desired template from the Template list box.
3. Choose OK. 

The new deck displays in the work space ready for you to add data. The deck has not 
been named and saved at this point. You will be prompted to name and save the deck 
when you close it. Or, you can save the deck before adding information. 

Related Topics...
Saving A Deck 

Template Definitions 



Saving A Deck
Saving in buttonFile performs essentially the same function as saving a word processor document--
the current state of your deck or deck design is saved to the filename you provide. At a minimum, you 
should save the deck as soon as you are finished creating it. But you can save your deck at any point 
during the deck design process. After the first time you save your deck in a design session, each time 
you use Save, it writes to the filename you provided the first time, updating that file. It is a good idea 
to save regularly during a design session.

If you add or modify a card, buttonFile automatically saves the new information when you move to 
another card. You can make sure your data is saved without moving to another card using the Save 
option on the File menu.

Saving a deck
1. Make sure the deck window you want to save is active.

2. Choose Save from the File menu, press + 

Or...

Click on  on the button bar.
Or...

Press  + 

The Save As dialog box displays.
3. Type a name into the File Name text box. Change directories and/or drives using the Directories 
and Drives list boxes, if desired.
4. Choose OK.

Once the deck has been saved, you can use the Save As option on the File menu to save a copy of 
the deck to a new file name.

Saving a copy of a deck to a different name
1. Make sure the design window you want to save is active.

2. Choose Save As from the File menu.

The Save As dialog box displays.

3. Type a name into the File Name text box. Change directories and/or drives using 
the Directories and Drives list boxes, if desired.

4. Choose OK.

Related Topics...

Closing the deck designer 

Exporting 

Resolving duplicate data box names 

Resolving overlapping elements 



Designing Your Own Decks
Introduction to Designing Your Own Decks 

Designing a Deck From Scratch 

Designing a Deck by Patterning After Another Deck 

Designing a Deck by Patterning After a Template 

Sizing the Card 

Adding Card Elements 
Adding Data Boxes 

Adding Text 

Adding a Notes Box 

Modifying Element Attributes 
Modifying a Data Box Name 

Controlling Whether a Data Box Name Shows 

Modifying the Data Box Length 

Making a Data Box Available to the Phone Dialer 

Modifying Text 

Modifying Text Alignment 

Modifying a Notes Box Name 

Controlling Whether a Note Box Name Shows 



Introduction To Designing Your Own Decks
buttonFile also lets you design your own decks to fit specific applications. You can specify the overall 
dimensions of a card, the names and sizes of the deck's data boxes and how they are laid out. You 
can also configure what colors and fonts will be used for the deck.

You can either design a deck from scratch or pattern your new deck after the layout of a either a 
buttonFile template or a previously created deck. Designing from scratch lets you specify each 
element of the deck from the ground up. Patterning after lets you start with another deck or template's
layout that is close to what you want. Then you can    add, delete, or rearrange the data boxes to meet
your needs.

Related Topics...

Designing a Deck From Scratch 

Designing a Deck by Patterning After Another Deck 

Designing a Deck by Patterning After a Template 



Designing a Deck From Scratch
To begin designing a deck from scratch

1. Choose New from the File menu, or click  on the button bar.
The New Card Deck dialog box displays.

2. Pull down the Source list box. 
3. Select Design Deck From Scratch.
4. Choose OK.

The deck designer window displays with a blank card.

Related Topics...

Adding Card Elements 



Designing a Deck by Patterning After Another Deck
To begin designing a deck patterned after another deck

1. Choose New from the File menu, or click  on the button bar.
The New Card Deck dialog box    displays.

2. Pull down the Source list box.
3. Select Design Deck Patterned After Deck
4. Choose OK.
5. Select a deck to pattern after from the File Name list box
6. Choose OK.

The deck designer window displays with the same layout as the deck selected in step 5.

Related Topics...

Adding Card Elements 

Modifying Element Attributes 

Working With Frames 



Designing a Deck by Patterning After a Template
To begin designing a deck patterned after a template

1. Choose New from the File menu, or click  on the button bar.
2. Pull down the Source list box.
3. Select Design Deck Patterned After Template.
4. Select the template to pattern after from the Template list box.
5. Choose OK.

The deck designer window displays with the same layout as the template selected in step
4.

Related Topics...

Adding Card Elements 

Modifying Element Attributes 

Working With Frames 



Sizing the Card
The right and bottom sides of the card border are resizeable up to the limits of the size of the deck 
designer child window. You may need to resize both the main buttonFile application window and the 
deck designer window before you can resize the card to the desired dimensions. If the button bar is 
active, the dimensions of the card are displayed when the card border is selected. You can resize the 
card at any point during the deck design process.

To size the card

Click any where on the right or bottom sides of the cards border and drag to the desired size. 

If the card border isn't currently selected, press  until it is.

Hold down the  key.

Use the  keys to resize the card border.



Adding Card Elements
After you have sized the card, you can start adding the three card elements 

Data Boxes

Text

Notes boxes
Add card elements using the buttons on the button bar or the options on the Tools menu. When a 
card element is first added, and when it is subsequently selected, it is displayed in a resizeable, 
movable frame . Once an element is selected (has a frame around it) it can be moved and resized 
using the mouse, or with menu options or accelerator keys when using the keyboard. Also, you can 
copy & paste single elements or groups of elements using the Edit menu options.

Go to...

Adding Data Boxes 

Adding Text 

Adding a Notes Box 

Working With Frames 



Adding Data Boxes
Each time you add a data box its frame initially displays in the upper left corner of the card. Then you 
can move the data box to the desired location and resize it.

Adding a data box

Click on the 

 button on the button bar.

Choose Add Data Box from the Tools menu. Or...

Press 

+ 

.

Related Topics...
Controlling Whether a Data Box Name Shows 

Making a Data Box Available to the Phone Dialer 

Modifying a Data Box Length 

Modifying a Data Box Name 

Moving Elements 

Resizing Elements 

Working With Frames 



Modifying Element Attributes
After you add a card element , or whenever you select it, you can specify its attributes using the 
options on the button bar, or you can use the attributes dialog.

Using the button bar
1. Choose the element's attribute on the button bar you want to modify.

2. Make your modifications.

3. Press , or choose another option.

Using the Attributes dialog
Double-click on the element.

Or...

Select the element, and press 

 or choose Set Attributes on the Tools menu.
The Attributes dialog box specific to the current element displays.

1. Make your modifications.

2. Choose OK.

You can use either method to modify an element's attributes at any time during the deck designing 
process.

Related Topics...

Configuring Deck Fonts 

Controlling Whether a Data Box Name Shows 

Making a Data Box Available to the Phone Dialer 

Modifying a Data Box Length 

Modifying a Data Box Name 

Modifying a Notes Box Name 

Modifying Text Alignment 

Modifying Text 



Modifying a Data Box Name
Using the button bar

1. Select the data box.

2. Click in the Name text box on the button bar, or press  + 

 to move the cursor into the Name text box.
3. Type or edit the data box name . 

Using the Attributes dialog

1. Double-click on the data box, or press  or

 until the desired box is selected and press

. 
The Data Box Attributes dialog box displays.

2. Type or edit the data box name in the Name text box.
3. Choose OK.

Related Topics...

Configuring Deck Fonts 

Controlling Whether a Data Box Name Shows 



Controlling Whether a Data Box Name Shows
You can specify whether to show a data box's name on the card you are designing. The default is to 
show the name. If you don't show the name, the data will still be accessible for printing, searching, 
sorting and other operations, using the name stored internally.

Using the button bar
1. Select the data box.

2. Select the Show Name check box on the button bar to show the name, or clear 

the Show Name check box to not show the name. Or, press +

 to toggle the Show Name check box on and off.

Using the Attributes dialog

1. Double-click on the data box, or press  until the desired box is selected and 
press 

. 
The Data Box Attributes dialog box displays.

2. Select the Show Name check box to show the name, or clear the Show Name check box to hide 
the name.
3. Choose OK.

Related Topics...

Adding Text 



Modifying the Data Box Length
You can specify the data box length using the Length text box on the button bar or Data Box 
Attributes dialog box.

Using the button bar
1. Select the data box.

2. Click in the Length spin box on the button bar, or press +

.
3. Type or edit the number in the Length spin box on the button bar. 

Using the Attributes dialog

1. Double-click on the data box, or press  or 

 until the desired box is selected and press 

. 
The Data Box Attributes dialog box displays.

2. Type or edit the number of stored characters in the Length spin box.
3. Choose OK.

You can adjust the display width of the data box by selecting and adjusting the frame. The number of 
characters that fit in the displayed area of a data box varies depending on the font and size of the 
data font . 

Related Topics...

Configuring Deck Fonts 

Resizing Elements 



Making a Data Box Available to the Phone Dialer
If you have a compatible modem for your computer and you have properly configured buttonFile, you 
can use phone number data from data boxes to dial the phone for you. During either the deck design 
process or when redefining, you need to mark the data box's "Phone" check box. This tells 
buttonFile's phone dialer that the data contained in the box is a phone number.

When designing or redefining a deck, use the following procedures to mark a data box for use with 
the phone dialer:

Using the button bar
1. Select the data box.

2. Select the Phone check box on the button bar, or press  + 

 to toggle the Phone check box on and off.

Using the Attributes dialog

1. Double-click on the data box, or press  or 

 until the desired box is selected and press 

.
The Data Box Attributes dialog box displays.

2. Select Phone on the Data Box Attributes dialog box.
3. Choose OK.

Repeat these steps if you need to remove the Phone attribute.

Related Topics...

Configuring the Phone Dialer 



Adding Text in the Deck Designer
buttonFile lets you add text boxes for labels and other card text.

 To add text

Click 

 on the button bar. 

Choose Add Text from the Tools menu. 
Or...

Press 

 + 

.

A frame with Sample Text initially displays in the upper left corner of the card.

Related Topics...

Configuring Deck Fonts 

Modifying Text Alignment 

Modifying Text 

Moving Elements 

Resizing Elements 

Working With Frames 



Modifying Text in the Deck Designer
Whenever a text frame is selected you can edit its contents using the Text text box on the button bar 
or on the Text Attributes dialog box. Each text frame can hold up to 64 characters. You may need to 
resize the text frame to be able to display the entire string of text. Resizing the text frame either 
truncates or wraps the text depending on the dimensions of the frame and the text font and point 
size . 

Using the button bar
1. Select the text frame. 

2. Click in the Text text box on the button bar, or press  + 

 to move the cursor into the Text text box.

2. Edit the text and press .

The contents of the text frame are updated as you edit. If necessary, resize the frame to 
properly display your text.

Using the Attributes dialog

1. Double-click on the text frame, or press  or 

 until the desired text is selected and press 

. 
The Text Attributes dialog box displays.

2. Enter and edit the text using the Text text box.
3. Choose OK.

The contents of the text frame are updated. If necessary, resize the frame to properly 
display your text.

Related Topics...

Configuring Deck Fonts 

Modifying Text Alignment 

Moving Elements 

Resizing Elements 

Working With Frames 



Modifying Text Alignment in the Deck Designer
Text can be left aligned, centered, or right aligned. buttonFile defaults to displaying text as left aligned.
Use the buttons on the button bar, or the option buttons on the Text Attributes dialog box to specify 
text alignment.

Using the button bar
1. Select the text box.

2. Click on , 

. or 

 on the button bar, or press 

 + 

 to cycle through the three alignment options.

Your alignment choice is reflected in the text frame.

Using the button bar

1. Double-click on the text, or press  or 

 until the desired text is selected, and press 

. 
The Text Attributes dialog box displays.

2. Choose the desired alignment option button.
3. Choose OK.

Your alignment choice is reflected in the text frame.

Related Topics...
Moving Elements 

Resizing Elements 

Working With Frames 



Adding a Notes Box in the Deck Designer
A card can have only one Notes box .

To add a notes box

Click on the 

 button on the button bar.

Choose Add Notes Box from the Tools menu.
Or...

Press 

 + 

.

A Notes box appears in the upper left corner of the deck designer.

After you add a Notes box, the Notes box button and the Add Notes Box option on the Tools menu are
no longer available, because buttonFile only allows a deck to have one Notes box.

Related Topics...
Configuring Deck Fonts 

Controlling Whether a Note Box Name Shows 

Modifying a Notes Box Name 

Moving Elements 

Resizing Elements 

Working With Frames 



Modifying a Notes Box Name
You can use up to 16 characters and spaces in a Notes box name. buttonFile automatically assigns 
an arbitrary name, like Name_9, depending on the order you defined any additional data boxes. The 
text of this arbitrary name is automatically selected when you first add the box so you can 
immediately type in your own name to replace the arbitrary name.    You can edit a Notes box name at
any point until you close the Deck designer window.

Using the button bar
1. Select the notes box.

2. Click in the Name text box on the button bar, or press +

 to move the cursor into the Name text box.
3. Type or edit the notes box name. 

Using the Attributes dialog

1. Double-click on the notes box, or press  or 

 until the desired box is selected and press

. 
The Notes Box Attributes dialog box displays.

2. Type or edit the notes box name in the Name text box.
3. Choose OK.

Related Topics...

Configuring Deck Fonts 

Controlling Whether a Note Box Name Shows 



Controlling Whether a Notes Box Name Shows
You can choose whether to show a Notes box name . The default is to show the name.

Using the button bar
1. Select the Notes box.

2. Select the Show Name check box on the button bar to show the name, or clear 
the Show Name check box to hide the name. 

Using the Attributes dialog

1. Double-click on the Notes box, or press  or 

 until the desired box is selected and press 

.
The Notes Box Attributes dialog box displays.

2. Select the Show Name check box on the button bar to show the name, or clear the Show Name 
check box to hide the name.
3. Choose OK.

Related Topics...
Adding Text 



Working With Frames in the Designers
Identifying What is Selected 

Selecting Single Elements 

Resizing Elements 

Selecting Multiple Elements 

Group Selection 

Item Selection 

Moving Elements 

Cutting Elements 

Copying Elements 

Pasting Elements 

Deleting Elements 



Identifying What is Selected in the Designers
Here's what the deck designer window looks like with one of each card element added:

Here's what a report designer window looks like with one of each frame type added:

When resizing and specifying attributes, only one element can be selected at a time. When moving 
and performing Edit menu operations, you can select one or more card elements as described in 
Selecting Multiple Elements 

Related Topics...

Selecting Multiple Elements 



Selecting Single Elements 



Selecting Single Elements in the Designer Windows
When using the mouse, select single elements by clicking on the desired element. When using the 

keyboard, press  or 

 to move the selection between all the card elements and border of the card itself.

 To select a single element

Click on the desired element.
A frame displays around the selected element.

Press 

 or 

 until a frame displays around the desired element.

A frame moves between elements in the order they were added to the card or report. If 
you are designing a deck, the selection moves to the card border after all elements have 
been accessed.

Related Topics...

Identifying What is Selected 

Modifying Element Attributes 

Resizing Elements 

Selecting Multiple Elements 



Resizing Elements

You can resize individually selected elements using the mouse or by holding down the  key and 
using the 

 keys. 
For cards, this only determines the display length of a data box, but does not affect the data storage 
length set when determining the data box's attributes.
For reports, the dimensions of a frame affects how the text or data it contains is printed. By default, data 
box frames are initially sized to print the maximum stored data length based on the average character 
width of the current font. Making a frame two or more lines tall, will cause the data or text to wrap to 
additional lines at the current width. If a frame is not tall or wide enough to print all of the text or data, 
some or all of the printed text will be truncated (chopped off).

To resize a frame

1. Click on the element to select it.

2. Point at the frame border.

The cursor changes into a double-ended arrow.

3. Hold down the left mouse button and drag the frame to the desired size.

4. Release the mouse button.

1. Press  or 

 until the desired element is selected.

2. Hold down the  key.

3. Use the  keys to resize the frame to the desired size.

4. Release the  key.

Related Topics...

Selecting Single Elements 



Selecting Multiple Elements in Designer Windows
For the purposes of moving and Edit menu operations (cut, copy, paste , and delete), buttonFile lets 
you select more than one card element at a time. And in the Report Designer, you can also select 
multiple elements to set frame styles and alignments. You cannot resize or specify element attributes 
on multi-selected frames in the deck designer.

buttonFile lets you multi-select elements two ways: group selection and item selection. You can 
perform either operation using either the mouse or keyboard.

Go to...

Group Selection 
Item Selection 



Group Selection in the Designer Windows
Make a group selection with the mouse by either dragging a selection frame around the elements to 
you want to select, or by shift-clicking on the beginning and end elements of the group you want to 
select. 

To perform a group selection
Using a selection frame 

1. Click and hold on a point outside the elements you want to select.

2. Drag the outline of the selection frame until it touches the border of the group of 
elements you want to select.

3. Release the mouse button.

Each element in the selected group displays a bold outline.

Shift-clicking 

1. Hold down the  key.
2. Click on the first element you want to select.
3. Click on the last element you want to select.

4. Release the  key.

Each element in the selected group displays a bold outline.

NOTE: This method is not strictly equivalent to using a selection frame. The elements 
included in the selected group are based on the order the selection moves when pressing

the  key. 

1. Navigate to the first element you want to select using  or 

.

2. Press .
If you have the button bar active, GROUP displays on the button bar indicating group selection 

mode is active. The element selected in step 1 is now the anchor point of the selection.

3. Navigate using  or 

 or 

 to select additional elements. Each element displays a bold outline as it is added to the group.

4. When all the elements you want in the group are selected, press  or 

.

Related Topics...
Item Selection 

Moving Elements 

Selecting Single Elements 



Item Selection in Designer Windows
Unlike group selection, selected elements dont have to be next to each other when performing item 
selection. You can use item selection in conjunction with group selection, for example, you can select 
adjacent elements with group selection, and then add or remove elements using item selection.

To select individual elements

Make a item selection with the mouse by holding down the  key and clicking on each element you 
want to include in the group. Control-clicking a second time on a selected element de-selects that 
element.

1. Hold down the  key.
2. Click on each element you want select.

A bold outline displays around each element when you select it.

NOTE: If you accidentally select an element, hold down  and click the element a 
second time to "de-select" it.

Make a item selection with the keyboard by pressing  + 

 and navigating to each element you want to select and pressing 

.

1. Navigate to the first element you want to select with  or 

.

2. Press  + 

.
The first element displays a bold outline to indicate it is selected, and ITEM displays on the button

bar.
3. Navigate to an element you want to add to the selection. (The current element will have a dotted 
line within the element.)

4. Press  to select the current element. Press 

 again, to de-select the current element.
5. Repeat steps 3 and 4 for each element you want to select.

6. When all the elements you want in the group are selected, press  + 

.

Related Topics...

Group Selection 

Moving Elements 

Selecting Single Elements 



Moving Elements in the Designer Windows
To move elements

1. Point at the element you want to move. To move multiple elements, select them 
first using one of the methods described in Selecting Single Elements or 
Selecting Multiple Elements ..

The cursor changes into a hand: 
2. Click and drag the element(s) to the desired location.
3. Release the mouse button to place the element(s).

1. Press  or 

 until the element is selected. If moving multiple elements, select them first using one of the methods
described in Selecting Multiple Elements.

2. Use the  keys to move the element(s) to the desired location.

Related Topics...

Copying Elements 

Cutting Elements 

Pasting Elements 



Cutting Elements
Cutting elements copies the selected element(s) to the clipboard and deletes the selected elements 
from their current location. If you are designing a deck, you can then paste the copied information to a
different Deck designer window or back into the original Deck designer window. If you are designing a
report, you can paste the copied information to a different report designer window or back into the 
original window.

Cutting elements
1. Select the element(s) to cut as described in Selecting Single Elements or 

Selecting Multiple Elements ..

2. Choose Cut from the Edit menu, or press  + 

.

You can now paste the information using the Paste option on the Edit menu.

Related Topics...

Group Selection 

Item Selection 

Pasting Elements 

Selecting Single Elements 



Copying Elements
Copying elements copies the selected element(s) to the clipboard without affecting the selected 
elements. If you are designing a deck, you can then paste the copied elements back to the same 
Deck designer window, or into another deck designer window. If you are designing a report, you can 
paste the copied information back to the same report designer window, or into another report designer
window.

Copying elements
1. Select the element(s) as described in Selecting Single Elements or Selecting 

Multiple Elements .

2. Choose Copy from the Edit menu, or press  + 

.

You can now paste the copied information using Paste on the Edit menu. 

Related Topics...

Cutting Elements 

Pasting Elements 



Pasting Elements
Pasting can only be performed after either cutting or copying. The Paste menu option will be 
unavailable, if nothing is currently on the clipboard . If you are designing a deck, you can paste cut or 
copied elements back into the same Deck designer window, or into another Deck designer window. If 
you are designing a report, you can paste cut or copied frames back into the same report designer 
window, or into another report designer window. You cannot paste copied card or report elements into
other areas of buttonFile or other Windows applications. 

Pasting within the same deck designer window
1. Cut or Copy elements as described in Cutting Elements or Copying Elements.

2. Choose Paste from the Edit menu, or press  + 

.
The pasted elements are displayed in the upper left corner of the designer window. 

3. Move the pasted elements to the desired location by dragging them with the mouse, or using the

 keys.

Pasting into a different designer window
1. Cut or Copy elements as described in Cutting Elements or Copying Elements.

2. Open or switch to another designer window of the same type (deck or report).

3. Choose Paste from the Edit menu, or press  + 

.
The pasted elements are displayed in the upper left corner of the designer window. 

4. Move the pasted elements to the desired location by dragging them with the mouse, or using the

 keys.

All element attributes are copied from the original element. When you save the newly designed deck, 
each data box must be named uniquely. When copying data boxes within the same card, you can 
give the copied data boxes new names yourself, or let buttonFile automatically rename them when 
you save the deck.

Related Topics...

Group Selection 

Item Selection 

Selecting Single Elements 



Deleting Elements 
Deleting elements

1. Select the element(s) to delete as described in Selecting Single Elements or 
Selecting Multiple Elements .

2. Choose Delete from the Edit menu, or press .

Related Topics...

Copying Elements 

Cutting Elements 



Configuring Decks
These options are available both when you are defining the deck and at most times afterwards: 

Configuring Deck Fonts 

Configuring Deck Colors 

Configuring the Phone Dialer 

Configuring the Index 

Configuring Deck Security 

Configuring a Deck Description 

Turning the Button Bar On and Off 

Configuring Enter to Work Like Tab 



Configuring Deck Fonts
buttonFile lets you configure what fonts and point sizes are used for the card text and data. buttonFile
defaults to using Arial if you are running under Windows 3.1 with TrueType fonts active, or Helv/MS 
San Serif, if you are running under Windows 3.0 or have TrueType fonts disabled under Windows 
3.1 .

Choosing certain fonts and point sizes may require you to resize card elements to properly display the
text or data. Also, if you are planning on sharing your deck with others or using your deck on more 
than one computer, you should be aware that the fonts on your system may not be available on 
another system. If Windows cannot find a matching font, it will provide the closest match it can find. 
However, there is no guarantee that the font Windows provides will display properly--you may need to
resize the card elements or choose a different font or point size. 

Choosing Fonts on the Configure menu displays a submenu to the right of the main menu. buttonFile 
gives you independent control over the screen fonts for the following card elements:

Data Font 

Name Font 

Text Font 

Index Font 

The window that is active    when you invoke one of the submenu options is affected by the font 
choices you make--this can be either a Deck Designer window, a Report Designer window, or a Deck 
window. 

Choosing any one of the submenu options displays a font configuration dialog box. The Font dialog 
box provides control over the font, font style , and font size .

Configuring deck fonts
1. Choose Fonts from the Configure menu.

A submenu displays to the right of the Fonts option.

2. Choose the desired submenu option: Deck Font, Name Font, Text Font, or Index 
Font.

The appropriate Font dialog box displays.

3. Scroll through the Font list box and choose the desired font.

4. Choose the desired style from the Font Style list box.

5. Scroll through the Size list and choose the desired size.

Each change you make is reflected in the Sample area.

6. Choose OK, when the Sample text meets your requirements.

Related Topics...

Configuring Deck Colors 

Redefining Decks 

Resizing Elements 



Configuring Deck Colors
buttonFile lets you configure what colors are used for various card elements. The Colors option on the
Configure menu gives you control over the colors for the following card elements:

The window that is active when you invoke the Deck Colors dialog is affected by the color choices 
you make. This can be either a Deck Designer window or a Deck window. 

Configuring deck colors

1. Make sure the window you want affected is active.

2. Choose Colors from the Configure menu.

3. Select the card element from the Card Element list, or click on the area of the 
Sample card.

4. Click on the desired color on the Basic Colors grid.

Your color selection is reflected on the Sample card.

5. Repeat steps 3 and 4 for all elements you want to configure.

6. Choose OK when you are finished configuring colors.

1. Make sure the window you want affected is active.

2. Choose Colors from the Configure menu.

3. Select the card element from the Card Element list.

4. Press  to move to the Basic Colors grid.

5. Use the  keys to move the bold outline to the desired color in the Basic Colors grid.
Your color selection is reflected in the Sample card.

6. To configure another Card element, press  or 

 to move back to the Card Element list.
7. Repeat steps 3 through 6 for all elements you want to configure.
8. Choose OK when you are finished choosing colors.

You can use the Use Windows Control Panel Colors check box on the Colors dialog box to make your
deck colors match the settings used for Windows. By default, the Use Windows Control Panel Color 
check box is on. The card elements are assigned to your Windows colors as follows:

Name Text.....assigned to.....Window Text



Other Text.....assigned to.....Window Text

Card Background.....assigned to.....Window Background

Data Box Text.....assigned to.....Menu Text

Data Box Background.....assigned to.....Menu Bar

Index Text.....assigned to.....Button Text

Index Background.....assigned to.....Button Face

Configuring deck colors to match Windows Control Panel colors
1. Make sure the deck window you want affected is active.

2. Choose Colors from the Configure menu.

3. Select the Use Windows Control Panel Colors check box.

4. Choose OK.

Related Topics...

Redefining Decks 



Configuring the Index
The order the cards in your deck are displayed is determined by the data boxes that show in the index
line on the top row of each card. Each template is pre-defined to index certain data boxes. When you 
define your own deck, buttonFile defaults to indexing only the first data box you added to your deck 
(the data box that was initially named Name_1). However you can change which data box or boxes 
are used with the Index option on the Configure menu after you have finished defining your deck.

Choosing Index from the Configure menu displays the Change Deck Index dialog box:

The three Level list boxes show which data box is sorted for each level. In the example, the data in 
Last Name is sorted first. Then First Name's data is sorted within the Last Name grouping. Lastly, 
Middle Initial's data is sorted within the First Name grouping. As a result, Smith, Albert E. would come 
before Smith, Albert Q., followed by Smith, Balthazar B. and so on. You can sort by one, two, or all 
three data boxes.    

The Reverse Order check box following each level's list box determines whether that level will be 
sorted in forward or reverse order. For example, with the Reverse Order check box off, the data on 
that level would be sorted A to Z. With the Reverse Order check box selected, the data on that level 
would be sorted Z to A.

When indexing in default forward order, buttonFile sorts space (blank) characters first; non-alphabetic,
non-numeric characters (such as !,@,#, etc.) second; alphabetic characters (letters) third; and 
numbers last. 

Changing the deck index
1. Make sure that the deck you want to sort is active. If it is not, click on its deck 

window, or press  + 

 until it is.

2. Choose Index from the Configure menu, or press  + 

.
3. Click on the down-arrow button to display the Level 1 list box and select the data box to sort on; 

or highlight the Level 1 list and scroll through the list using the  and 

 keys until the desired data box is displayed.
4. Check Reverse Order for that level, if desired.
5. Repeat steps 3 and 4 for the two remaining levels. Choose NONE from the Level list box, if you 
dont want the deck sorted on that level. If you choose NONE for level 2, level 3 will also not be sorted. 
Level 1 must be sorted by some data box--there is no NONE option in its list box.

6. Choose OK to sort the deck.

Indexing Numbers or Dates



buttonFile performs all sorting on a character-by-character basis across the data box being sorted. 
For this reason, numbers sort as a series of characters, not as numeric values. For example, if you 
entered 6 separate cards sorted on a data box containing 1, 2, 10, 20, 100, and 200, buttonFile would
sort them in this order: 1, 10, 100, 2, 20, 200. In this case, buttonFile has essentially alphabetized the 
numbers--all entries beginning with the same digit are grouped together. 

If you want the data to sort as numeric values, first you need to determine the largest number you will 
enter. Then you need to enter your data with leading zeros or spaces so that each digit falls in a 
position in the data box corresponding to its place value. For example, if the largest number you enter
will have 3 places, every entry must have 3 digits, or a total of 3 digits and spaces. For example, if the
largest number you will ever enter will be 999, you would enter one digit entries with two leading 
zeroes or spaces: 001 or      1. Two digit entries would have one leading zero or space: 010 or    10. 
Three digit entries would have no leading zeros or spaces. 

For related reasons, to sort dates chronologically you must enter the date with the year first, followed 
by the month and then the day. Every date entry must have the same number of characters. Here's 
some examples of date formats that follow these rules (the dates in parentheses represent January 3,
1993): YYMMDD (930103), YYYYMMDD (19930103), YY/MM/DD (93/01/03), and YYYY-MM-DD 
(1993-01-03).

Related Topics...
Redefining Decks 



Configuring Deck Security
With the Add Security option on the Configure menu, you can password-protect your deck, so that 
anyone attempting to open the deck must provide a password. You also have the option to encrypt 
the data in your deck. You can add or remove either of the file security features at any time. If a deck 
has been previously password-protected, you must know the current password before you can 
remove or change it. 

WARNING: Be VERY careful with these features--if you add a password and forget it, you will not 
be able to get back into your deck. Choose a password you can easily remember, or write it down and
put it somewhere secure.

Adding file security
1. Open the desired deck, or make that deck's window active if it's already in the 

work area.

2. Choose Add Security from the Configure menu.

3. Type a password of up to 8 characters into the Password text box. Spaces are 
not allowed.

4. Check Data Encryption On, if desired.

5. Choose OK.

The Verify Password dialog box displays.

6. Type your new password into the text box to verify it.

7. Choose OK.

Removing file security
1. Open the desired deck, or make that deck's window active if its already in the 

work area.

2. Choose Remove Security from the Configure menu.

3. Type your current password into the Password text box.

4. Choose OK.

Changing a password or Adding data encryption
1. Remove your current file security as described above under Removing File 

Security.

2. Add and redefine file security features as described above under Adding File 
Security.

Related Topics...

Redefining Decks 



Configuring a Deck Description
Using the Deck Description option on the Configure menu, buttonFile lets you enter a description for 
your deck up to 30 characters long.

Adding or editing a deck description
1. Open the desired deck, or make that deck's window active if its already in the 

work area.

2. Choose Deck Description from the Configure menu.

The Change Deck Description dialog box displays. If the deck already has a 
description, it will appear highlighted in the Description text box. 

3. Type a deck description or edit the existing one.

4. Choose OK.



Turning the Button Bar On and Off
Using the Show Button bar option on the Configure menu, you can turn the button bar display on or 
off. (Note: when viewing decks, this includes the index buttons as well as the icon buttons) Choosing 
this option toggles the button bar on and off. When a checkmark is displayed next to the option on the
menu, the button bar is on, when there is no checkmark, the button bar is off. This setting affects the 
button bar display for all buttonFile window types.

Toggling the button bar display on and off
Choose Show Button bar from the Configure menu.

If the option is checked, button bar display is turned on, if the check mark is cleared, 
button bar display is turned off.

Related Topics...

Customizing the Work Area for Daily Use 



Configuring ENTER to Work Like TAB

Using the ENTER works like TAB option on the Configure menu, you can affect how the  key 
behaves when adding and editing data. This option does not affect how the 

 key works in dialog boxes or other areas of the program.

By default, this option is turned off, and you must press the  key (or use the mouse) to move 
between data boxes. Pressing the 

 key in this case does nothing. 

Toggling the ENTER works like TAB feature on and off
Choose ENTER works like TAB from the Configure menu.

If the option is now checked, ENTER works like TAB is on, if the checkmark is cleared 
ENTER works like TAB is turned off.

Related Topics...

Customizing the Work Area for Daily Use 



Resolving Overlapping Elements
buttonFile will not allow you to save a deck design if elements are overlapping. buttonFile displays the
overlapping elements in a contrasting color so you can easily identify which elements need to be 
adjusted. 

You must make sure that each element occupies its own space before you can save the design.

Go to...

Moving Elements 

Resizing Elements 

Saving a Deck 

Sizing the Card 



Resolving Duplicate Data Box Names
buttonFile also will not let you save a deck with duplicate data box names. This can occur if you 
accidentally enter the same name when placing data boxes. Duplicate names can also occur if you 
paste one or more copies of the same data box or boxes from the clipboard .

If buttonFile detects duplicate names when you try to save your deck, an error message will display. If
you choose Yes to continue, buttonFile will change any duplicate names to make them unique--you 
can change them later using the Redefine option, if you wish. If you choose No, your deck will not be 
saved and you are returned to the designer window so you can change the names yourself.

Related Topics...

Modifying a data box name 

Modifying a notes box name 

Saving a Deck 



Closing the Deck Designer
If you are finished with your design and want to start using your new deck, close the design window 
using the Close option on the File menu, or by double-clicking on the Deck design windows control-
menu box. A message displays asking you if you want to use the deck. Choosing Yes lets you start 
entering information into your new deck. Choosing No, closes the Deck designer window and returns 
you to the buttonFile work space.

NOTE: If you need to stop for a long period of time in the midst of a design session, you can save 
your design as it is. To resume designing your deck, use New from the File menu and choose Design 
Patterned After Deck from the Source list. Choose the filename you saved in your previous session to
resume designing. If you want, you can then use Save As to save the work from you new session to 
the old filename.

Closing the deck designer

1. Double-click on the Control menu icon in the upper left-hand corner of the 

window. . (Dont click on the main buttonFile application window Control 
menu. This will close all windows and exit the program!)

Or...
Choose Close from the File menu.
If you have made modifications to your deck design since the last time you save it, you will be 

asked whether you want to save it. Choose Yes to save changes. If you have not saved at all during the 
design session, the Save As dialog box will display for you to enter a file name. Type in a name and 
choose OK.

A prompt displays asking if you want to use the deck now.
2. Choose Yes to use the new deck.

The new deck is displayed ready to enter data.

1. Press +

Or...
Choose Close from the File menu.
If you have made modifications to your deck design since the last time you save it, you will be 

asked whether you want to save it. Choose Yes to save changes. If you have not saved at all during the 
design session, the Save As dialog box will display for you to enter a file name. Type in a name and 
choose OK.

A prompt displays asking if you want to use the deck now.
2. Choose Yes to use the new deck.

The new deck is displayed ready to enter data.

Related Topics...

Saving a deck 



Redefining Decks
Introduction to Redefining 

The Redefine Process 



Introduction to Redefining
The Redefine option on the File menu allows you to perform the following operations on a deck:

Resize the card

Resize card elements

Move card elements

Edit current text

Add new text

Delete current text

Edit data box and notes box names

Turn Show Name on or off

Turn Phone data flag on or off

You can't alter any other elements of the deck structure with Redefine. For example, can't add or 
delete data boxes and notes boxes with Redefine. However, you can use the two-step process 
described in Modifying the Deck Structure Using the Merge Feature to add or delete data boxes and 
notes boxes to a deck structure and transfer the original data.

Why Redefine?
The primary reasons to use the Redefine option are:

You have changed deck fonts and/or sizes 

You have changed Windows display resolutions (e.g. from standard VGA to Super VGA). 

The actions listed above can result in data or text that will not fit in the area originally defined--the 
bottom or end of the text or data will be truncated (chopped off), or the font may be too small to read.

The Redefine option allows you to resize and rearrange the card and card elements so that all of the 
new font can be displayed. Obviously there are some limits--it is possible to make a font too big to 
ever fit within a deck's design.

Truncated or hard-to-read fonts can also occur if you are using a deck on a computer other than the 
one it was originally defined on. If the fonts used to define the deck on the original computer are not 
available on the new computer, the deck fonts Windows provides buttonFile may not fit properly. In 
this case, the simplest solution may be to adjust the size of the font using the Fonts options on the 
Configure menu. But, you can also resize deck elements using Redefine to fit the new font.

As mentioned in the list above, there are other reasons to use Redefine. You may want to add, delete,
or edit card text; to edit box names; to turn the box name on or off; and to turn the phone data flag on 
or off.

Related Topics...

The Redefine Process 



The Redefine Process
Starting the redefine process

1. Open the deck, or make active the deck you want to redefine.

2. Choose Redefine from the File menu.

The Menu bar and button bar change to provide the Redefine options.

Once you have a deck open to redefine you can perform any of the following operations

Card Operations

Sizing the Card 

Data and Notes Box Operations

Moving Elements 

Resizing Elements 

Modifying a Data Box Name    

Modifying a Notes Box Name 

Controlling Whether a Data Box Name Shows 

Controlling Whether a Note Box Name Shows 

Making a Data Box Available to the Phone Dialer    

Text Operations

Adding Text 

Deleting Text Frames 

Modifying Text 

Modifying Text Alignment 

Moving Elements 

Resizing Elements 

Related Topics...

Modifying the Deck Structure Using the Merge Feature 





Opening a Deck
Opening a buttonFile deck is simply a matter of choosing the Open option of the File menu, or clicking

 on the button bar, and picking the deck file you want to open from the File Name list box. 
You can also use this same option to import (bring in) data files from other programs. See Importing and 
Exporting for details on exchanging data with other programs and file formats.

Opening a deck

1. Choose Open from the File menu, or click  on the button bar.
2. Move the highlight to the file you want to open in the File Name list. Alternatively, type the file 
name into the File Name text box.
3. Choose OK. 

Note: You must have additional disk space available when opening a deck. In general, this will be 
about 50K plus 10% of the deck file size. For example, if your deck file is 500K, you must have an 
additional 100K of available disk space to open and work with the file. This disk space is necessary 
for the filename.PRE file, which is used as a backup and work space file.

Related Topics...

button  File Program and Data Files   

Closing A Deck Window 



Deleting A Deck
There is no menu option within buttonFile for deleting decks or the reports associated with a deck. 
Delete an unwanted deck and its reports using whatever means you are most comfortable with. For 
example, you could use Windows File Manager, the DOS Shell, the DOS DEL command from the 
DOS command line, or a third-party utility.

NOTE: All of a deck's reports are stored in a file with the same name as the deck using an .REP 
extension. Deleting the .REP file deletes ALL reports at once. See Deleting a Report for details on 
how to delete individual reports.

Using Windows File Manager

1. Start the Windows File Manger by choosing  in the Program Managers Main 
group window.

2. Open the directory window where the deck you want to delete resides.
3. Select FILENAME.BTN from the directory window, where filename is the file name of the deck 
you want to delete. Select FILENAME.REP to delete all reports for the deck filename.

4. Choose Delete from the File menu, or press .
5. Confirm the deletion, if you have File Delete Confirmation turned on.

From the DOS command line

1. Choose the  icon from the Windows Program Manager, or exit Windows.

2. Type cd\butnfile and press . Type a directory name other than \butnfile if the deck you want 
to delete is in a different subdirectory.
3. Type del filename.btn where filename is the file name of the deck you want to delete. Or, type 
del filename.rep to delete all reports for the deck filename.

4. Press .



Adding Cards
When you have a deck open, adding a card is just a matter of clicking on the add button and filling in 
the blanks. If your deck is displayed in Card View , a new empty card will appear at the front of the 
deck. If your deck is displayed in Table View, a blank row displays on the first row. If your deck has a 

notes box , it will display as a button in Table View--clicking on this button, or pressing  will 
display an edit window for entering data into your notes box.

All Windows-standard text handling features, such as selecting, copying, and pasting text, are available 
when adding or editing records. Plus, buttonFile provides additional Edit menu features to allow copy and 
paste information from several data boxes at once. 

Adding a card
Choose Add from the Card menu. 

Or...

Click 

 on the Button Bar. 
Or...

Press 

 + 

.

If your deck is displayed in Card View, a new card displays at the front of the current 
deck. If your deck is displayed in Table View, a blank row displays on the top row.

Adding data to a card
1. Move the cursor to the desired data box by clicking in the box, or by pressing

 or 

.
2. Type in your information.
3. Repeat for each data box you want filled.

The information added to the new card is saved when you add another card, navigate to 
another card, or close the deck. The new card moves to the appropriate place in the 
index when it is saved. You can force buttonFile to save the last card entered by 
performing one of the actions listed under Adding a card.

Related Topics...

Using the Edit Menu 

Configuring ENTER to Work Like TAB 



Deleting And Undeleting Cards
Once you've added cards to your deck you can delete them. There will always be at least one blank 
card in a deck --you cannot delete this card. If you accidentally delete a card you can undelete it. 
However, if you delete a card in error, you must immediately undelete that card to recover it. 
buttonFile can only remember the contents of the last card you deleted. If you delete more than one 
card in a row, only the last card deleted can be restored with the Undelete command.

Deleting a card
1. Display the card to delete as the top card in Card View, or put the cursor in the 

cards line in Table View.

2. Choose Delete Card from the Card menu. 

Or... 

Click on  on the Button Bar.
Or...

Press  + 

.
A confirmation dialog box displays.

3. Choose OK to confirm deletion.

Undeleting the last card deleted
Choose Undelete from the Card menu. 
Or... 

Press 

 + 

.
The last card deleted is restored.



Duplicating Cards
Occasionally you may need to add a several cards that share some of the same information. For 
example, you may need to enter cards for several people who work for the same company. To make 
this task easier, buttonFile lets you duplicate an entire card. The Duplicate option on the Card menu 
adds a copy of the current card.

Duplicating a card
1. Add or display the card you want to duplicate.

2. Choose Duplicate from the Card menu, or press  + 

.

The duplicate card is now on the top of the deck. Make any changes desired and repeat, 
if desired.

Related Topics...

Using the Edit Menu 



Editing Cards
After you've added cards to your deck, you can update them at any time. When your deck is 
displayed in Card View , the cursor is always active in the topmost card of the deck. To edit in Card 
View, navigate to the card you want to edit and make the desired changes. When your deck is 
displayed in Table View , navigate to the card's row and edit the desired data boxes. 

To edit a card
1. In Card View: Display the card you wish to edit. In Table View: Navigate to the 

desired card's row.

2. Click in the data box you want to modify, or press  or 

 until the cursor is in the desired data box. Then add or edit your information. (NOTE: If you are in 
Table View and your deck has a notes box, it will display as a button--click the button or highlight it and 
press 

 to display an edit window to view and edit your notes box. )
3. Repeat step 2 for any additional data boxes you want to edit.

The edited information is saved when you display another card, add a new card, save the
deck, or close the deck. 

All the Windows-standard text handling features are available when editing cards. You can select, cut,
delete, copy and paste text with either the mouse or keyboard. buttonFile also has its own editing 
features that allow you to copy information from several data boxes at once.

Related Topics...

Configuring ENTER to Work Like TAB 

Navigating 

Searching For Cards 

Using the Edit Menu 



Using the Edit Menu
Operations on the Edit menu let you copy information from one or more data boxes and paste it into 
other locations via the clipboard .

Single Selection Editing 

Multi-Selection Editing 

Group Selection 

Item Selection 

Deleting Selected Information 

Pasting Multi-Selected Information 



Single Selection Editing
Single selection editing is performed in the same fashion as other Windows applications: With this 
method you can cut or copy all or a portion of the information from one data box and paste to: 

Another data box within the same card 

Another card in the same deck 

Another card in another deck

Another windows application

The process is essentially the same in all cases. Single selection editing can also be used to delete 
(clear) single-selected data.

Copying or cutting information from a data box
1. Open the deck and display the card containing the data you want to copy or cut.

2. Select the text using the standard Windows selection procedures.

3. To copy the selected text and leave it in place, choose Copy from the Edit menu, 

or press  + 

.
Or...
To delete the selected text and paste it to a new location, choose Cut from the Edit menu, or 

press  + 

.
4. Move the cursor where you want to paste the selected text. This can be within the same card, in 
another card in the same deck, or you can open a different deck and paste to one of its cards.

5. Choose Paste from the Edit menu, or press  + 

.

You can also copy data between buttonFile and any other application that can use the Windows 
clipboard.

Copying or cutting information between buttonFile and other Windows 
applications

1. Open the application and file you want to copy from.

2. Select the text you want to copy.

3. To copy the selected text and leave it in place, choose Copy from the Edit menu, 

or press  + 

.
Or...
To delete the selected text and copy it to a new location, choose Cut from the Edit menu, or press

 + 

.
4. Open the application and file you want to paste into.
5. Put the cursor where you want the text to be copied.

6. Choose Paste from the Edit menu, or press  + 

.



See your Windows documentation for more details on working with text, and to find out how to 
transfer data to and from a non-Windows application using the clipboard .

If you need to transfer data to a program that can't use the Windows clipboard, or if you want to 
transfer a large amount of data and using the clipboard is not convenient, use the Save As option of 
the File menu to save your deck to a file that can be imported by the other program. See Importing 
and Exporting for details.

Deleting (clearing) information from a data box
1. Open the deck and display the card containing the data you want to delete.

2. Select the text you want to delete from one data box.

3. Choose Clear from the Edit menu, or press .

Related Topics...

Multi-Selection Editing 

Importing 

Exporting 



Multi-Selection Editing
Multi-selection editing lets you select data from several data boxes. When multi-selecting data, you 
can only select the entire contents of each selected data box. There are two ways to multi-select 
information:    group selection and item selection . After you've selected the information you can copy 
or cut and then paste:

Into the corresponding data boxes in any deck

Into a notes box in any deck

From the data box where the cursor is currently located, skipping forward to a new data box for 
each copied data box

Into another Windows application 

You can also delete (clear) multi-selected data box information.

After you multi-select and cut or copy the desired information, move the cursor to the desired location 
and use Paste on the Edit menu to paste all of the copied information from the current cursor location 
forward. This allows you to paste into any Windows application that supports pasting text from the 
clipboard . 

If the cursor is placed into a buttonFile data box before pasting, the first copied data boxs information 
is pasted into that data box, the cursor skips to the next data box on the card and pastes the next 
copied data boxs information into that data box, and so on, until all information is pasted. If you place 
the cursor into a Notes box before pasting, all the copied information is pasted into the Notes box.

Alternatively, using Smart Paste on the Edit menu pastes the copied information into the 
corresponding data boxes in another buttonFile card. A smart paste will only copy information into 
data boxes that are named identically to the data boxes in the card you copied from. This works for all
data boxes when smart pasting within the same deck, but may only copy into some or no data boxes 
when smart pasting into another deck.

Related Topics...

Group Selection 

Item Selection 



Group Selection
There are three ways to perform a group selection : 

Using a mouse, you can anchor and drag a selection frame 

Using a mouse, you can shift-click in a data box to extend the selection from the current cursor 
location to that point

Using the keyboard, you can press 

 to toggle group selection mode on and navigate to extend the selection from the current cursor 
location

Group selection using a selection frame 

You don't have to be very accurate when selecting multiple data boxes using a selection frame--as long 
as the selection frame touches the data boxes that make up the border of the group you want to select, 
those and any others within the frame will be selected.

1. Click and hold on a point on the card outside the data boxes you want to select.

2. Drag the outline of the selection frame until it surrounds the data boxes you want 
to select.

3. Release the mouse button.

4. Choose Copy or Cut from the Edit menu, or press  + 

 or 

 + 

 to copy or cut the selected information.

Group selection by "shift-clicking" 

Alternatively or in conjunction with the above method, you can shift-click in a data box with the mouse to 
extend group selection. 
To start a shift-click group selection, click in a data box to move the cursor and anchor the selection. Then
shift-clicking in another data box, extends the selection from the anchor point to that point. 

1. Click in the first data box to anchor the selection.

The data box is highlighted and a dotted box displays within it.

2. Hold down the  key.
3. Click in another data box to extend the selection to that point. If you want, you can click in another
data box to extend or reduce the selection.

4. Release the  key.

5. Choose Copy or Cut from the Edit menu, or press  + 

 or 

 + 

 to copy or cut the selected information.

Group selection with the 

You can use the keyboard to perform group selection by navigating to the first data box you want to 



select, and then toggling group selection on. Navigating with the keyboard extends the selection from the 
current cursor location.

1. Navigate to the first data box you want to select with  , 

 , or the 

 keys.

2. Press .
The current data box is selected and ITEM displays on the button bar indicating the item selection

mode is on.

3. Navigate to extend the selection using  , 

, or the 

 keys.

4. Press  or 

 to stop selecting

5. Choose Copy or Cut from the Edit menu, or press  + 

 or 

 + 

 to copy or cut the selected information.

Related Topics...

Item Selection 



Item Selection in Deck Windows
You can use item selection alone or in conjunction with group selection: you can select a group of 
adjacent data boxes and then expand your original selection using item selection.

Item selection

Item selection is performed using the mouse by pointing at the selected data box and control-clicking .

1. Hold down the  key.
2. Click in each data box you want to select.

Control-clicking a second time in a previously selected data box removes the selection.

3. Choose Copy or Cut from the Edit menu, or press  + 

 or 

 + 

 to copy or cut the selected information.

1. Press  + 

.
ITEM displays on the button bar indicating the item selection mode is on.

2. Navigate to a data box you want to select using  , 

 , or 

 keys.

3. Press  to select that data box.
4. Repeat steps 2 and 3 to select additional data boxes.

5. Press  + 

, or 

.

6. Choose Copy or Cut from the Edit menu, or press  + 

 or 

 + 

 to copy or cut the selected information.

Related Topics...
Group Selection 



Deleting Selected Information
You can delete (clear) the information in single or multi-selected data boxes after using any selection 
method.

Deleting (clearing) selected information
1. Open the deck and display the card containing the data you want to delete.

2. Select the data boxes you want to clear.

3. Choose Clear from the Edit menu, or press .



Pasting Multi-Selected Information
After you cut or copy multi-selected information (using either Group or Item selection) to the 
clipboard , you can paste that information into another card using either the standard Paste or the 
Smart Paste options on the Edit menu.

If you choose the Paste option, each copied data box's information is pasted sequentially from the 
current cursor location forward, skipping to the next data box for each item copied. However, if you 
put the cursor in a Notes data box, all the copied data is copied into the Notes data box.

If you choose the Smart Paste option, only information from data boxes with matching names will be 
pasted. If no data box names match, nothing will be pasted.

Pasting multi-selected information sequentially from the current data box
1. Put the cursor in the first data box you want to copy into.

2. Choose Paste from the Edit menu, or press  + 

.

Note: Putting the cursor into a Notes data box in step 1 copies all the multi-selected 
information into the Notes data box.

Smart Pasting multi-selected information
1. Display the card you want to smart paste into.

2 Choose Smart Paste from the Edit menu, or press  + 

.

Only data from matching data box names is copied.

Pasting Multi-Selected Information into Another Application
When pasting multi-selected information into the applications other than buttonFile, only the Paste 
option is available. This is because the Smart Paste option uses a proprietary clipboard format that 
will only work within buttonFile. The only difference between using the Paste command with single 
selected and multi-selected information, is that multi-selected data is pasted on separate lines--i.e. 
each copied data box's information is separated by a line feed/carriage return.

Pasting multi-selected information into another Windows application
1. Open the application you want to paste into, and open a file.

2. Put the cursor where you want the text to be copied.

3. Choose Paste from the Edit menu, or press  + 

.

Each data box is pasted with a new line between it.

Pasting Information from Other Windows Applications into Multiple Data 
Boxes
You can also paste information from another application into more than one data box, if the data you 
copy from the other application is separated into multiple lines. Each copied line must be separated 

by a linefeed/carriage return--in most word processor this would be accomplished by pressing  
at the end of each line you want to copy. To paste the copied data into separate data boxes, you must
multi-select which data boxes you want to copy into before pasting. Any pre-existing data will be 
overwritten. Most typically, this procedure would be used to copy an address from a word processor 



document into a buttonFile deck.

Pasting information from other applications into multiple data boxes
1. Open the application and the file you want to copy information from.

2. Select the information you want to copy (each item must be on its own line or 
separated by line feed/carriage return).

3. Choose Copy from the Edit menu.

4. Open the buttonFile deck you want to copy into and select the card to copy into, 
or add a new card.

5. Multi-select the data boxes you want to copy into using any of the methods 
described earlier in this chapter.

6. Choose Paste from the Edit menu, or press  

.

Each line of data is copied into the selected data boxes.

Related Topics...
Importing 

Exporting 



Merging Decks
Use the Merge option on the File menu to combine the data from two or more decks into one deck. 
Merging reads all or selected card information from one deck and copies it as new cards in another 
deck.

Merging does not combine information from a card in the source deck with information from a card in 
the target deck to produce a composite card. Each card read from the source deck is added to the 
target deck as a separate new card.

Also, note that the source deck is not physically incorporated into the target deckthe source deck 
information is simply read and copied into the target deck. If you want to eliminate the source deck 
after merging, you need to delete it as described in Deleting A Deck .

Merging decks
1. Open the deck you want to merge the data into; or, if the deck is already open, 

make its window active .

2. Choose Merge from the File menu.

3. Highlight the desired source file and choose OK.

4. Map data boxes as desired. Refer to the discussions and procedures in Mapping 
Data Boxes for details.

5. Choose whether to merge all or selected cards .

6. Choose OK to start the merge process.

7. If you chose to merge all cards in step 5, the merge process starts immediately 
with an information box indicating the rate of progress. If you chose to merge 
selected cards in step 5, a search dialog box displays. Enter the appropriate 
search and choose OK. 

Related Topics...

Mapping Data Boxes 

Importing 

Merging All or Selected Cards 

Modifying a Deck Structure Using the Merge Feature 



Mapping Data Boxes
The Merge Mapping dialog box lets you map information from data boxes in the source deck into data
boxes in the target deck . Mapping determines which data boxes in the target deck will be filled with 
information from data boxes in the source deck. 

You can choose to map all information from the source deck into the target deck or only some. For 
example, you may not want to copy some information from the source deck, there may be too few 
data boxes in the target deck to contain all information, or some data box contents may not 
correspond with data boxes in the merge deck. 

Mapping one-to-one
1. Select a data box from the Map From list box.

2. Select a data box from the Map To list box. 

3. Choose the Map button.

The source deck data box name displays with a < character to pointing to the 
target deck data box it is mapped to.

4. Repeat steps 1 through 3 to map additional data boxes.

Mapping many-to-one
When performing many-to-one mapping you can choose to separate the information from
each source data box with a space, a comma, or a semicolon. If you do not choose a 
separator, all source deck information will be combined into a single string of characters. 
An example, mapping City, State, and Zip Code data boxes into a single Address data 
box with a comma following the City and a space following the State would look like this:

1. Select a data box from the Map From list box.

2. Select a data box from the Map To data box. 

3. Choose the Map button. (This maps the first source deck data box into the 
selected target deck data box.)

4. To insert a separator before the data box information that will follow, do not move 
the highlight in the Map To list box and scroll to the end of the Map From list box. 
Select      to insert a space, select , to insert a comma, or select ; to insert a 
semicolon. Choose the Map button to add the separator.    Skip this step if you do
not want a separator.

5. To add an additional data box, do not move the highlight in the Map To list box 
and select the second data box from the Map from list box. Choose the Map 
button. 

6. Repeat steps 4 and 5 to map additional separators and data boxes into the target
deck data box.

Mapping all data boxes
Choosing the Map All button simply maps each list from top to bottom. Generally, this will 
only give you the desired results if the structure of both decks matches for all data boxes. 
However, if many of the data boxes match, this may be a good way to start. After 
mapping all, you can undo only the incorrect mappings and proceed from there.

Choose Map All
All data boxes are mapped top to bottom.

Undoing Mappings
If you make an error or change your mind while mapping, you can highlight that line in the Map To list 



and choose the Remove button to undo the mapping. Choosing the Remove All button undoes all 
mappings.

Undoing a single mapping
1. Select the line in the Map To list box to undo.

2. Choose the Remove button.

Repeat steps 1 and 2 to undo additional mappings.

Undoing all mappings
Choose the Remove All button.

Related Topics...

Merging All or Selected Cards 



Merging All or Selected Cards
The Merge dialog box also provides the option to merge all or selected cards. This allows you to 
merge a subset of the source deck's cards with the target deck.

Select whether to merge all or selected cards
Choose All cards to include all cards (this is the default), or choose Selected cards to include a 

selected group of cards.

If you choose Selected cards, after you choose OK to continue the merge process a 
dialog box displays to allow to select which cards to include.

Related Topics...

Searching for Cards 

Mapping Data Boxes 



Modifying a Deck Structure Using the Merge Feature
If you have a deck and want to add or delete data boxes or notes boxes, you can use the merge 
feature in conjunction with the deck designer to modify the decks structure. In brief, you define a new 
deck patterned after the deck you want to modify, modify the new deck, then merge data from the old 
deck into the new deck.

Modifying a deck structure
1. Choose New from the File menu.

The New Card Deck dialog box    displays.

2. Select Design Deck Patterned After Deck from the Source list.

3. Choose OK.

The Open dialog box    displays.

4. Select the deck that you want to modify.

5. Choose OK.

The Deck designer window displays with the selected deck's structure.

6. Modify the deck's structure as desired. Refer to Designing Your Own Decks    for 
details.

7. When you are finished modifying the deck structure, choose Close from the File 
menu.

A prompt displays asking if you want to save the new deck.

8. Choose Yes to save the deck.

9. Enter a new file name for the deck (DO NOT save to the same name as the 
original deck!).

10. Choose OK.

A prompt displays asking if you want to use the new deck.

11. Choose Yes to use the deck.

12. Choose Merge from the File menu.

A file selection dialog box displays.

13. Choose the original deck (the one you to patterned after in step 4) and choose 
OK.

The Merge dialog box displays.

14. Map each data box appropriately.

15. Choose All cards to include all cards from the original deck, or choose Selected 
cards    to enter a search to include only selected cards.

16. Choose OK to start the merging process.

When the merging process is completed, the new deck created in steps 1 through 6 
should contain the data from the original deck. The original deck is not altered or deleted 
in this process. After you have confirmed that the process was successfully completed, 
you can delete the original deck and rename the new deck if you wish.

Related Topics...

Designing Your Own Decks 

Redefining Decks 







Switching Views
You can switch between Card View and Table View at any time.

Changing views
1. Choose Views from the menu bar.

2. Choose the desired view. A check mark is displayed to the left of the current view.

Or...

Press 

 to switch between views.

Related Topics...

Adjusting Table View Column Widths 



Adjusting Table View Column Widths
Using the mouse, you can change the display width of any column to see more or less of that 
columns information. You cannot change the column display width using the keyboard. The adjusted 
column widths are saved when you close the deck--the current column widths when you close the 
deck are restored the next time you open the deck.

Adjusting Table View column widths 

1. Move the mouse pointer over the line right side of the column you want to adjust. 
The cursor turns into a double-ended arrow.

2. Hold down the left button of the mouse and drag the line to adjust the column 
width.

3. Release the mouse button. The column is redrawn to the new dimensions. 

4. Repeat for each column you want to re-size.



Navigating in Views
Navigate through a deck using the navigation buttons and index buttons on the button bar, the options
on the Navigate submenu, or the navigation keys. 

You can navigate by:

Browsing through the deck one or more cards at a time

Browsing through the deck one windowful at a time

Jumping to the first card in a group using Index buttons
Browsing in Card View 
Browsing in Table View 
Using the Index Buttons 



Browsing in Card View
When browsing in Card View, cards display in an endless loop like a Rolodex card file--when you 
reach the last card, if you continue, the first card in the deck follows it.

There are a number of different ways to browse in Card View using either the mouse or keyboard. 
You can browse one card at a time, several cards at a time, or a windowful of cards at a time. A 
windowful of cards will vary according to the size of the deck window and the size of each card. 
buttonFile displays as many cards as will fit in the deck window.

Browsing in Card View With the Mouse
You can bring any card visible in the deck window to the front of the deck by clicking on its index line. 
The cards in front of the card you click on disappear and cards following it fill in behind. 

Clicking on the top edge of the second card moves you through the deck one card at a time. Similarly,
clicking on the third card moves you through the deck two cards at a time, and so on. Also, clicking on
the topmost card moves you through the deck one windowful of cards at a time.

You can also browse using the navigation buttons on the left end of the Button Bar. If the Button Bar is
not currently showing, choose Show Button Bar from the Configuration menu to activate it.

Browsing in Card View With the Keyboard
Browsing with the keyboard performs the same functions as browsing with the mouse, except there is
no keyboard equivalent to clicking on a card's index line .

Card View Navigating Procedures
To bring a card to the front of the deck

Click on the index line of any card visible in the deck window to bring it to the front of the deck.

To browse through the deck one card at a time

Click 

 on the Button Bar to advance one card.

Click 

 on the Button Bar to backtrack one card.

Press 

 to advance one card in the sorted order (toward Z if your deck is sorted A to Z).

Press 

 to backtrack one card in the sorted order (toward A if your deck is sorted A to Z).

To browse through the deck one windowful of cards at a time

Click 

 on the Button Bar to move one windowful of cards forward.

Click 

 on the Button Bar to move one windowful of cards backward.



Press 

 + 

 to advance one windowful of cards.

Press 

 + 

 to backtrack one windowful of cards.

To navigate to the first or last card in the deck

Press 

 + 

 to navigate to the first card in the sorted order.

Press 

 + 

 to navigate to the last card in the sorted order.

Related Topics...

Browsing in Table View 

Using the Index Buttons 

Searching for Cards 



Browsing in Table View
In Table View each card in a deck displays as a row. All the card's data boxes display left to right 
across the row in access order. Data boxes are aligned vertically with the data box name at the top of 
each column. 

Browse through Table View rows using the vertical scroll bar on the right side of the window. You can 

also perform the same actions using the navigation buttons on the Button Bar, or using the  or 

 keys.
Scroll right and left to view additional columns using the horizontal scroll bar at the bottom of a Table View

window. You can also move the current data box highlight right or left by pressing  or 

.
Browsing in Table View with the Keyboard
Browsing in Table View with the keyboard performs essentially the same functions as browsing with the 
vertical and horizontal scroll bars. However, there are two main differences when scrolling horizontally 
with the keyboard: 

Scrolling with the keyboard moves the current data box highlight right or left--scrolling with the 
mouse scrolls only the view, the data box highlight doesn't move.

The highlight wraps around when you reach either end of the row when navigating with 

 or 

.

Additionally, there is no keyboard equivalent for dragging the scroll box to move to a relative location 
within the Table View window, however there are keyboard commands to move to either end of a row,
and to the first or last row.

Table View Navigating Procedures
To scroll one row up or down

Click on the arrow buttons at either end of the vertical scroll bar, or click on 

 or 

 on the Button Bar.

Press 

 or 

.

To scroll one windowful of rows up or down

Click above or below the scroll box in the vertical scroll bar, or click on 

 or 

 on the Button Bar.

Press 



 or 

.

To scroll to the first row in the deck

Press 

 + 

.

To scroll to the last row in the deck

Press 

 + 

.

To scroll to a relative row location

Click and drag the scroll box within the vertical scroll bar. For example, to get to a row in the 
middle of the deck, drag the scroll box to the middle of the scroll bar.

To scroll one column left or right

Click on the arrow buttons at either end of the horizontal scroll bar.

Press 

 to scroll one column to the right. Press 

 to scroll one column to the left.

To scroll one windowful of columns left or right

Click to the left or right of the scroll box within the horizontal scroll bar.

To scroll to the first column in the current row

Click and drag the scroll box in the horizontal scroll bar to the left end of the scroll bar.

Press 

 + 

 + 

.

To scroll to the last column in the current row



Click and drag the scroll box in the horizontal scroll bar to the right end of the scroll bar.

Press 

 + 

.

To scroll to a relative column location

Click and drag the scroll box within the horizontal scroll bar.

Note: The currently highlighted data box does not move when scrolling with the 
horizontal scroll bar. Click in the desired data box to move the highlight after scrolling.

Related Topics...

Browsing in Card View 

Using the Index Buttons 

Searching for Cards 



Using the Index Buttons
In either Card View or Table View , you can jump to the first card of a group by clicking on the lettered 
and numbered index buttons on the Button Bar, or by using the accelerator keys.

Clicking on an index button displays the first card whose index line begins with that letter or number. If
no card for the selected letter or number exists, the first card of the next group displays. For example, 
if you click the A index button but the first card's index line begins with B, that card displays. Clicking 
the blank button at the beginning of the row of index buttons displays the first card in the deck.

Note: All index buttons may not visible if the width of the buttonFile application window is too narrow 
to display them.

To jump to the first card in a group

Click on the desired letter or number on the row of index buttons.

Press 

 + 

 + LETTER or NUMBER. For example, 

 + 

 + 

 moves to the first card in the group that begins with M. 

Note: Press  + 

 + 

 to select the blank button that jumps to the first card in the deck.

Related Topics...

Browsing in Card View 

Browsing in Table View 

Searching for Cards 



Searching for Cards
How to Search 

Entering Search Text 

Selecting a Data Box to Search In 

Selecting the Search Type 

Other Search Options 

Using an Additional Comparison 

Search Direction 

Continuing a Search 

Search Speed and the Index 



How to Search
As your deck grows, you may find it easier to locate specific cards by having buttonFile search for 
specific data. Searching also allows you to specify a subset of data to print, export , or merge .

How to search
1. Choose Find from the Search menu. 

Or...

Click  on the button bar. 
Or... 

Press  + 

.
The Find dialog box displays

2. Type your search text in the Search For text box.
3. Choose the data box(es) to search in from the Search In Data Box list box.
4. Choose the search type from the Search Type list box.
5. Choose any of the other search options as desired.
6. If you want to perform an And or an Or search, choose either the AND option button or OR option 
button from the Additional Comparisons options; and repeat steps 2 through 5 to enter your second 
comparison.
7. Choose the desired Search direction option button.
8. Choose OK to start the search.

If you are in Card View when searching, the first card found that meets your search 
criteria displays at the front of the deck. If you are in Table View when searching, that 
card's row displays. The text you searched for is highlighted. If no card is found, an 
information box will be displayed.

Related Topics...

Continuing a Search 

Search Speed and the Index 



Entering the Search Text
Type the text you want to search for in the Search For text box. You can type all or only part of the 
string of characters you want to find. How buttonFile will use the text you enter is determined by your 
choices for the other options on the Find dialog box. See Search Type    and Search Options    below 
for more details.

Wildcards
You can also type wildcard characters into your search text to indicate that any character 
will be accepted in that position. buttonFile provides two wildcard characters: the question
mark (?) and the asterisk (*).

The question mark (?) wildcard character is used to indicate any single character is 
accepted in that position. For example, if you type: t?o as your search text, cards 
containing two, too, tao, and so on, would be found. You can use more than one question 
mark wildcard in any position in the search text

The asterisk (*) wildcard character is used to indicate any group of characters is accepted
in that position. While you can use the asterisk wildcard character anywhere in a search 
string, it only really makes sense to use it at the beginning or in the midst of your search 
text. For example, if you type: *ing, cards containing data ending with ing will be found: 
changing, raining, and so on. An example using the asterisk wildcard between other 
characters in the search text: r*g would find raining, rug, rag, and so on. You can even 
use more than one asterisk wildcard if you wish: r*g*d would find ragged, rugged, raged, 
and so on.

Reusing Previous Search Text
buttonFile keeps track of the last five search entries you've made in the current session. 
Clicking on the down arrow button to the right of the Search For text box displays a list of 
the five most recent search entries. Choosing a search entry from the list lets you reuse 
it.

Related Topics...

Other Search Options 



Selecting a Data Box to Search In
The Search in Data Box list box specifies whether buttonFile will search in all data boxes or one 
particular data box. buttonFile defaults to searching in the data box that is sorted as Level 1 in the 
deck index . Clicking on the down arrow button to the right of the Search in Data Box list box pulls 
down a list that displays the names of all data boxes in the deck. 

The topmost option in the list is ALL DATA BOXES. Choosing this option causes buttonFile to look for 
the search text in every data box on the card. Use this option if you are not sure which data box 
contains the search text, or to make sure all data boxes are searched.



Selecting the Search Type
Each of the Search Type options specify how buttonFile compares the search text. 

Begins With
The Begins With search type specifies that the comparison with the search text is made 
starting from the first character in the data box. For example, if you type Al as your search
text, buttonFile might find cards with a data box that begins with Al, Albert, Albertson and 
Alvin. However, no entries that contain al within the data will be found. For example, the 
al in Calvin would not be considered a match. 

You can use as few as one character for your search. For example, entering only A finds 
any name that begins with A. Including more characters narrows the search. For 
example, if you typed Albertson, only cards containing Albertson or Albertsons will be 
found.

All of the above examples assume that the Match Whole Word Only option is turned off. 
When the Match Whole Word Only option is turned on, a Begins With search only finds 
exact matches starting from the beginning of the data box. See Search Options below for 
more details.

NOTE: Begins With searches on the indexed data box are the fastest kind of search. See
Search Speed and the Index    for details.

Contains
The Contains search type will find the search text if it occurs anywhere within the data 
box. For example, if you choose Contains text, and type Leary as your search text, cards 
with the last name Leary and OLeary might be found. By contrast, using the Begins With 
Text search type, only the Leary cards are found. 

Use the Contains search type to have buttonFile scan across the entire data box for your 
search text.

Does Not Begin With
The Does Not Begin With search type excludes any cards that begin with the search text.
For example, if you have a deck with a State data box, and you want to find everyone 
who does not live in Washington, you would type WA for your search text, choose to 
search the State data box, and choose the Does Not Begin With search type. Only cards 
from states other than Washington would be found.

Does Not Contain
The Does Not Contain search type excludes any cards that contain the search text 
anywhere within the specified data box. This search type scans across the entire data 
box to make its comparison.

Less Than
The Less Than search type only finds cards that contain data less than the search text. 
For example, typing D for your search text, choosing to search the Last Name data box, 
and choosing the Less Than search type would only find last names that begin with A, B, 
and C. 

Less Than or Equal To
The Less Than Or Equal To search type finds cards that include the search text and any 
data less than the search text. For example, typing D for your search text, choosing to 
search the Last Name data box, and choosing the Less Than Or Equal To search type 
would find last names that begin with A, B, C, and D.



Greater Than
The Greater Than search type only finds cards that contain data greater than the search 
text. For example, typing D for your search text, choosing to search the Last Name data 
box, and choosing the Greater Than search type would find last names that begin with E 
to Z.

Greater Than or Equal To
The Greater Than Or Equal To search type only finds cards that include the search text 
and any data greater than the search text. For example, typing D for your search text, 
choosing to search the Last Name data box, and choosing the Greater Than Or Equal To 
search type would only find last names that begin with D to Z.

Searching for Numbers using Less Than and Greater Than Comparisons
buttonFile uses a string comparison for all its searches. This means that it is always 
searching for a string of characters, never numeric values. This can cause some 
confusion if you are searching data boxes that contain numbers when using the Less 
Than, Less Than Or Equal To, Greater Than, and Greater Than Or Equal To search 
types. For example, if you type the search text 50 and choose the Greater Than search 
type, buttonFile will find 51, 52, etc. but it will also find any entry that begins with 6 or 
more: 6, 7, 8, and 9.

However, you can work around this limitation. When adding cards, enter numeric values 
so that each digit falls in a position in the data box corresponding to its place value. For 
example, if the largest number you will ever enter into a data box is 999, you would enter 
one digit entries with two leading spaces:      1. Two digit entries would have one leading 
space:    21. Three digit entries would have no leading zeros or spaces.

This does not create a problem with number entries that have the same length. For 
example, zip codes, phone numbers, social security numbers, and part numbers, 
generally have the same number of characters for each entry. If all your zip code entries 
have only 5 digits, searching for greater than 98059 will always find zip codes 98060 or 
greater.



Other Search Options
In addition to the search type, you can further specify how buttonFile handles the search text using 
the following options:

Match Whole Word Only 

Case Sensitive 

Sounds Like 



Match Whole Word Only
Select the Match Whole Word Only check box on the Find dialog box if you want buttonFile to find 
exact matches for the search text. For example, if you using a Begins With search on Smith and 
choose the Match Whole Word Only option, only Smith entries would be found. However, using the 
same search text with the Match Whole Word Only option turned off, would find Smith, Smithers, 
Smithson, and so on.



Case Sensitive
Select the Case sensitive check box on the Find dialog box if you want buttonFile to search for the 
exact characters you typed in your card. For example with this option selected, if you typed Smith as 
your search text, SMITH and smith would not be found, only cards containing Smith would be found.



Sounds Like
Select the Sounds Like check box on the Find dialog box if youre not sure how to spell a name or 
data item. buttonFile will search for data that sounds like the data you entered for your search text. 
For example, if you entered Johnson, Jonson and Johnston would also be found.



Using An Additional Comparison
buttonFile lets you enter up to two items to search for. For example, you could search for everyone 
with the last name Cooper in the state of Maine. Choosing either the And option button or the Or 
option button under Additional Comparisons expands the Find dialog box. Enter additional search text
in the second Search for text box, choose the data box to search in, and choose the other search 
options as desired.

And or Or Searches
The option you choose determines how the two items you are searching for will be used.

An And search will find cards where each card must contain both of the search items. For example, 
using an And search to search for Cooper in Last Name and Maine in State will find only cards 
containing both Cooper and Maine. 

An Or search will find any card that contains either one or both of the search items. Searching for 
Cooper and Maine as an Or search, will find all cards with the last name Cooper regardless of the 
entry for State, and all cards with the State as Maine regardless of the entry for Last Name.

Note: buttonFile does not prevent you from entering a search that is logically impossible. For 
example, you could perform an And search to search for Smith in Last Name and for Jones in Last 
Name--this can never be true and no cards will be found.



Search Direction
Beginning to End

The Beginning to End option causes buttonFile to start searching from the first card in the
deck index and search forward until it reaches the last card in the deck index. This is 
typically the way you want to search if you want to make sure that all cards are accounted
for.

Forward from the Current Card
The Forward From Current Card option causes buttonFile to search forward through the 
deck from the card that was current when you initiated the search. The direction is always
relative to the indexed order: if your deck is indexed from A to Z, searching forward 
searches in the direction of Z; if your deck is indexed in reverse order from Z to A, 
searching forward searches in the direction of A.

Backward from the Current Card
The Backward From Current Card option causes buttonFile to search backward through 
the deck from the card that was current when you initiated the search. The direction is 
always relative to the indexed order: if your deck is indexed from A to Z, searching 
backward searches in the direction of A; if your deck is indexed in reverse order from Z to 
A, searching backward searches in the direction of Z.



Continuing a Search
You can have buttonFile continue the last search entered to search for additional matching cards 
using the Find Next option on the Search Menu. The search proceeds using the same search you last
specified with the Find dialog box. 

Continuing a Beginning to End Search
Since a Beginning to End search is always proceeding in a forward direction, continuing a
search always moves toward the end of the deck. If you continue searching to view all 
cards that meet your search criteria, buttonFile will notify you when the entire deck has 
been searched. If you want, you can continue searching to review previously found cards.

Continuing a Forward or Backward from Current Card Search
If you repeat either kind of current card search after finding a card, buttonFile will 
continue in the same direction you originally specified. When you are searching forward 
and reach the last card in the index , buttonFile asks you if you want to continue your 
search from the beginning of the deck. Likewise, when you are searching backward and 
reach the first card in the index, buttonFile asks you if you want to continue your search 
from the end of the deck. If you choose Yes to continue, buttonFile will continue searching
until it reaches the card you started from. When the search reaches the card you started 
from, buttonFile tells you that the entire deck has been searched.

To continue a search
Choose Repeat Last Find from the Search Menu. 

Or...

Click 

Or...

Press 

 + 

.



Search Speed and the Index
For the highest performance when searching, search for data in the Level 1 data box of the index (the
data that appears leftmost on the index line when a deck is displayed in Card View). Best speed also 
requires that the Sounds like check box is off, and that Begins with is selected in the Search Type list 
box.

If you find that you are searching more frequently in a data box other than the Level 1 data box, you 
can change the decks index using the Index option on the Configure menu.

Related Topics...

Configuring the Index 



Search and Replace
Use the Replace option on the Search menu to replace data in selected records. For example, if you 
are maintaining a mailing list and the Post Office changes a particular zip code from 98056 to 98059, 
you can search for all cards with 98056 in the Zip Code data box and change them to 98059. Also, if 
you choose to search all data boxes, you can have buttonFile find and replace data wherever its 
located on a card.

The Replace feature works much like the a word processors search and replace feature: you enter 
the data to search for and the data to replace with--then buttonFile lets you choose whether to confirm
every replacement or to automatically replace all occurrences found.

Using the Replace Dialog Box
Choosing the Replace option on the Search menu displays the Replace dialog box. The options in the
Search For grouping work identically to the same options used for a normal search. See Searching 
for Cards    earlier in this chapter for details on how to enter search text and how to use other search 
options. 

The Replace feature always searches starting from the card that was current when you initiated the 
Replace operation, just like the Forward from Current Card or Backward from Current Card options on
the Find dialog box. 

To search for and replace data

1. Choose Replace from the Search menu, or press  + 

.
The Replace dialog box displays.

2. Type the data to search for in the Search for text box .
3. Select which data box to search in from the Search in data box    list box.
4. Select the search type from the Search type list box .
5. Select any of the three check boxes--Match whole word only , Case sensitive , or Sounds like --if 
appropriate.
6. Type the replacement data in the Replace with text box.
7. To confirm each replacement: Choose Find Next to search forward from the current card, or 
choose Find Previous to search backward from current card. When a match is found, choose the Replace
button to replace the data, or choose Find Next or Find Previous to skip to the next matching card. 
Choosing Find Next starts searching forward from the current card, and choosing Find Previous starts 
searching backward from the current card. When using either Find Next or Find Previous, buttonFile stops
when it finds a match to allow you to confirm whether to perform the replacement.

Or...

To replace all matches without confirming: Choose the Replace All button. 
Choosing Replace All starts searching forward from the current card and does 
not stop for you to confirm replacements.

buttonFile prompts you when it reaches either end of the deck.

8. Choose No to stop searchingthe entire deck will not have been searched. 
Choose Yes to continue searching and completely search the entire deck. 
buttonFile displays a Yes/No prompt when the entire deck has been searched, 
choose Yes to stop searching. 

Confirming Replacements with the Replace Button
When using the Find Next and Find Previous buttons buttonFile stops at the first match 
that it finds. The matching data that is about to be replaced displays in the Current Data 
text box and the Replace button becomes active. At this point, you can choose Replace 
to replace the data in the current card--buttonFile will continue to the next match. Or, you 



can choose Find Next or Find Previous to skip the current match and continue to the next
match. You can continue in this fashion confirming each replacement, or if you decide you
want buttonFile to continue making replacements without interruption, you can choose 
Replace All.

Continuing At the End or Beginning of the Deck
Whether you choose to confirm each replacement using the Replace button, or if you use
the Replace All button, buttonFile will stop when it reaches either the end or beginning of 
the deck (depending on which direction you are searching in). When either extremity of 
the deck is reached, buttonFile displays a prompt asking you if you want to continue. 

Choose Yes, if you want to make sure all cards in the deck are processed--buttonFile will 
display another prompt when the entire deck has been searched. 

Choose No, to stop replacements at that point, but be aware that in doing so, all cards in 
the deck are not examined for matching data.

Related Topics...

Searching For Cards 

Editing Cards 





Introduction to Report Designing and Printing
All of buttonFile's printing operations, whether you are printing on cards, labels, or standard sheets 
are referred to as reports. 

You can print reports any of four ways:

Printing a Pre-Defined Report 

Printing a Default Report

Designing a New Report

Modifying a Report

If you define a deck using a template (either directly from a template, or by patterning after a 
template), buttonFile automatically provides one or more pre-defined reports for the deck. The 
purpose of pre-defined reports vary.

If you design a deck from scratch, buttonFile automatically provides two default reports for every deck
you create: a default page report that prints as many full cards as will fit on a page; and a default row 
report that prints a column-style report.

You can also design new reports for any deck. For example, if you want hard copy of your deck, you 
can design a report to print on real 3x5 or Rolodex cards. You can design reports to print labels for 
addresses, folders, video and music cassettes, price tags, or part numbers. Design reports to print 
phone and address lists, or a catalog of the books, videos, music, or software. New reports are 
created using the report designer. You can also modify any report (pre-defined, default, or new), by 
loading the report into the report designer.

Related Topics...

The Available Reports Dialog Box 

Summary of the Report Design Process 

Printing 

Template Definitions 



The Available Reports Dialog Box

Choosing the Print Report option on the File menu, or clicking  on the button bar displays the 
Available Reports dialog box. The Available Reports dialog box is the main pathway into buttonFile's 
printing and report designing features. Each command button controls one of the following 
procedures:

Printing a Report 

Designing a New Report 

Modifying an Existing Report 

Deleting a Report 

Restoring Default Reports 



Printing a Report
You can print any available report by selecting it from the list box and then choosing the Print button 
on the Available Reports dialog box. This displays a dialog box with controls for the various printing 
options.

To print a report

1. Choose Print Report from the File menu, or click  on the button bar.
The Available Reports dialog box displays.

2. Select (highlight) the report you want to print in the list box.
3. Choose the Print command button.

The Print dialog box displays.
4. Select the desired options.
5. Choose OK.

Related Topics...

Printing Reports 



Designing a New Report
You can start designing a new report by choosing the New button on the Available Reports dialog box.
This displays a dialog box to choose what kind of paper or stock you will be printing on. After you've 
done this, the report designer window displays, ready for you to start designing your report.

To start designing a new report

1. Choose Print Report from the File menu, or click  on the button bar.
The Available Reports dialog box displays.

2. Choose the New button.
The Forms dialog box displays.

3. Choose the option button for the kind of report you want to design: Card, Label, or Report.
4. Select the desired form from the list box.
5. Choose OK.

The report designer window opens ready for you to start designing a new report.

Related Topics...
Summary of the Report Design Process 



Modifying an Existing Report
You can modify the design of any report regardless of its origin using the report designer window. For 
example, modifying one of the default reports that contain all of the data boxes in your deck is a good 
way to start defining a report. 

Modify a report by selecting it from the list box in the Available Reports dialog box, and then choosing 
the Modify button. This loads the selected report into the report design window.

To modify an existing report

1. Choose Print Report from the File menu, or click  on the button bar.
The Available Reports dialog box displays.

2. Select (highlight) the report to modify in the list box.
3. Choose the Modify button.

The report design window opens with the selected report format loaded ready for you to 
make modifications.

Related Topics...

Summary of the Report Design Process 



Deleting a Report
You can delete any of the reports shown on the Available Reports dialog box. You can only delete one
report at a time. 

If you accidentally delete a report, you can undo the deletion by choosing the Undo Del button 
immediately after deleting. The Undo Del button only undeletes the last report deleted as long as the 
Available Reports dialog remains displayed.

To delete a report

1. Choose Print Report from the File menu, or click  on the button bar.
The Available Reports dialog box displays.

2. Select (highlight) the report to delete from the list box.
3. Choose the Delete button.

A confirmation dialog box displays.
4. Choose Yes to delete the report.

The report is removed from the list box on the Available Reports dialog box.

To undo a report deletion
Choose the Undo Del button.

The last report deleted is restored.

Related Topics...

Deleting a Deck 



Restoring Default Reports
If you delete both the Default Page Report and the Default Row Report from the Available Reports 
dialog box, you can restore them using the Add Defaults button. The Add Defaults button is 
unavailable until both default reports are deleted.

NOTE: If you use the Redefine option on the File menu to modify your deck, the changes are not 
reflected in the two default reports. Deleting both default reports and then restoring them updates 
them.

To restore default reports

1. Choose Print Report from the File menu, or click on the button bar.
The Available Reports dialog box displays.

2. Choose the Add Defaults button.

The Default Page Report and Default Row Report are added to the list box.



Forms
Choosing a Pre-defined Form 

Defining a Custom Form 

Resizing the Form 

Report Form Headers and Footers 

Changing the Form 



Choosing a Pre-defined Form
The Card, Label, and Report option buttons on the top of the Forms dialog box specify which kind of 
form shows in the list box below. Forms are sorted alphabetically by name and then by dimensions--
the width of the card, label, or page is always listed first, followed by the height. 

Choosing the Card option button displays a list of cards and envelopes including Avery stock. 

Choosing the Label option button displays a list of labels including a large variety of Avery and 
Dennison labels. 

Choosing the Report option button displays a list of standard paper sizes in both portrait or 
landscape orientations.

The rightmost column in Card and Label lists contains additional information: either the kind of printer 
each form is appropriate for (dot matrix or laser), or a part number--unless indicated otherwise, this is 
an Avery part number.

If you can't find the form you want to print on, choosing the Custom button allows you to define a 
custom form to your specifications.

To start designing a report using a pre-defined form
1. Make sure the deck you want to define the report for is current.

2. Choose New Report from the File menu.

Or...

Click  or press 

 + 

.
Choose New.
The Forms dialog box displays.

3. Choose the option button for the kind of report you want to design: Card, Label, or Report.
The list box updates to show the choices available for the kind of report you choose.

4. Choose the desired form from the list box.
5. Choose OK.

The report design window replaces the current deck window with a report designer 
window using the form you chose in step 4.

Related Topics...

Defining a Custom Form 

Adding and Modifying Frames 

Working with Frames 



Defining a Custom Form 
If the form you want to print on is not available on the Forms dialog, you can create a custom form .

To start designing a report using a custom form
1. Make sure the deck you want to define the report for is current.

2. Choose New Report from the File menu.

The Forms dialog box displays.

3. Choose the option button for the type of form you want to define: Card, Label, or 
Report.

4. Choose the closest form to the one you want to define from the list box.

5. Choose the Custom button on the Forms dialog box.

The Define Custom Form dialog box displays. At this point, you can define each 
of the options listed below. As you make your choices, the Sample area of the 
dialog box reflects what the resulting form will look like.

6. Select the correct form type from the option buttons: Card, Label, Report.

7. Select a sheet/page size    from the drop-down list box, or specify the dimensions 
in the Width and Height boxes.

8. Specify top, bottom, right, and left margins using the corresponding spin boxes, if
desired. Specify the horizontal and vertical margins, if applicable (only for multi-
column or multi-row labels and cards).

9. If you chose Card or Label in step 3, specify the number of columns and rows 
using the Columns and Rows    spin boxes. If you chose Report in step 5, specify 
the header and footer sizes using the Header and Footer    spin boxes.

10. Choose OK.

The report design window replaces the current deck window with a report designer 
window using your custom form.

Related Topics...

Report Form Headers and Footers 

Changing the Form 



Choosing the Form Type
The three option buttons on the top row of the Custom Form dialog box (Card, Label, or Report) let 
you specify a different kind of form than the one you started with. Generally, you will leave these 
settings alone.



Page/Sheet Size
If you choose to design a Report form, the upper left group of controls is labeled Page Size. If you 
choose to design a Card or Label form, the upper left group of controls is labeled Sheet Size. 

Pulling down the drop-down list only displays the page size options available for the current Windows 
printer driver. The options available can vary from printer to printer. To make sure you are working 
with the correct page size options, you may want to check to see which printer is current using the 
Printer Setup option on the File menu before proceeding.

At minimum, standard paper sizes will be listed. Some printers also support various envelopes and 
other stock. As long as you see the page size you want to print on, select that option from the list box.

If you dont find the page size you want to print on in the list box, and if your printer supports a User 
Defined page size, you can specify non-standard page sizes using the Width and Height spin boxes. 
This is not recommended if you are using a laser or sheet-fed printer--generally, you should only 
select one of the standard printer page sizes from the list box.



Margins
The Margins area specifies the top, bottom, right, and left margins within the page size selected 
above. If you are defining a Card or Label form to print more than one row or column, you can use the
Horizontal and Vertical spin boxes to specify the distance between each column and row of cards or 
labels. When defining a Report form, the Horizontal and Vertical spin boxes are unavailable. Type the 
dimensions into each spin box, or use the arrow buttons to the right of each box.



Cards/Labels Per Page or Header/Footer
The options available in the lower left group of controls will be labeled differently depending on the 
kind of form you choose to define: Cards per page when defining a Card form, Labels per page when 
defining a Label form, or Header and Footer when defining a Report form. 

The Cards or Labels per page options specify the number of columns and rows when printing Card or
Label forms. Type the number of columns and rows into each spin box, or use the arrow buttons to 
the right of each box.

The Header and Footer options define how much of the page is set aside for headers and footers. 
Type the desired size into each spin box, or use the arrow buttons to the right of each box.



Resizing the Form
After you have selected or defined a form type, the deck window is replaced by a Report designer 
window. The contents of the designer window varies depending on the form type you are using. Card 
and Label forms are generally smaller, since you are defining a single card or label which may print 
multiple copies per page. Report forms are the same size as the page you are printing, less any top, 
bottom, left, and right margins. Report forms also have resizable headers and footers .

Typically, you do not need to resize the form you selected at the beginning of the report design 
process. However, at any point in the design process you can change the exact dimensions of the 
form and margins using the Define Custom Form dialog. 

To resize the form

1. Choose Change Form from the Tools menu, or click on the  button.
The Forms dialog box displays

2. Choose the Custom button
The Define Custom Form dialog box displays.

3. If desired, change the form width using the Width spin box.
4. If desired, change the form height using the Height spin box.
5. If desired, change any of the margin settings using the appropriate spin boxes.

NOTE: If you are defining a Card or Label form, you may need to use the Left, Right, Top, 
Bottom, Vertical, and Horizontal spin boxes, as well as the Rows and Columns spin boxes to define the 
form. See Defining a Custom Form earlier in this chapter for details.

Changes are reflected in the Sample area as you make them.
6. Choose OK when you are finished.

Related Topics...
Report Form Headers and Footers 



Report Form Headers and Footers
Report forms provide area at the top and bottom of the page to format headers and footers. Typically 
you would place titles and system data like page numbers or the current date in the header and footer
areas. However, you can place data boxes in headers and footers as well. For example, you might 
want to put the Last Name data box in the corner of a header when creating a phone list. 

Resize the header or footer area by dragging the border with the mouse. Or, invoke the Design 
Custom Form dialog box and enter values for the header and footer size.

To resize a header or footer

1. Move the mouse pointer over the border between the body of the form and the 
header or footer. (On color systems, the header and footer borders are blue.) The
pointer turns into a double-ended arrow.

2. Drag the border until the header or footer is the desired size. Use the ruler on the
left side of the form as a guide.

3. Release the mouse button.

1. Choose Change Form from the Tools menu, or click on the  button.
The Forms dialog box displays

2. Choose the Custom button
The Define Custom Form dialog box displays.

3. Enter the new header size using the Header spin box.
4. Enter the new footer size using the Footer spin box.
5. Choose OK.

Related Topics...

Defining a Custom Form 

Resizing the Form 



Changing Forms
After you've started defining a report, you can change to a different pre-defined form if you need to. To

do this choose Change Form from the Tools menu, or click  on the button bar. This will redisplay 
the Forms dialog box which provides all the options described in the Choosing a Pre-defined Form 
and Defining a Custom Form sections.



Configuring Report Fonts
You can use two fonts in your report: the report data font , and the report text font . By default, the 
report data font is the same as your deck's data font , and the report text font is the same as your 
deck's text font (defined using the options on the Fonts submenu of the Configure menu when your 
deck is displayed). If you didnt configure fonts for your deck your fonts will be: 10 point, regular style, 
Arial (if you are using Windows 3.1 with TrueType fonts enabled); or 10 point, regular MS San Serif or
Helv (if you have disabled TrueType fonts, or are using Windows 3.0).

If you want to use fonts or sizes that are different from the default fonts, it is a good idea to configure 
your fonts before you start laying out your report. The reason for this is that when you first add a 
frame, it is sized for the current font. Data box frames also account for the maximum stored length 
and how it will fit within the width of your form. However, if you change the font after placing frames, if 
necessary, only the frame height relative to the new font size will change. The lengths of frames do 
not change--you may have to resize the frame to print all text or data. If necessary, deleting a data 
box frame and adding it again after changing fonts, will create a suitably sized frame.

To select a different font or size, choose either Report Data Font or Report Text Font from the Fonts 
submenu on the Configure menu, which displays the font configuration dialog box:

The Font dialog box provides control over the following report font features:

Font

The font itself. All fonts available on your system are shown in the scrolling list box.

Font Style

Regular, bold, italic, bold-italic styles are standard options. The options available will 
depend on the font definition--not all fonts will have all four style options. If your current 
frames have a mix of style attributes set before you make a new Font style selection, the 
new font style is added to the current attributes. For example, if choose Bold, the bold 
attribute is added to any pre-existing attributes (Bold Italic, Bold Italic Underlined, or just 
Bold). Choosing Regular turns off Bold for any pre-existing frames, but leaves Italic or 
Underline styles in place.

Size

The size of the chosen font in points (1/72"). The options available will depend on the font
definition--not all fonts have the same size options.

To configure report fonts
1. Choose Fonts from the Configure menu.

A submenu displays to the right of the Fonts option.

2. Choose the desired submenu option: Report Data Font or Report Text Font.

The appropriate Font dialog box displays.

3. Scroll through the Font list box and select the desired font.

4. Select the desired style from the Font Style list box. 

5. Scroll through the Size list and select the desired size.

Each choice you make is reflected in the Sample area.

6. Choose OK, when the Sample text meets your requirements.

Fonts and Printing Speed
The printing speed is affected by the kind of fonts you choose--this can be quite noticeable when 
printing several pages. Within Windows you can have system , printer , and TrueType (if you are 
using Windows 3.1) fonts. The kind of font is distinguished by an icon to the left of the font name in 



the Font list box. System fonts have no icon on their left. printer fonts have a small printer icon on the 
left, and TrueType fonts have a TT icon on the left. Choose printer fonts for the fastest printing 
speeds. 

Related Topics...

Working with Frames 



Adding and Modifying Frames
Once you have selected the form and configured which fonts to use, you're ready to lay out the body 
of your report by placing element frames. buttonFile provides five kinds of report elements--text 
frames, data box frames, notes box frames, system data frames, line/box frames--each of which are 
displayed in movable, resizeable frames when they are selected.

Go to...

Text Frames 

Data Box Frames 

Notes Box Frames 

System Data Frames 

Line and Box Frames 



Adding Text Frames in Reports
Use text frames to enter any constant text you want in your report, such as: titles, headings , or notes.

To add a text frame

1. Click on the  on the button bar, choose Add Text Frame from the Tools 
menu, or press 

 + 

.
A new frame displays in upper left corner of the form.

2. Type your text in the Text text box on the button bar. Or, select the frame, press  and type 
your text in the Text text box on the Text Attributes dialog box.
3. Move or resize the Text frame as required.

Tip: You can also add and edit a longer passage of text by first typing it into a text 
program, like Windows Write, then copying portions to the clipboard and pasting them 
into your buttonFile report. Keep in mind that there is a maximum of 100 characters per 
text frame, so you generally will not want to copy more than about one line per frame.

Related Topics...

Working with Frames 

Setting Frame Attributes 



Adding Data Box Frames in Reports
Use data box frames in reports to print information from your deck. As you add data box frames, 
buttonFile automatically assigns each data box in access order. After a frame is in place, you can 
choose which data box will print in the frame using the Name drop-down list box on the button bar. 

Alternatively, you can select the frame and press  to display the Data Box Attributes dialog box 
and use the Name list box on that dialog box. Each data box that has already been assigned will have
a » character next to it in the Name list box.

To add a data box frame

1. Click  on the button bar, choose Add Data Box Frame from the Tools menu, 
or press 

 + 

.
A new frame displays in the upper left corner of the form.

2. Choose the data box to print using the Names drop-down list box on the button bar. Or, select the

frame, press  and choose the data box using the Names drop-down list box on the Data Box 
Attributes dialog box.
3. Move or resize the data box frame as required. See Working with Frames for details.

Combining Data Box Information with Text
In addition to being able to place a text frame and a data box frame next to each other to combine 
constant text with deck information, you can type text directly into the same frame with a data box 
using the Name text box on the button bar. This has an added advantage, in that the text will not print 
if there is no data to print for a given card. 

To combine text and data box data in one frame

1. Click  on the button bar, choose Add Data Box Frame from the Tools menu, 
or press 

 + 

.
A new frame displays in the upper left corner of the form.

2. Choose the data box to print using the Name drop-down list box on the button bar. Or, select the 

frame, press  and choose the data box using the Name drop-down list box on the Data Box 
Attributes dialog box.

3. Click on the Name text box on the button bar, or press  + 

 to move the cursor into the Name text box.
4. Type text on either side of the brackets surrounding the data box name, being careful not to 
disturb either bracket or data box name.

The text you enter displays in the data box frame.
5. Move or resize the data box frame as required.

Related Topics

Working with Frames 

Setting Frame Attributes 



Adding Notes Box Frames in Reports
Adding a notes box frame to your report is essentially the same procedure as adding a data box 
frame. However, you have the additional option of choosing whether or not to print the entire contents 
of the notes box. 

To add a notes box frame

1. Click  on the button bar, choose Add Data Box Frame from the Tools menu, 
or press 

 + 

.
A new frame displays in the upper left corner of the form.

2. Choose your deck's notes box name from the Names drop-down list box on the button bar. Or, 

select the frame, press  and choose the notes box name from the Names drop-down list box on the 
Data Box Attributes dialog box.
3. Choose whether to print all or part of the notes box using the Print Entire check box on the button 

bar; or select the frame, press  and use the Print Entire text box on the Data Box Attributes dialog 
box
4. Move or resize the data box frame as required.

Related Topics...

Working with Frames 

Setting Frame Attributes 



System Data Frames
System data frames are used to print system data. Each time you print a report with system data 
frames, such as date or time, the frames will print the current information. 

Choosing the Add System Data option on the Tools menu or clicking the  button on the button 
bar displays the Add System Data dialog box. The Add System Data dialog box breaks down each of 
the system options into three groups: Dates and Time, Numbers, and System Data. Choosing the 
option button next to each list activates that list. You can scroll through the list, or pull down the list to 
view all options. As an option is highlighted, an example of its output is displayed in the Example area
of the dialog box. This dialog box also lets you set the alignment and style for system data. See    
Setting Frame Attributes for more details on alignment and style.

After you place a system data frame, a sample of the output in the current text font is displayed in the 
frame. See Configuring Report Fonts if you want to change fonts. 

To add a system data frame

1. Choose Add System Data from the Tools menu, or click  on the button bar.
2. Choose which kind of system data you want to place: Date and Time, Numbers, or System.

3. Scroll through the list with  and 

 to choose an option, or pull down the list and choose an option.
4. Set Alignment and Style, if desired.
5. Choose OK.
6. Move or resize the system data frame as required.

Editing System Data
Once a system frame is placed, it is treated as a text frame containing a code that represents the 
system data . This code is displayed in the Text text box on the button bar when a system data frame 
is selected. For example, buttonFile uses the code {page} for a Page number system frame. After you
have placed a System Data frame, you cannot use the Add System Data dialog box to modify it. If you
decide you want a different system data option, you can either delete the current system data frame 
and place it over again, or you can edit the current system data code, replacing it with a new code, 
using the Text text box on the button bar. See the System Data Codes table later in this section for a 
complete listing of all system data codes.

To edit a system data frame
1. Select the frame you want to edit.

The current system data code displays in the Text text box on the button bar.

2. Refer to the System Data Codes table and replace the current code with the 
desired code. Make sure that the code is surrounded by braces and is spelled 
properly.

A sample of the new system data displays in the frame as you edit it.

Combining Constant Text and System Data
You can add constant text to print along with the system data using the Text text box on the button 
bar. For example, after placing a page number system data frame, you could edit the contents of the 
Text text box to read Page {page}. The printed result would be something like: Page 10. 

You can also combine more than one system data code in the same frame. For example, editing the 
contents of a system frame to read: Printed at {time} on {shortdate} would print something like: 
Printed at 10:30 AM on 01/01/93. Text added with system data is reflected in the frame while 
designing the report. The same limits for text frames holds: the combined length of text and system 
data codes cannot exceed 100 characters.



To combine system data and constant text
1. Select the frame you want to edit.

2. Type constant text in the Text text box on the button bar being careful not to 
disturb the system data code(s). Add additional system data codes, if you wish.

Text and sample system data displays in the frame as you edit it.

System Data Codes
The following table shows the system frame options, their internal codes, and a sample of typical 
output.

Frame Option Code Sample Output
Dates and Time
Date - long {longdate} Friday, March 5, 1993*

Date - short {shortdate} 03/05/1993*

Day - long {longday} 05

Day - short {shortday} 5

Weekday - long {long weekday} Friday

Weekday - short {short weekday} Fri

Month - long {longmonth} January

Month - short {shortmonth} Jan

Year - long {longyear} 1993

Year - short {shortyear} 93

Time - long {longtime} 06:53:56 PM*

Time - short {time} 06:53 PM*

Hour {hour} 6

Minutes {minutes} 56

AM/PM {am/pm} AM*

Numbers
Page number {page} 10

Cards in deck {cardtotal} 537

System
Report name {reportname} Phone List

Deck name {deckname} Contacts

Deck description {description} Wholesale Distributors

Deck file path {path} C:\BUTNFILE\CONTACTS.BTN

* These formats will vary depending on your Windows Control Panel settings. The printed
and displayed formats of {longdate}, {shortdate}, {longtime}, and {time} are determined by
the Date Format and Time Format settings available through the International option on 
the Windows Control Panel. These are system-wide settings that are available to all 
programs running under Windows. For example, using the Control Panel Date Format 



settings you can configure whether the {longdate} code uses leading zeros for single digit
days of the month, or you can configure a different month/day/year order. There are 
several other options available for configuring date and time formats. Refer to your 
Windows documentation or on-line help system for details on how to use Control Panel 
date and time format settings.

Related Topics...

Working with Frames 

Setting Frame Attributes 



Line and Box Frames
buttonFile also lets you define horizontal lines, vertical lines, and boxes for your report. You can 
choose from a variety of line styles for both lines and boxes: single or double lines in a variety of 
widths. Additionally, you can specify the fill pattern and corner radius for boxes. Unlike other frame 
types, line and box frames can be superimposed on each other. Also, box frames can have text and 
data box frames placed within them.

To add a line

1. Click  on the button bar, or press 

 + 

.
A box frame displays in the upper left corner.

2. Choose the  to format a horizontal line, or choose the 

 to format a vertical line. (Pressing 

 + 

 cycles through the line and box buttons, if you're using the keyboard.)
3. Choose a line style from the Line Style list box.
4. Move or resize the line frame as required.

To define a box

1. Click  on the button bar, or press 

 + 

.
A box frame displays in the upper left corner.

2. Choose a line style from the Line Style list box.
3. Choose a fill pattern from the Fill Pattern list box.
4. If you want rounded corners, enter a value in the Corner Radius spin box.

The display of the box frame is updated as you make each choice.
5. Move or resize the box frame as required.

Related Topics...

Working with Frames 

Setting Frame Attributes 



Setting Frame Attributes
buttonFile provides options for setting text attributes for style and alignment on all frame types. You 
can set any combination of bold, italic, and underlined styles. And you can set either left, centered, or 
right alignment.

If you select multiple frames before using the button bar or Frame Attributes dialog box, all selected 
frames take on the attributes you select--any attributes previously set are overridden.

To set a frame's style and alignment using the button bar

1. Select the frame(s) you want affected.

2. Click on the desired style button(s),

3. Click on the desired alignment button.

The effect of your choices are reflected in the frame(s).

1. Select the frame(s) you want affected.

2. Press  + 

 for bold, 

 + 

 for italic, or 

 + 

 for underline.

3. Press  + 

 until the desired alignment button is selected.

The effect of your choices are reflected in the frame(s).

To set text style and alignment using a Frame Attributes dialog box
1. Select the frame(s) you want affected.

2. Press , or double-click on the frame(s).
A frame attributes dialog is displayed.

3. Choose the desired options from the Style and Alignment areas of the dialog box.
4. Choose OK.

The effect of your choices are reflected in the frame(s).

NOTE: If you selected multiple frames in step 1, the Group Attributes dialog box will 
display after step 2.

On the Group attributes dialog box, check boxes can also be gray in addition to checked 
or empty. A gray check box indicates an ambiguous status. For example, if the selected 
group currently has a mixed set of attributes (for example, some frames are bold only, 
others are bold and italic, some underlined, and some have no attributes) some or all of 
the Font Style check boxes will be filled with gray. As long as you leave the Font Style 
check boxes gray, the original styles will be retained. If you check any of the check boxes 
(x in the box), that attribute will be set for all of the selected group when you choose OK. 
Likewise, clearing a check box (neither x nor gray), turns the attribute off for all of the 
members of the selected group.



Similarly, if the selected group has a mixed set of alignments (for example, some left, 
some right, and some centered), when you invoke the Group Attributes dialog box, the 
Alignment option button for each alignment in the group will be on (filled). This means it is
possible for all three alignment option buttons to be on at the same time. If you do not 
select any of the Alignment option buttons, the original alignments for each frame are 
retained when you choose OK. However, if you select an Alignment option button, the 
other options will be turned off and all frames in the selected group will be assigned that 
alignment when you choose OK.

Related Topics...

Working with Frames 



Placing Frames for Special Formatting
Formatting to Remove Spaces and Blank Lines
When printing addresses you may want to remove blank spaces between data boxes in the line so 
that each piece of information prints next to each other. Also, your deck may have data boxes for 
more than one address line. If one of the address data boxes for a card does not contain any data, 
you will probably want to remove that blank line from the printed address.

Removing Spaces Within a Line
Ordinarily, buttonFile reserves as much space as the size of the frame when printing. 
However, when printing several data boxes in a line, you may want to remove all but one 
space between each data frame. You can do this by placing data frames next to each 
other so that vertical borders within the line are touching.

For example, a line of data boxes to print a name in an address formatted like this:

Prints like this:

Frederick Stonewall Flintstone

However, moving the same three data boxes together with vertical borders touching like 
this:



Prints like this:

Frederick Stonewall Flintstone

All but one space between the information in each pair of data boxes is removed when 
touching frames are printed.

To remove blank spaces within a line of frames
Position frames so that vertical borders within the line are touching.

NOTE: If you move frames too close together they will be overlapped and buttonFile will 
shade the frames dark blue. Vertical borders that are properly aligned to remove spaces 
will display as a single dark blue line.

Removing Blank Lines Within a Group of Lines
A similar situation arises if you have several lines in an address when the data boxes in 
one or more of the lines may be empty. For example, an address formatted like this:

Prints like this if the Address 2 data box is empty:



Frederick Stonewall Flintstone
1 Bedrock Place

Bedrock, Mesopotamia 00001

Moving the data boxes in all lines so that horizontal borders are touching, like this:

Prints like this if the Address 2 data box is empty:

Frederick Stonewall Flintstone
1 Bedrock Place
Bedrock, Mesopotamia 00001

To remove blank lines within a group of lines
Position frames so that horizontal borders between lines are touching.

NOTE: If you overlap frames, buttonFile will shade the frames dark blue. Horizontal 
borders that are properly aligned to remove spaces will display as a single dark blue line.

Forcing a Page Break on Report Forms
Card and Label forms always feed each card printed to a new card or label. Report forms print as 
many cards as will fit in a page given the report layout. This is what you want in most situations. For 
example, if you want a tabular (row) type report, you define a single line of frames that fit across the 
top of your report form, and buttonFile fills the page with a line for each card printed. The same 
principle applies to multiple line reports--buttonFile prints the information from as many cards as fit on 
the page.

However, if you are printing a form letter, or simply want a separate page for each card printed, you 
need to make sure buttonFile will not try to print below the last line in your layout. To do this, you may 
need to resize the footer so that it is below the last line in your definition.

To force a page break when using a Report form
After placing all the frames you want to print on the page, resize the footer section so that it is 

immediately below the last line of your report definition. See Report Form Headers and Footers for details
on how to do this.

NOTE: This method will not work properly if you are printing a Notes box frame with the 
Print entire check box turned on. See the following section.

Forcing a Page Break When Printing The Entire Notes Box



You need to use different method to force a page break if you are printing an entire notes 
box (the Print Entire check box is checked on the button bar when the notes box is 
selected.) In this case, you need to resize the notes box frame so that it touches the 
footer. In this case the footer size remains the same, and no matter how much data a 
notes box contains, buttonFile feeds to a new page when it is finished printing.

To force a page break when printing an entire notes box using a Report form
After placing all the frames you want to print on the page, resize the notes box so that it touches 

the footer border.

Related Topics...

Working with Frames 



Saving a Report Design
You can save your report design at any point in a design session. The first time you do this in a 
session, the Save Report Design dialog box displays. You can enter a name or description up to 40 
characters long in the Name text box. If you want to save your design to a new name within the same 
report design session, use the Save Report As option on the File menu .

To save a report design

1. Choose Save Report from the File menu, click , or press 

 + 

.
2. Type the report name into the Name text box on the Save Report Design dialog box.
3. Choose OK.

Performing step 1 after the first time within a design session saves any changes made up
to that point under the same name.

To save a report to a new name
1. Choose Save Report As from the File menu.

2. Type the report name into the Name text box on the Save Report Design dialog 
box.

3. Choose OK.

Resolving Overlapping Frames
If any of the frames in your report overlap each other, the border of the form, or the borders of the 
header and footer sections, you will not be able to save your report. Also, any frames that fall outside 
the borders of the form will be considered as overlapping.

If you try to save a report while frames overlap an error message will display. buttonFile indicates the 
overlapping frames by shading them dark blue. As soon as the frames are moved apart or moved on 
to the form, they will no longer be shaded, and you can proceed with saving your report.

Related Topics...

Exiting a Report Design Session 

Printing 



Exiting a Report Design Session
To exit a report design session

Choose Close Report from the File menu: This closes the report design window and returns you 
to your deck.
Or...

Double-click on the control menu box 

 in the upper left corner of the report design window: This works identically to using the Close Report
option on the File menu.
Or...

Choose Print Report from the File menu or click 

 on the button bar: This closes the design window and displays the Print dialog box to allow you to 
print your report. See Printing Reports for details.
Or...

Choose New Report from the File menu: This closes the current report design window and starts 
a new report design session.
Or...

Choose Exit buttonFile from the File menu: This closes the current design session and closes 
buttonFile entirely.

In all cases, if you have not saved the report you will be asked to save the report before continuing. If 
you have saved the report, but have made changes after the last time you saved, you will be asked if 
you want to save the current design before continuing.

Related Topics...

Printing 

Saving a Report Design 



Summary of the Report Design Process
The following procedure provides a summary all the elements of the report design process.

To design a report
1. Either:

Choose New Report from the File menu.
Or...

Click 

 on the button bar, or press 

 + 

.
The Available Reports dialog box displays.

Choose New .
The Forms dialog box displays.

2. Choose the option button for the kind of report you want to define: Card, Label, or Report. Refer 
to Forms for details on different form types.
3. Select the desired form from the list box. (If you need to define a custom form instead, refer to 
Defining a Custom Form for details and procedures.)
4. Choose OK.

The Report Designer displays.

5. Place frames using either the , 

, 

, or 

 buttons on the button bar, or by choosing the Add Text, Add Data Box, Add System Data, or Add 
Line or Box options on the Tools menu. See Adding Frames and Working With Frames for details on how 
to add, move, and size frames. Also see Placing Frames for Special Formatting if you need to remove 
spaces with lines or blank lines between lines.

6. If necessary, make adjustments to frame attributes using either the button bar or 
Frame Attributes dialog box. See Setting Frame Text Attributes for details.

7. Choose Save Report from the File menu when you are finished designing your 
report.

The Save Report Design dialog box displays.

8. Type your reports name in the Name text box.

9. Choose OK.

At this point you are ready to print or preview your report.

Related Topics...

Exiting a Report Design Session 

Printing 



Printing
Printing Reports 

Print Preview 

Printer Setup 

Directing Printer Output to a Disk File 



Printing Reports
You can print a report once you have finished defining it. Or, if you designed your own deck, you can 
print either of the two default reports . Deck's created with templates have one or more pre-defined 
reports that fit typical needs. See Template Definitions for a listing of the pre-defined reports for each 
template. You can create default reports for decks created with templates using the procedure 
described in Restoring Default Reports. .

To print a card, label, or report

1. Choose Print Report from the File menu, or click  on the button bar.
The Print dialog box displays.

2. Specify how many copies to print using the spin box in the Print Selection grouping. See How 
Many Copies for details.
3. Select whether to print the current card, all cards, or selected cards using the option buttons in 
the Print Selection grouping. See Choosing Which Cards to Print    for details.
4. Choose OK to start printing, or choose Print Preview to preview your report.

Printer Doesnt Support Page Size
If the page size a report is designed for is not available on your printer, buttonFile will display this 
message when you start printing:

Warning...The printer doesnt support this reports page size. Continue printing?
This can occur if the report was originally defined for a different printer, or if you chose a pre-defined 
form that is not supported by your printer. It can also happen, if you used the Custom Form dialog box
and created a page size that is not supported by the printer using the Width and Height spin boxes.

Choosing OK when the message displays will send the report to the printer, but you may not get the 
desired results. Generally, you should modify the report and choose a new form that is supported by 
your printer. See Modifying an Existing Report and Changing Forms for details.

Related Topics...

How Many Copies 

Choosing Which Cards to Print 

Print Preview 

Printer Setup 

Modifying an Existing Report 

Changing Forms 

Directing Printer Output to a Disk File 



How Many Copies
The copies spin box specifies the number of copies for each card printed. If the This Card option 
button is selected, this specifies the number of copies to print of the current card. If the All Cards 
option button is selected, this specifies the number of copies to print of each and every card in the 
deck. If the Selected Cards option button is selected, this specifies the number of copies to print of 
each of the selected cards.

To specify the number of copies to print:
Click on the    up or down arrows to increase or decrease the number of copies.    

Or...
1. Move the cursor to the Copies spin box
2. Type the number of copies to print.

Related Topics...

Choosing Which Cards to Print 



Choosing Which Cards to Print
The three option buttons to the right of the copies spin box determine which of the deck's cards will be
printed:

This Card:    The card that was on top of the deck when you started the print operation will be 
printed.

All Cards:    Every card in the deck will be printed.

Selected Cards:    Every card selected by the search entered using the Define Search button will 
be printed. The Define Search button will only become active after this option button is selected. 
Choosing the Define Search button displays a dialog box that works identically to standard Find dialog 
box, except searching always proceeds from the beginning of the deck to the end. See Searching For 
Cards for details on how to enter a search. Once a search is entered, it description displays in the 
Summary of Selected Cards area of the Print dialog box. 

To print the current card
1. Choose the This Card option button.

2. Choose OK to print.

To print all cards
1. Choose the All Cards option button.

2. Choose OK to print.

To print selected cards
1. Choose the Selected Cards option button.

2. Choose Define Search command button.

The Print Selected Cards dialog box displays.

3. Enter the search to select the cards to print. See Searching For Cards for details 
on how to enter a search.

4. Choose OK to close the Print Selected Cards dialog box.

5. Choose OK to print.

Related Topics...

How Many Copies 



Print Preview
The Print Preview button on the Print dialog box displays a reduced-size representation of each page 
that is about to be printed. This gives you a chance to see if you are getting the desired results before
you start printing.

If you are printing no more than one page, the Next Page button will be unavailable. Otherwise, 
choosing the Next Page button displays the next page. The current page number is displayed in the 
upper left corner. Choosing the First Page button returns to the first printed page.

If you are satisfied with the results, choosing the Print button prints your report on the current printer.

To preview your report
1. Choose Print Preview.

The Print Preview dialog box displays.

2. Choose Next Page to view additional pages.

3. Choose Print when you are ready to print.

Related Topics...
Printing Reports 



Printer Setup
Using the Printer Setup button on the Print dialog box, you can configure options for the current 
printer, and if you have configured Windows to use more than one printer on different ports, you can 
choose a printer other than the default printer. The same options are available by choosing the Printer
Setup option on the File menu.

On the Printer Setup dialog box, the printer listed below the Default Printer option is your Windows 
default printer. Choosing the Specific Printer option activates the drop-down list box which shows all 
the printers you currently have installed for Windows. Choosing a printer from this list redirects 
buttonFiles output to that printer.

The options in the Orientation area of the dialog box will be active, if the current printer supports both 
portrait and landscape printing. Choose the Portrait option button to print in the standard orientation 
across the shorter dimension of the page. Choose the Landscape option button to print sideways 
across the longer dimension of the page.

The options in Paper area of the dialog box reflect the paper size and paper source options supported
by the current printer. These options will not be available for all printers.

Choosing the Options button on the Print Setup dialog box displays further settings available for the 
current printer. The options available are determined by the Windows printer driver you have loaded. 
For example, you may be able to control whether the printer prints in Draft or Letter Quality mode, or 
you may be able to choose which font cartridge to use. In most cases, there will be a Help button that 
will give you information on how to use the options that are available.

You cannot connect a printer to a different port or install a new printer using the Print Setup dialog 
box. You must use the Printers option of the Windows Control Panel to do this. Refer to your Windows
documentation for details on using the Control Panel.

To use the Printer Setup options
1. Choose Printer Setup from the File menu, or choose the Printer Setup button 

from the Print dialog box. 

The Print Setup dialog box displays.

2. Select Default Printer to use the Windows default printer. Or select Specific 
Printer and scroll through the list box to select a different printer.

3. Select the paper orientation, if desired. (These options are not available for all 
printers.)

4. Select a paper size and source, if desired. (These options are not available for all
printers.)

5. Choose the Options button if you want to make additional settings for the printer 
you selected in step 2. The options available will vary depending on the printer 
and printer driver you are using. Choose OK to return to the Print Setup dialog 
box.

6. Choose OK when you are finished making printer settings.

Related Topics...

Directing Printer Output to a Disk File 



Directing Printer Output to a Disk File
Occasionally, you may want to send buttonFile's printer output to a file instead of a printer. This lets 
you modify the formatting with your word processor, merge it with another document, or print it at 
another location. To do this you need to use the Printers option on the Windows Control Panel to 
connect the printer to a file.

If you want to produce an unformatted ASCII file (one that contains no printer control characters), you 
need to choose the Generic / Text Only printer driver using the Control Panel. This assumes that you 
havent modified the Generic / Text Only driver to produce printer control characters. If you don't have 
this driver loaded, you must use the Add >> button on the dialog box invoked by choosing the Printers
option on the Windows Control Panel. Refer to your Windows documentation for more detail on 
installing printers. 

NOTE: The following procedure refers to Windows 3.1. The procedure will be slightly different if you 
are running under Windows 3.0.

To print to a file

1. Choose the  icon in the Main group window in the Program Manager.

2. Choose the  icon.
The Printers dialog box displays.

3. Select (highlight) the printer you want to use from the Installed Printers list box. 
If the printer you want to use is not currently installed, choose the Add>> button, then select the 

printer you want to use from the List of Printers list box, and choose the Install button--you may need to 
supply one of your Windows installation diskettes to load the printer driver, if the printer driver you 
selected is not currently available.
4. Choose the Connect button.

The Connect dialog box displays.
5. Select FILE: from the Ports list box. 
6. Choose OK to return to the Printers dialog box.

The current selection in the Installed Printers list box should read: Printer on FILE: where printer 
is the name of the printer you installed in steps 4 and 5.

7. Choose Close to activate your selections.

8. Return to buttonFile and use the Printer Setup option to select the new on FILE: 
printer selection from the Specific Printers list.

9. Make any other selections from the Print dialog box and choose OK to start 
printing.

The Print to File dialog box displays to prompt you to enter a file name.

10. Type the desired drive, subdirectory (if appropriate), and file name in the text box.

11. Choose OK.

The printer output will be directed to the file you entered in step 9. Once you have performed steps 1-
7, that selection will always be available in buttonFile--you only need to perform steps 8-11 to print to 
a disk file.





buttonFile Dialing Requirements
If your computer has a modem and phone attached to it, buttonFile can dial your phone for you. 
buttonFile will find any phone number in the current card and display a list for you to choose from. 
buttonFile can also dial a phone number you type directly into the dialing dialog box. Plus, you can 
enter a list of up to 100 commonly used numbers which can be dialed any time you have buttonFile 
running. And if you want, buttonFile will even keep track of the phone calls you make in a disk file.

Note: You cannot use buttonFile's dialing features to connect to another computer, such as a BBS or 
communications service, or to a fax machine. buttonFile's dialing features can only be used for 
normal voice connections.

To make use of buttonFile's phone dialing features, you need the following equipment:

Communications Port
You must have a serial communications port on your computer--either COM1, COM2, 
COM3 or COM4, or an internal modem configured as one of the four communications 
ports. (Note: You may need to configure the communications port to work properly with 
your modem using the Port option on the Windows Control Panel. Refer to your modems 
manual for port settings.)

Modem
You must have an external Hayes compatible modem connected to your communications 
port, or a Hayes compatible internal modem. Hayes compatible means that your modem 
recognizes the main Hayes modem commands. Most modems can do this.

Telephone
You must have a telephone connected to the modem. There's generally a connector on 
the modem that's labeled to phone or handset.

buttonFile can use either a dial (pulse) or touch-tone phone connection. You need to tell 
buttonFile which kind of phone connection you are using with the Configuration option of 
the Phone menu. 

Related Topics...
Configuring the Phone Dialer 

Using the Phone Dialer 



Configuring the Phone Dialer
After you have all required equipment    hooked up, you need to configure buttonFile to recognize the 
kind of hardware you're using.

When you choose Phone Dialer from the Configuration menu the Phone Dialer Configuration dialog 
box displays. Listed below are the different sections of the dialog box. Click on an item to find out 
more about it:

Port 

Dial Method 

Initialization 

Dialing Defaults 

Dialing Prefixes 

Quick Dials 

To configure buttonFile for dialing
1. Choose Phone Dialer from the Configuration menu.

The Phone Dialer Configuration dialog box displays.

2. In the Port area, select the option button for the port your modem is attached to 
(or configured as, if using an internal modem).

3. In the Dial Method area, select the option button for the dialing method your 
phone line uses.

4. Choose any of the Get Outside Line , Long Distance and Log The Call check 
boxes, if you want these options to default as checked when dialing.

5. Change the numbers in the Get Outside Line and Long Distance text boxes, if 
necessary.

6. Enter Quick Dials if you want to.

7. Choose OK to save your configuration choices.

Related Topics...

Using the Phone Dialer 



Port
These option buttons specify which communications port your modem is attached to (or is configured 
as, if youre using an internal modem). If you're using an external modem, you should be able to check
the back of your computer to see which port it is attached to. If you have an internal modem, you may 
need to consult the documentation to determine which port it is configured as.



Dial Method
These option buttons specify which dialing method is used with your phone connection. This generally
corresponds to the kind of phone you are using: For push-button phones, choose Tone; for rotary 
(dial) phones, choose Pulse.



Initialization
These option buttons determine whether buttonFile will use the default initialization string to dial your 
modem or a custom initialization string that you enter into the text box. Generally, you can safely use 
the default settings.



Dialing Defaults
Long Distance
The Long Distance check box determines whether the corresponding Long Distance check box on the
Phone Dialer dialog box defaults as checked. When dialing, you can turn the check box on the Phone
Dialer dialog box on or off regardless of the default you set here.

Get Outside Line
The Get Outside Line check box determines whether the corresponding Get Outside Line check box 
on the Phone Dialer dialog box defaults as checked. When dialing, you can turn the check box on the 
Phone Dialer dialog box on or off regardless of the default you set here.

Log the Call
This check box determines whether the corresponding Log This Call check box in the Phone Dialer 
dialog box defaults as checked. When dialing, you can turn the check box on the Phone Dialer dialog 
box on or off regardless of the default you set here.

When you choose to log a call, buttonFile writes a log file recording the date, time, phone number and
the person called. buttonFile will create a file with the same name as the deck's file name with a .LOG
extension. For example, if your deck's file name is PHONE.TN, its phone log file would be named, 
PHONE.LOG.

Each line in the log file will be in this format:

Date, Time, Phone number, xxx 
where xxx is the data from the three data boxes on the index line of the card you dialed. This would 
be the person's name you dialed in most cases. See Printing Your Phone Log later in this chapter for 
instructions on how to print a list of your phone calls.



Dialing Prefixes
Long Distance Prefix
The Long Distance Prefix text box contains the number that is sent when the Long Distance check 
box on the Phone Dialer dialog box is checked. buttonFile supplies a default of 1, which is used by 
most long distance carriers. Type a different number or numbers in the text box if your long distance 
carrier requires a long distance prefix other than 1.

Outside Line Prefix
The Outside Line Prefix text box contains the number that is sent when the Get Outside Line check 
box on the Phone Dialer dialog box is checked. buttonFile supplies a default of 9, which is used with 
many office phone systems. Type a different number in the text box if your phone system requires a 
number other than 9.

The comma following the 9 causes the modem to pause briefly (two seconds on most modems) 
before dialing the phone number that follows. This gives the phone system a moment to activate the 
outside line before dialing begins. You may need to add additional commas if your phone system 
requires more time to activate an outside line.

Local Area Code
Type your local area code in the Local Area Code text box. If you enter area codes for all phone 
numbers in your deck (including local numbers), the area code will not be dialed if the long distance 
check box is off when dialing local numbers. For example, if a phone number data box contains (206) 
555-1212 and you have 206 entered in the Local Area Code text box, only 555-1212 will be dialed if 
the Long Distance check box is off. This lets you make your phone number decks portablewhen you 
are within the local dialing area, leave the Long Distance check box off; when you are outside the 
local dialing area, turn the Long Distance check box on.



Quick Dials
You can enter up to 100 phone numbers and descriptions in the Quick Dials list box. These numbers 
can be dialed from the Phone Dialer dialog box regardless of which card is displayed.

To add Quick Dial phone numbers
1. Choose Phone Dialer from the Configuration menu.

The Phone Dialer Configuration dialog box displays.

2. Choose the Add button.

The Add Quick Dial dialog box displays.

3. Type a description in the Description text box.

4. Type the phone number in the Phone Number text box.

5. Choose OK.

6. Repeat steps 2 through 5, if you want to add additional Quick Dials.

7. Choose OK when you are done entering Quick Dials.

To modify Quick Dial phone numbers
1. Choose Phone Dialer from the Configuration menu.

The Phone Dialer Configuration dialog box displays.

2. Select (highlight) the Quick dial number you want to modify.

3. Choose the Modify button.

The Modify Quick Dial dialog box displays.

4. Modify the description in the Description text box.

5. Modify the phone number in the Phone Number text box.

6. Choose OK.

7. Repeat steps 2 through 5, if you want to modify other Quick Dials.

8. Choose OK when you are done modifying Quick Dials.

To delete Quick Dial phone numbers
1. Choose Phone Dialer from the Configuration menu.

The Phone Dialer Configuration dialog box displays.

2. Select the Quick Dial to delete from the Quick Dials list box.

3. Choose the Delete button.

A confirmation dialog box displays.

4. Choose Yes.

5. Repeat steps 2 through 4, if you want to delete additional Quick Dials.

6. Choose OK when you are done deleting Quick Dials.



Using the Phone Dialer
You can dial four ways with buttonFile:

Select (highlight) a phone number on the current card and choose the 

Select a phone number for the current card from the Phone Dialer dialog box.

Type any phone number into the text box on the Phone Dialer dialog box

Choose a Quick Dial phone number from the Phone Dialer dialog box

The three check boxes in the lower right corner of the Phone Dialer dialog box determine whether 
buttonFile will perform the corresponding function:

Get Outside Line

Long Distance

Log This Call
You can turn on or off any of the functions for a particular call by choosing the appropriate
check box. For example, if you are placing a long distance call and you want to log the 
call, turn on (X in the box) the Long Distance and Log This Call check boxes. If you want 
to place a local call and not log the call, turn off both the Long Distance and Log This Call 
check boxes.

NOTE: In order for dialing to work properly, the phone's handset MUST be down until buttonFile is 
finished dialing the number.

NOTE: If the phone number begins with the local area code and the Long Distance check box is not 
checked and the local area code has been entered into the Phone Dialer Configuration dialog box, 
the area code will not be dialed.

To dial a number directly from a card
1. Display the card you want to dial from. (Dont lift the phone handset yet.)

2. Select (highlight) the phone number you want to dial on the current card.

3. Choose Dial from the Phone menu, press , or click 

buttonFile displays an information box. First, it will indicate: Connecting to Modem, then 
Initializing Modem, then it will display the message, Dialing - xxx-xxxx, where xxx-xxxx is the phone 
number you are dialing. 

4. Lift the handset when dialing stops and choose OK (or press ) to clear the dialing 
information box.

To dial a number from the current card using the Phone Dialer dialog box
1. Display the card you want to dial from. Dont lift the phone handset.

2. Choose Dial from the Phone menu, press , or click 

The Phone Dialer dialog box displays. If buttonFile only finds one number in the card, that 
number will display in the Phone Number text box. If buttonFile finds more than one phone number in the 
card, each number will display in the Card Numbers list box. See Making a Data Box Available to the 
Phone Dialer .
3. Change the status of any of the check boxes (Get Outside Line, Long Distance Call, or Log This 
Call) at this time, if desired.



4. If buttonFile only found one number, choose Place Call to dial that number. If there is more than 
one number, double-click on the desired number to place the call, or highlight it and choose Place Call. 
The phones handset must still be down at this point for dialing to work.
5. buttonFile displays an information box. First, it will indicate: Connecting to Modem, then 
Initializing Modem, then it will display the message, Dialing - xxx-xxxx, where xxx-xxxx is the phone 

number you are dialing. Lift the handset when dialing stops and choose OK (or press ) to clear the 
dialing information box.

To dial a number not on the current card

1. Choose Dial from the Phone menu, press , or click 

2. Type the number you want to dial in the Phone Number text box.
You can change the status of any of the check boxes (Get Outside Line, Long Distance Call, or 

Log This Call) at this time, if desired.
3. Choose Place Call.

4. Lift the handset when dialing stops and choose OK (or press ) to clear the dialing 
information box.

To dial a number using Quick Dial buttons

1. Choose Dial from the Phone menu, press , or click 

2. Select (highlight) the desired phone number from the Quick Dial list box.
You can change the status of any of the check boxes (Get Outside Line, Long Distance Call, or 

Log This Call) at this time, if desired.
3. Choose Place Call.

4. Lift the handset when dialing stops and choose OK (or press ) to clear the dialing 
information box.

Note: The phone numbers used for each Quick Dial button and their descriptions must be
entered using the Phone Dialer option on the Configuration menu as described in 
Configuring the Phone Dialer .

Related Topics...

Print Your Phone Log 

Making a Data Box Available to the Phone Dialer 



Printing Your Phone Log
If you choose the Log This Call check box when dialing, buttonFile keeps track of the phone calls 
youve made. This information is saved to a file that has the same file name as your deck with a .LOG 
extension. A deck named PHONE.BTN, would have a log file named, PHONE.LOG. You can view and
print this file using Windows Notepad, Windows Write, or a word processor. You can also import the 
file into a deck of its own and print it as a buttonFile report, if you wish. The advantage of printing after
importing the file into its own deck, is that you can format your report. If you print with Notepad, Write, 
or a word processor, you can print the file as is or format it manually.

To print the log file with Notepad, Write, or a word processor
1. Start Notepad or Write by clicking on its icon in the appropriate Program Manager

group window (this is normally the Accessories group window). Or start your word
processing application the way you normally do.

2. Choose Open from the File menu, if you are using Notepad or Write. Choose 
the .LOG file using the File Open dialog box. It will have the same name as your 
deck with a .LOG extension. Refer to your Windows documentation, or the Help 
menu option if you are unsure how to open a file with Notepad or Write. If you are
using some other word processor or editor, open the .LOG file as you normally 
would (the log file is an unformatted ASCII file).

3. Choose Convert, if you are using Windows Write.

4. Format the file if you wish, and choose Print from the File menu, if you are using 
Notepad or Write. Otherwise, print as you normally would if you are using some 
other word processor.

5. If you want to save the newly formatted file, make sure to use the Save As option 
on the File menu to save the file to a name other than the original .LOG file 
name.

To print the phone log file by importing it into a deck
1. Start buttonFile and choose Open from the File menu.

File Open dialog box displays. 

2. Change drive or directory, if necessary.

3. Choose Comma Delimited from the List Files of Type list box.

4. Type *.log in the File Name text box.

5. Press .
Any available log files display in the Files list box.

6. Choose the .LOG file you want to import.
buttonFile scans the file and displays the Import - Examine dialog box.

7. Choose OK.
The Change Deck Index dialog box displays. The Box_1 data box which contains the date will be 

indexed.
8. Choose OK.

Importing starts. When importing is finished, an information box displays.
9. Choose OK, to start using the new deck. If you want, you can choose Redefine from the File 
menu to rename and rearrange data boxes.
10. Choose New Report from the Print menu to format a custom report. Or choose Print Report from 
the Print menu to print using one of the two default reports. See the procedures in Chapter 6 for details on
how to design and print reports.





Importing: Opening Data from Other Programs
You can import data from other file formats using the same dialog box used to open buttonFile decks. 
Choosing Open from the File menu displays the Open dialog box

Use the List Files of Type list box to tell buttonFile what kind of data file to open. Scrolling through the 
List Files of Type list box displays four options in addition to the buttonFile and TakeNote options. 
Each import type defaults to searching for all files with a standard extensions.

File Type Default Extension
dBase III or PC-File .DBF

Comma-delimited (mail merge) .CSV

Microsoft Cardfile .CRD

WordPerfect 5.1 Secondary Merge .WP

If the file you want to import was saved using a different extension, after selecting which kind of file to 
import, you can change the extension to search for in the File Name text box, or type the full file name
in directly.

After an import file is selected, buttonFile scans the file and prepares to create a simple card layout 
for each field it detects. Since dBase files contain an internal header that defines each fields name 
and length, buttonFile is able to read this information and create appropriately named data boxes with
the correct lengths. When importing Comma Delimited and WordPerfect 5.1 Merge file formats, 
buttonFile assigns arbitrary data box names (box_1, box_2, and so on) for each field it detects. 
Additionally, each record is scanned to determine the appropriate data box length to use for each 
field.

During the scanning process, this dialog box displays:

If you want to change data box names or lengths , you can do so at this time by highlighting an item in the
New Deck Structure list and choosing the Modify button. This displays the Edit Data Box Structure dialog 



box:

Using this dialog box, you can edit or change the name of the data box using the Name text box. You can 
also modify its data length using the Length text box. And you can change the data box to a notes box by 
choosing the Notes Box check box (NOTE: You can only have one notes box per deck. If another data 
box is already designated as a notes box, choosing this option for another data box will turn it off for that 
data box.). The data displayed next to Sample: comes from the first record scanned in the import file, and 
is intended to aid you in giving data boxes appropriate names. If you prefer, you can change the data box 
name after the import process is complete using the Redefine option on the File menu instead.
Since Microsoft Cardfile files are a free form entry (no data boxes/fields), no scanning is necessary. 
buttonFile simply converts the first line to a data box and places the remaining data in a Notes Box.

In all cases, you can rearrange and rename data boxes after the import process is through using the 
Redefine option on the File menu. See Redefining Decks for details on how to redefine a deck.

Note: To bring data into a buttonFile deck from another program and combine that data with a pre-
existing buttonFile deck, first import the data into its own deck, as described above, then use the 
Merge option on the File menu. See Merging Decks for details on how to merge decks.

Import data from dBase III+, Comma Delimited, or WordPerfect 5.1 Merge 
files:

1. Choose Open from the File menu.

The Open dialog box displays.

2. Select the kind of file you want buttonFile to open from the List Files of Type list 
box.

3. If necessary, change the drive or subdirectory you want buttonFile to search 
using the Drives and/or Directories list boxes.

4. If the file you want to open was not saved using the default file extension, type *. 
followed by the extension to search for into the File Name text box and press

. For example, to search for .WS files, type *.WS and press 

.
5. Choose the desired file from the Files list box.

Note: If you know the name and location of the desired file, you can skip steps 3, 4, and 5 by 
typing the full path name (drive, subdirectory and filename with extension) into the File Name text box. 
For example, to open the file named ADDRESS.WP on the C drive, in the \DATA subdirectory type    c:\
data\address.wp into the File Name text box.
6. Choose OK.

The Import Examine dialog box displays showing the results of the scanning process.

7. If you want to modify data box names, lengths, or types at this time follow these 
steps:

Highlight an item in the New Deck Structure list box.



Choose the Modify button.

The Edit Data Box Structure dialog box displays

Edit the data box name using the Name list box.

Edit the length using the Size list box.

Choose the Notes Box check box to designate a Notes Box (only one per deck).

Choose OK.

Repeat these steps for each item you want to modify.

8. Choose OK to continue the importing process.

The Change Index dialog box displays.

9. Change the index definition if you wish. 

10. Choose OK.

An information box displays when the import process is complete.

11. Choose OK.

The import process is finished. Choose Save    from the File menu to save the new deck. 
Choose Redefine from the File menu to modify the deck layout and data box names.

To import data from Microsoft Cardfile files
1. Choose Open from the File menu.

The Open dialog box displays.

2. Select Microsoft Cardfile from the List Files of Type list box.

3. If necessary, change the drive or subdirectory you want buttonFile to search 
using the Drives and/or Directories list boxes.

4. Choose the desired file from the Files list box.

Note: If you know the name and location of the desired file, you can skip steps 3 
and 4 by typing the full path name (drive, subdirectory and filename with 
extension) into the File Name text box. For example, to open the Cardfile file 
named ADDRESS.CRD on the C drive, in the \DATA subdirectory type    c:\data\
address.crd into the File Name text box.

5. Choose OK.

The Change Index dialog box displays.

6. Change the index definition, if you wish. 

7. Choose OK.

An information box displays when the import process is complete.

8. Choose OK.

The import process is finished. Choose Save from the File menu to save the new deck. 
Choose Redefine from the File menu to modify the deck layout and data box names.

Related Topics...

Merging Decks 

Exporting 

Redefining Decks 





Exporting: Saving Decks to Other File Formats
Using the Save As option of the File menu, buttonFile can save a copy of a deck in these file formats:

TakeNote 1.0 (.TN files)

dBase III+ or PC-File (.DBF files) 

Comma-delimited (.CSV, MailMerge files) 

Microsoft Cardfile (.CRD files)

WordPerfect 5.1 Secondary Merge (.WP files) 

This allows you to use buttonFile data with other programs. You can also use this option to save a 
copy of a deck as a buttonFile file under a new name. Check the documentation for the program you 
want to import buttonFile data into to see if it can accept buttonFile export file formats.

Selecting the Export File Format
To choose which format to export to, make sure the deck you want to export from is 
current, then choose the Save As option from the File menu. Then pull down the List Files
of Type list box. The List Files of Type list box shows all the file type options for saving, 
the last five options are the export file types.

To start the export process, select the file type to export to from the List Files of Type list 
box.

Selecting Which Cards to Export
After you have selected the file type to export to, type the name you want to save the 
export file under in the File Name text box. Then choose OK, which displays the Export 
dialog box (except for TakeNote format, which saves directly without using the Export 
dialog box):

The Export dialog box lets you select which cards will be exported, and you can specify 
the order data boxes will be exported in.

To export the data from all cards, choose the All Cards option button. When you start exporting, 
all cards from the current deck will be included in the export file.

To export selected cards, choose the Selected Cards option button. After you specify the export 
order (see below) and choose OK to start exporting the Find dialog box displays.

The options on this dialog box are essentially the same as the Find dialog box. See 
Searching for Cards    for details on how to enter a search to select cards.

Specifying the Export Order
The Data Box Name and Export Order list boxes and the buttons between them let you 
specify which data boxes to include and the order they will be saved in the export file. 

If you want to include all data boxes in the same order as your buttonFile deck, choose 
Add All--this transfers all the data box names into the Export Order list box.

If you want to select only certain data boxes and/or specify a different order, you need to 
perform a two-step procedure for each data box you want to include in the export file:

Select the data box you want to include from the Data Box Name list box.

Choose the Add button.

Each data box you select is added to the Export Order list in the order you picked it. You 
can perform the same operation with the mouse in one step by double-clicking on each 
data box you want to include in the Data Box Name list box.



If you make an error, or if you prefer to add all of the data boxes first and then remove 
some, you can perform a similar two-step procedure to remove data boxes from the 
Export Order list box:

Select the data box you want to remove from the Export Order list box.

Choose the Remove button.

You can perform the same operation with the mouse in one step by double-clicking on 
each data box you want to remove from the Export Order list box.

Using the Save As option to export to a different file type
1. Open the deck you want to save to a different format.

2. Choose Save As from the File menu. 

The Save As dialog box displays.

3. Choose the file format to save as from the List Files of Type list box.

4. If necessary, change the drive or subdirectory you want buttonFile to search 
using the Drives and/or Directories list boxes.

5. Type the file name you want to save to in the File Name text box. If you don't 
supply an extension buttonFile automatically supplies an appropriate file 
extension.

6. Choose OK.

The Export dialog box displays.

7. Specify whether to export all or selected cards by selecting the appropriate option
button from the Export Which Cards area.

8. To export all data boxes in the same order as your deck:

Choose Add All
All data box names are moved to the Export Order list box.

9. To export some data boxes and/or to specify a different export order:

Select a data box to export from the Data Box Name list box.

Choose Add. (Instead of these two steps you can double-click on each data box you want to 
include.)

Repeat these steps for each data box you want to include, in the order you them exported.

10. Choose OK to start exporting.

11. If you selected the Selected Cards option button in step 7, the Export Selected 
Cards dialog box displays. Enter your search and choose OK.

An information box displays indicating the rate of progress.

Related Topics...

Searching for Cards 

Saving a Deck 





Template Definitions
buttonFile comes with 13 deck templates. Each template provides a pre-defined deck layout and one 
or more reports. You can use templates as they are to define a deck, or you can use them as a 
starting point for defining your own customized deck design. See Creating Decks with Templates and 
Designing Your Own Decks for details on how to use either of these two methods of defining decks.

Available Templates
Book Library Music Library 

Business Cards Notes 

Credit Cards Personnel Records 

Data/Boxes Recipes 

File Folders Rolodex 

Home Inventory Software Library 

Mailing List Video Library 

Book Library

Data Box Name Length
Title 50
Index 50
Author 50
Publisher 50
Catalog number 20
Year published 5
Volume 10
Number 5
Pages 4



Genre 30
Subject 50
Description 200
Notes 8192

Predefined Reports
Index Card (3 x 5 - laser)
Index Card (3 x 5 - pin)
Bibliography



Business Cards

Data Box Name Length
First Name 20
Middle Initial 15
Last Name 30
Title 50
Company 50
Address 1 50
Address 2 50
City 25
State 5
Zip + 4 10
Country 25
Phone 25
Fax 15
Home 15
Cellular 25
Category 50
Notes 8192

Predefined Reports
Card (3 x 5 - laser)
Card (3 x 5 - pin)
Envelope (9½ x 4 - landscape)
Envelope (9½ x 4 - portrait)
Address Label (3½ x 15/16 - pin)
Address Label (4 x 1 2-across - laser)
Phone List



Credit Cards

Data Box Name Length
Type 30
Institution 50
Address 35
City 35
State 5
Zip + 4 10
Card number 20
Expiration 5
Cardholder 50
PIN 28
Credit limit 11
Call if lost 20
Cust. Service 20
Notes 8192

Predefined Reports
Index Card (3 x 5 - laser)
Index Card (3 x 5 - pin)
Credit Card Information



Data/Boxes

Data Box Name Length
Data Box 1 75
Data Box 2 75
Data Box 3 75
Data Box 4 75
Data Box 5 75
Notes 8192

Predefined Reports
Page Report



File Folders

Data Box Name Length
Main Heading 50
Sub Heading 50
Cabinet Location 35
Drawer 15
Contents 8192

Predefined Reports
File Label (3½ x 7/16 - laser)
File Label (3-7/16 x 2/3 2-across - pin)
Listing of Files



Home Inventory

Data Box Name Length
Item 50
Make/Model 50
Serial number 30
Location 50
Purchase date 20
Purchase price 15
Purchased from 20
Current value 15
Insured value 15
Warranty expires 20
Notes 8192

Predefined Reports
Index Card (3 x 5 - laser)
Index Card (3 x 5 - pin)
Home Inventory



Mailing List

Data Box Name Length
First Name 30
Last Name 30
Address 1 50
Address 2 50
City 25
State 2
Zip + 4 10
Phone 15
Phone 2 15
Country 25

Predefined Reports
Mailing Labels



Music Library

Data Box Name Length
Title 100
Artist 50
Composer 50
Conductor 35
Soloist 35
Category 30
Label 50
Catalog number 15
Producer 35
Engineer 35
Year 4
Tracks 8192
Date 25
Medium 20
Tape number 10

Predefined Reports
Cassette Tape Label (laser)
Music Inventory
Title & Tracks



Notes

Data Box Name Length
Notes 8192

Predefined Reports
Notes



Personnel Records

Data Box Name Length
First Name 20
Middle Initial 2
Last Name 30
Title 50
Department 30
Supervisor 30
Date Hired 20
Birthday 20
Phone 25
Home 20
Social Security 11
Address 50
City 20
State 2
Zip + 4 10
Emergency 25
Contact 30
Notes 8192

Predefined Reports
Index Card (3 x 5 - laser)
Index Card (3 x 5 - pin)
Address Label (3½ x 15/16 - pin)
Address Label (4 x 1 2-across - laser)
Emergency Contacts



Recipes

Data Box Name Length
Title 50
Category 50
From 50
Servings 20
Calories 8
Time to prepare 20
Fat 8
Recipe 8192

Predefined Reports
Recipe Card (3 x 5 - laser)
Recipe Card (3 x 5 - pin)



Rolodex

Data Box Name Length
First Name 20
Middle Initial 2
Last Name 30
Company 40
Address 1 40
City 20
State 2
Zip + 4 10
Country 30
Work 25
Home 15
Birthday 20
Notes 8192

Predefined Reports
Card (3 x 5 - laser)
Card (3 x 5 - pin)
Envelope (9½ x 4 - landscape)
Envelope (9½ x 4 - portrait)
Address Label (3½ x 15/16 - laser)
Address Label (4 x 1 2-across - pin)
Phone List



Software Library

Data Box Name Length
Product 30
Version 10
Company 50
Serial# 25
Registered 50
Purchased 20
From 30
Tech support 20
Support plan 20
Customer servic 20
Notes 8192

Predefined Reports
Index Card (3 x 5 - laser)
Index Card (3 x 5 - pin)
Software Registrations



Video Library

Data Box Name Length
Title 50
Category 30
Year made 4
Rating 5
Review 10
Date taped 20
Format 20
Tape number 12
Start 6
End 6
Length 30
Notes 8192

Predefined Reports
Video Cassette Label (face)
Video Cassette Label (spine)
Video Library Listing





buttonFile Program and Data Files
Program Files
BUTNFILE.EXE

The main buttonFile program file.

BUTNFILE.HLP
This file contains buttonFile's on-line help system. If you delete this file you will not be 
able to access the on-line help information.

BUTNWARE.DLL
This file contains information essential to run buttonFile.

COMMDLG.DLL
This file contains information essential to run buttonFile under Windows 3.0. You can 
safely delete it if you are running under Windows 3.1 or higher.

CTL3D.DLL
This file contains information essential to run buttonFile

MUSCROLL.DLL
This file contains information essential to run buttonFile.

WBTRCALL.DLL
This file contains information essential to run buttonFile.

READ.ME
A text file containing additional information. You can read this file with any word 
processor, editor, or file viewer that reads ASCII files, such as Windows Notepad.

SOFTWARE.BTN
This is a sample buttonFile deck for entering software registration information. You can 
safely delete it, if you will not be using it.

buttonFile Data Files
deckname.LOG

This is the disk file that contains a log of decknames phone dialing activity. See Printing 
Your Phone Log    for details on how to use this file.

deckname.PRE
This file is a security and work space file. This file will be about 50K plus 10% of the deck 
file (.BTN) size. For example, if the deck file is 500K, the .PRE file will be about 100K 
(50K + (500K x .1)). To be able to open a deck, you must have sufficient disk space 
available to open the .PRE file.

Ordinarily, you will not see this file on disk. It is deleted when your deck is closed. 
However, this file may be left on your disk if buttonFile was terminated abnormally: loss of
power or program crash.

deckname.BTN
This file contains the data you enter into your buttonFile deck. Be sure to make backup 
copies of this file on a regular basis.





Chapter Listing Of Procedures
CHAPTER 1: Getting Started With buttonFile

Welcome To   button  File   

Requesting Technical Support 

Requesting Customer Service 

Before You Begin 

Installing   button  File   

Un-installing   button  File   

Confirming Installation 

Registering Your Copy Of   button  File   

Converting From TakeNote 1.0 

CHAPTER 2: Making Yourself At Home With buttonFile
Starting And Exiting   button  File   

Edit Menu Options 

Working With Application Windows 

CHAPTER 3: Creating And Configuring Decks
Creating Decks With Templates 

Designing Your Own Decks 

Working With Frames 

Configuring Decks 

Saving A Deck 

Closing the Deck Designer 

Redefining Decks 

CHAPTER 4: Working With Decks
Opening A Deck 

Saving A Deck 

Deleting A Deck 

Adding Cards 

Deleting And Undeleting Cards 

Duplicating Cards 

Editing Cards 

Using The Edit Menu 

Merging Decks 

CHAPTER 5: Navigating And Searching
Switching Views 

Adjusting Table View Column Widths 



Navigating 

Searching For Cards 

Search And Replace 

CHAPTER 6: Printing Cards, Labels, And Reports
Introduction To Report Designing And Printing 

The Available Report Dialog Box 

The Report Designer Workspace 

Forms 

Configuring Report Fonts 

Adding and Modifying Frames 

Setting Frame Attributes 

Working With Frames 

Placing Frames For Special Formatting 

Saving a Report Design 

Exiting a Report Design Session 

Summary Of The Report Design Process 

Printing 

CHAPTER 7: buttonFile Dialing Features
button  File Dialing Requirements   

Configuring The Phone Dialer 

Using The Phone Dialer 

Printing Your Phone Log 

CHAPTER 8: Exchanging Data With Other Programs
Importing: Opening Data From Other Programs 

Exporting: Saving Decks To Other File Formats 

APPENDIX A:
Template Definitions 

APPENDIX B:
button  File Program And Data Files   

APPENDIX C:
Error And Information Messages 



Alphabetic Listing Of Procedures
-A-
Adding a Notes Box in the Deck Designer 

Adding Data Box Frames in Reports 

Adding Report Frames 

Adding Line and Box Frames in Reports 

Adding Notes Box Frames in Reports 

Adding System Data Frames in Reports 

Adding Text Frames in Reports 

Adding Card Elements in the Deck Design 

Adding Cards to a Deck 

Adding Data Boxes in the Deck Designer 

Adding Text in the Deck Designer 

Adjusting Table View Column Widths 

Arranging Icons 

The Available Reports Dialog Box 

-B-
Before You Begin Using   button  File   

Browsing in Card View 

Browsing in Table View 

button  File Dialing Requirements   

button  File Program and Data Files   

button  File's Requirements   

-C-
Cascading Windows 

Case Sensitive Searching 

Changing Forms in Reports 

Checking the Contents of Your package 

Choosing a Pre-defined Form 

Choosing How Many Copies to Print 

Choosing Which Cards to Print 

Closing a Deck Window 

Closing All Windows And Icons 

Closing the Deck Designer 

Closing Windows 

Configuring a Deck Description 

Configuring Deck Colors 



Configuring Deck Fonts 

Configuring Deck Security 

Configuring Decks 

Configuring ENTER to Work Like TAB 

Configuring Report Fonts 

Configuring the Index 

Configuring the Phone Dialer 

Confirming Installation 

Continuing a Search 

Controlling Whether a Data Box Name Shows 

Controlling Whether a Note Box Name Shows 

Converting   button  File Decks to TakeNote Decks   
Converting From TakeNote 1.0 

Converting TakeNote Decks to   button  File Decks   
Copying Deck & Report Design Elements 

Creating Decks with Templates 

Customer Service 

Customizing the Work Area for Daily Use 

Cutting Deck & Report Design Elements 

-D-
Defining a Custom Form 

Deleting a Deck 

Deleting a Report 

Deleting and Undeleting Cards 

Deleting Deck & Report Design Elements 

Deleting Selected Information on a Card 

Desigining a Deck by Patterning After a Template 

Designing a Deck by Patterning After Another Deck 

Designing a Deck From Scratch 

Designing a New Report 

Designing Your Own Decks 

Directing Printer Output to a Disk File 

Duplicating Cards 

-E-
Edit Menu Options (introduction) 

Editing Cards 

Entering Search Text 



Error and Information Messages 

Exiting a Report Design Session 

Exiting   button  File   

Exporting: Saving Decks To Other File Formats 

-F-
Forms 

-G-
Group Selection (introduced) 

Group Selection in Deck Windows 

Group Selection in the Designer Windows 

-H-
Headers and Footers 

-I-
Identifying What is Selected in the Designers 

Importing: Opening Data From Other Programs 

Installing   button  File   

Introduction to Designing Your Own Decks 

Introduction to Redefining a Deck 

Introduction To Report Designing And Printing 

Item Selection in Deck Windows 

Item Selection in the Designer Windows 

-M-
Making a Data Box Available to the Phone Dialer 

Making Windows Active 

Mapping Data Boxes 

Match Whole Word Only in Searches 

Maximizing a Window 

Merging All or Selected Cards 

Merging Decks 

Minimizing A Window 

Modifying a Data Box Length 

Modifying a Data Box Name 

Modifying a Deck Structure Using the Merge Feature 

Modifying a Notes Box Name 

Modifying an Existing Report 

Modifying Data Box Frames in Reports 

Modifying Deck & Report Element Attributes 



Modifying Line and Box Frames in Reports 

Modifying Notes Box Frames in Reports 

Modifying Report Frames 

Modifying System Data Frames in Reports 

Modifying Text Alignment in the Deck Designer 

Modifying Text Frames in Reports 

Modifying Text in the Deck Designer 

Modifying the Data Box Length 

Moving Deck & Report Design Elements 

Moving Windows 

Multi-Selection Editing 

-N-
Navigating in Deck Views 

-O-
Opening a Deck 

Opening   button  File Windows   

Other Search Options 

-P-
Pasting Deck & Report Design Elements 

Pasting Multi-Selected Information 

Placing Frames For Special Formatting in Reports 

Print Preview 

Printer Setup 

Printing (procedures) 

Printing a Report (introduction) 

Printing Reports 

Printing Your Phone Log 

-Q-
Quick Dials 

-R-
The Redefine Process 

Redefining Decks 

Registering Your Copy Of   button  File   

Resizing Elements 

Resizing the Form 

Resizing Windows 

Resolving Duplicate Data Box Names 



Resolving Overlapping Elements 

Restoring A Window Or Icon 

Restoring Default Reports 

-S-
Saving a Deck or Deck Design 

Saving a Report Design 

Searching explained 

Search and Replace 

Search Direction 

Search Speed and the Index 

Searching for Cards 

Selecting a Data Box to Search In 

Selecting Multiple Elements in the Designer Windows 

Selecting Single Elements in the Designer Windows 

Selecting the Search Type 

Setting Report Frame Attributes 

Single Selection Editing in Decks 

Sizing the Card 

Sounds Like Searches 

Starting   button  File   

Summary of the Report Design Process 

Switching Views 

-T-
Technical Support 

Template Definitions 

Tiling Windows 

Turning the Button Bar On and Off 

-U-
Un-installing   button  File   

Using an Additional Comparison 

Using Dialog Boxes 

Using the Edit Menu 

Using the Index Buttons 

Using the Phone Dialer 

-W-
Welcome To   button  File   

Working With Application Windows 



Working With Frames 



Before You Begin
Checking the Contents of Your Package 

button  File's Requirements   





The buttonFile Screen
buttonFile is organized like most Windows programs, with easy-to-use pull-down menus, dialog 
boxes, command buttons and movable, resizeable windows. We've also added some additional 
features to make using buttonFile as convenient as possible: the icon buttons on the button bar and 
the index buttons.

buttonFile lets you open more than one window at a time within the workspace--much like the 
Windows Program Manager. This means you can be working on several projects in buttonFile all at 
the same time. Microsoft refers to applications that have the ability to open several windows at the 
same time as an MDI (Multiple Document Interface) application. Windows located within buttonFile's 
workspace are referred to as child windows.

Here is a list of the three types of child windows in buttonFile.

Click on an item in the list below to find out more about it.

Deck Window 

Deck Designer Window 

Report Designer Window 



Deck Window
Deck windows are the most common type of window in buttonFile. This is where you add, modify, and
delete, and search for data. There are two ways to open a deck window: Open a deck, or create a 
new deck from a template.

buttonFile can display your data in one of two ways--Card View or Table View . Each type of view is 
shown below.

CARD VIEW:    Click on a screen element to learn more about it.

TABLE VIEW:    Click on a screen element to learn more about it.





Deck Designer Window
Deck windows contain a re-sizable area to define the dimensions of the card for the deck you want to 
create. You design the deck by placing text, data boxes and notes boxes on the card area. Open a 
deck designer window by choosing New on the File menu, and then choosing one of the design 
methods in the Source list box on the New dialog box.

Click on a screen element to learn more about it.

Related Topics...

Designing Your Own Decks 



Report Designer Window
There are three ways into the report designer window:

Choose the New Report option from the File menu.

Click 

 or press 

 + 

. Then choose the New button from the Available Reports dialog box.

Click 

 or press 

 + 

. Choose a current report from the Available Reports dialog box, and then choose the Modify button.

A report designer window displays in one of three modes depending on the kind of form you are 
designing. After you've chose then form, you design your report by placing different printing elements 
(text frames, data box frames, notes box frames, system frames, and line or box frames) on the form 
where you want them to print.

Click on a screen element to learn more about it.

Related Topics...

Introduction to Report Designing and Printing 





Terms and definitions
- A -
access order 

active window 

anchor point 

AND Searches 

- B -
buttonFile icon 

- C -
card 

card number 

card view 

cascading 

case sensitive 

check box 

child window 

clear 

clipboard 

command button 

communications port 

control-clicking 

copy 

corner radius 

custom form 

cut 

- D -
data box 

data box frames 

data box length 

data box name 

data font 

deck 

deck description 

deck fonts 

deck structure 

default report 

delete 



dial method 

dialog box 

double click 

dragging-and-dropping 

drop-down list box 

- E -
element 

encryption 

ENTER works like TAB 

export 

- F -
fill pattern 

font size 

font style 

footer 

form 

frame 

frame attributes 

frame buttons 

- G -
get outside line 

group selection 

- H -
header 

- I -
import 

index 

index buttons 

index font 

index line 

index text 

initialization 

item selection 

- L -
line/box frame 

line style 

list box 



LOG file 

long distance 

- M -
match whole word only 

maximize 

maximums 

MDI (multiple document interface) 

merge 

minimize 

multi-selection 

- N -
name font 

name text 

name text box 

navigating 

notes box 

notes box frame 

- O -
option buttons 

OR searches 

- P -
page size 

password 

paste 

path 

phone number data 

portrait 

print entire 

printer font 

- Q -
quick dial 

- R -
redefine 

report data font 

report text font 

restoring 

rulers 



-S -
scroll bars 

scroll box 

selection frame 

sheet size 

shift-clicking 

show name 

single selection 

smart paste 

sounds like 

source deck 

spin box 

system data 

system font 

system frame 

- T -
table view 

target deck 

template 

text box (dialogs) 

text box (decks) 

text font 

text frame 

tiling 

title bar 

TrueType font 

- U -
undo 

- W -
wildcard 



access order

The data box access order is the order the cursor moves when pressing  while adding or editing 
data.    This order is always set left to right, top to bottom when you save your deck. That is, the top 
leftmost data box will be first in the access order, any data box to its right will be next, and so on 
across the first row of data boxes, then the leftmost data box on the second row of data boxes is 
accessed, the next one to its right, and so on until all rows are accessed.

After saving the deck, you can use the Redefine option on the File menu to rearrange data boxes and a 
new access order will be established when you save the redefined deck.



anchor point

The data box with a dotted box inside it: 
The anchor point indicates which was the most recently selected (or unselected frame), and is also used 
for determining where the selection will extend to when using Group Selection.



active window
The windows that is on top, or the window in which you are currently working. Usually the active 
window's title bar is a different color than the other windows' on the screen. You can also see which 
window is active, by clicking on the Window menu--the active window will have a check-mark next to 
it.



AND searches
An AND search will find cards where each card must contain both of the search items. For example, 
using an AND search to search for "Cooper" in the Last Name and "Maine" in State will only find 
cards contain both Cooper and Maine.





buttonFile icon

Double-click on this icon in the buttonFile group in Windows Program Manager to start buttonFile. The
same icon appears on the Windows screen when buttonFile has been minimized.



card
Each separate entry in a buttonFile deck is called a card. A card in buttonFile performs the same 
function as a card in a physical card file like a library card file, or a box of 3x5 cards filled with 
addresses, recipes, personnel information, etc. A card is comparable to what is typically called a 
record in most database programs.



card number
The cards sequential number in the deck according to the index. The card number is determined by 
the current index--it does stay with the card if you re-index the deck on a different set of data boxes.

In card view, you can see the card's number on the right-hand side of the button bar. In table view, the
card numbers are listed in the first column of the table.



element
Elements are the "building blocks" of a card and reports

The following items are card elements:

data boxes

notes boxes

card text
The following items are report elements:

data box frames

text frames

system frames

line/box frames
Add, arrange, and edit these elements to create a custom card decks and reports.



card view
A buttonFile deck displayed in card view looks much like the cards in a library card file, or a Rolodex. 
The front card displays all the data boxes for that card. Only the index lines of the cards that follow 
display above the front card. buttonFile displays as many index lines as will fit within the card window.

When browsing through cards in Card View, the cards are displayed in a continuous loop like an old-
style Rolodexwhen you browse forward past the last card in the deck, the first card is displayed and 
vice versa.



cascading
The Cascade option on the Window menu resizes and stacks all open windows in the work space so 
that every windows title bar is visible. Any window icons are arranged at the bottom of the work 
space. All windows, open or minimized will be visible.



case sensitive
Select the Case Sensitive check box if you want buttonFile to search for the exact characters you 
typed in your card. For example with this option selected, if you typed Smith as your search text, 
"SMITH" and "smith" would not be found, only cards contain "Smith" would be found.



clear
Choosing Clear from the Edit menu removes the highlighted information in the data box(es). Clear is 
the same as pressing delete--the information that is cleared is NOT placed on the clipboard. See 
delete also.



clipboard
The Clipboard is a temporary storage area in Windows which allows you to exchange information 
between different documents within an application and between different applications. Clipboard 
operations (cut, copy & paste) are usually located on an application's Edit menu. The standard 
procedure for using the clipboard is as follows:

Select the information you want to transfer

Choose Copy or Cut on the Edit menu--this places the information on the clipboard.

In the same application or in another application, choose Paste--the information on the clipboard 
is inserted into the current windows application.



child window
Child windows are windows contained within the buttonFile application (the "parent" window). Decks, 
Deck designs, and Report designs are the three types of child windows you will see in buttonFile.



communications port
Communications ports are the serial ports on your computer. They are named COM1, COM2, COM3, 
or COM4.



control-clicking
Control-clicking is synonymous with Item selection. Control-clicking is performed by holding down 

the  key and clicking the left mouse button. 



copy
Copying elements copies the selected element(s) to the clipboard and leaves the selected elements 
in their current location. You can then paste the copied information to a different Deck designer 
window or back into the original Deck designer window.



corner radius
The Corner Radius spin box specifies how rounded box corners are. The default value of zero 
produces square corners. Entering a value in the Corner Radius spin box defines the radius (in 
inches) of the circle used to produce the rounded corner.



custom form
A card, label, or report form whose dimensions, margins, column and row numbers, header and footer
dimensions are defined by the user. Custom Forms can be based upon an available form, or they can
be defined from scratch.



cut
Cutting elements copies the selected element(s) to the clipboard and deletes the selected elements 
from their current location. You can then paste the copied information to a different Deck designer 
window or back into the original Deck designer window.



data box
The text boxes within a card are called data boxes. A data box is used to store information that falls 
into a particular category, such as a persons name or social security number. A data box is basically 
the same as a field in most database programs. Generally each data box has a label to its left 
indicating the kind of data you enter into it. However, sometimes the label refers to a group of data 
boxes. For example, the single label Name may appear to the left of three separate data boxes for 
first name, middle initial and last name. 

Data boxes contain any kind of character data (letters, numbers, or symbols). Data boxes hold a 
single line with from 1 to 256 characters. A data box can contain more characters than can be 
displayed at once. This depends on the size of the font you are using, the defined data length, and 
the dimensions you determine when defining the data box. When you define a data length longer than
the dimensions of the data box, data scrolls within the data box. A card can have up to 40 data boxes 
(including up to one Notes box). Normally a data box shows its name to the left of the data entry area,
but you can turn this off so the name does not show.

NOTE: buttonFile does not have data boxes for specific data types: Numeric, Date, Money, Time, and
so on. This does not mean that you cannot enter these kinds of data in buttonFile data boxes, but 
they will not be handled any differently from other text entries.



data box frames
A data box frame in a report design tells buttonFile where and how to print information from your 
decks data boxes.

Like all report frames, a data box frame prints as much text as fits within its dimensions. When you 
initially select which data box to print in the frame, the frame is automatically sized to the data box 
storage length and is proportional to the size of the Report Data Font (the font displayed when 
choosing Report Data Font from the Fonts submenu). Resizing a frame to more than one line high 
causes data box information to wrap to additional lines. If a frame is not sized large enough to print all
of a data boxs information, the extra information is truncated (chopped off).



data box length
You can specify how many characters a data box can store using the Length text box on the button 
bar or Data Box Attributes dialog box. The default length is 25 characters. The minimum number of 
characters is 1, and the maximum number of characters is 256. 

The data box length only determines how many characters can be typed into a data box, not how 
many characters are displayed. If a data box frame is not long enough to fit the number of character 
specified for the length at once, the data scrolls within the data box. You can adjust the display width 
of the data box by selecting and adjusting the frame. Also, the number of characters that fit in the 
displayed area of a data box varies depending on the font and size of the data font.



data box name
The data box describes, in general terms, what type of data is stored in that data box.    Examples are:
Last name, Phone number, and Occupation are examples of appropriate data box names. 

When designing decks, you can use up to 16 characters and spaces to name a data box. As you add 
data boxes, buttonFile automatically assigns arbitrary names, Name_1, Name_2, and so on. The text 
of this arbitrary name is automatically selected when you first add a data box so you can immediately 
type in your own name to replace the arbitrary name. After selecting a data box, you can edit its name
at any point during the deck designing process. Or you can redefine the deck at any time to change 
the name.



data font
The font used to display the information in Data boxes and Notes boxes



deck
The file which contains your cards' data. A deck is basically the same as a "database". Deck files 
have a BTN extension.



deck description
Using the Deck Description option on the Configure menu, buttonFile lets you enter a description for 
your deck up to 30 characters long. This description is displayed on the deck window title bar 
following the deck's file name when the deck is a child window. If the deck is fully maximized, the 
description displays on the main buttonFile window title bar. The deck description also displays at the 
bottom on the File open dialog box when opening decks.



deck fonts
buttonFile lets you configure what fonts and point sizes are used for displaying information on your 
cards. buttonFile gives you independent control over the screen fonts for the following card elements:

Data Font

Name Font

Text Font

Index Font
buttonFile defaults to using Arial if you are running under Windows 3.1 with TrueType fonts active, or 
Helv/MS San Serif, if you are running under Windows 3.0 or have TrueType fonts disabled under 
Windows 3.1 .

Choosing certain fonts and point sizes may require you to resize card elements to properly display the
text or data. Also, if you are planning on sharing your deck with others or using your deck on more 
than one computer, you should be aware that the fonts on your system may not be available on 
another system. If Windows cannot find a matching font, it will provide the closest match it can find. 
However, there is no guarantee that the font Windows provides will display properly--you may need to
resize the card elements or choose a different font or point size.



deck structure
The deck structure is the "definition" of your deck. It consists of the following information:

How many data boxes are on the card.

How much information can each data box hold.

The names of each data box.



default report
The Default Page Report and Default Row Report are automatically created when you define a new 
deck from scratch. Both reports contain all the data boxes in your deck. The default reports are rarely 
exactly what you want print, but they provide good starting points to define other reports. You can 
easily start a report design by modifying a default report, deleting or rearranging the data boxes to get
the desired result. Both default reports are defined using the Report 8½ x 11 Letter (portrait) form.

A Default Page Report prints all data boxes using the same layout as the cards in your deck.

A Default Row Report prints all the data boxes in row format. If all data boxes won't fit on a single 
line, the data boxes are wrapped to additional lines.



delete
Choosing Delete from the Edit menu removes the highlighted frame(s). This is the same as pressing 
delete--the information that is deleted is NOT placed on the clipboard. See clear also.



dial method
The options buttons in the dial method specify which dialing method is used with your phone 
connection. This generally corresponds to the kind of phone you are using: For push-button phones, 
choose Tone. For rotary (dial) phones, choose Pulse.



double-click
Clicking your left mouse button twice quickly without moving the mouse pointer.

Double-clicking on an item or objet is often a shortcut for selecting the item and choosing some other 
action.



dragging-and-dropping
Clicking down with left mouse button, moving the mouse pointer and the accompanying icon to a new 
location, and releasing the left mouse button.



encryption
Encrypting scrambles the data file so that it cannot be read directly from the disk. This provides an 
additional level of security beyond the password.



ENTER works like TAB

When the ENTER works like TAB option is checked on, pressing the  key will move the cursor 
between data boxes in access order. You still need to use 

 to move backward in the access order. Turning ENTER works like TAB on, makes entering data into
cards simpler, if you are used to pressing 

 to advance to a new data box.
The ENTER works like TAB option also affects how the ENTER key works when editing the contents of a 

Notes box. When this option is turned off, pressing  adds a new line in a Notes box. When this 
option is turned on, you must press 

 + 

 to add a new line in a Notes box.



export
Exporting data means writing your information out to a file on disk in a different format. Exporting is 
most commonly used when you want to transfer a large amount of information to another program, or 
when you want to convert your data for use with another program.



fill pattern
The fill pattern is the pattern used to fill a box in the report designer. A box's fill pattern can be clear, 
solid black, shades of gray, or one of several patterns.



font size
The size of the chosen font in points (1/72"). The options available will depend on the font you have 
selected--not all fonts have the same size options.



font style
The font allows you to define a variation on the font type you have chosen. Regular, bold, italic, bold-
italic are standard font-style options. The options available will depend on the font you have selected. 
Not all fonts will have all four style options.



footer
The bottom area of the page where you generally print page numbers, or other system data. Footers 
are only available on Report forms.



form
A form specifies the dimensions of the paper you will be printing on, including margins, rows and 
columns depending upon the form type. There are three types of forms:.

Card form
Prints the information from your deck in a card format. Used for printing index cards, post 
cards, Rolodex cards, and envelopes. Depending on the definition of the card form, one 
or more columns and rows may print per page. One cards data is printed per card, 
envelope, etc. 

Label form
Prints the information from your deck in a label format. Used for printing on any label 
stock supported by your printer. Depending on the definition of the label form, one or 
more columns and rows may print per page. One cards data is printed per label. 

Report form
Prints the information from your deck on a full page: tabular (row) reports, custom reports,
form letters, and so on. Report forms provide a resizable header and footer. Depending 
on how you lay out your report on a report form, information from one or more cards may 
print per page.



frame
Each element on a card or a report is defined by placing a frame. A frame can be re-sized or moved 
using either the mouse or the keyboard. When a frame is selected, a border like a window border is 

displayed. Select a frame by clicking on it with the mouse or by pressing  until the desired 
frames border becomes active. 



frame attributes
In the deck designer, frame attributes determine what the frame's name is, how much it can hold, 
whether it is available to the phone dialer, and whether the frame's name shows on the card.

In the report designer, frame attributes determine what a frame prints and how it will print it, including 
alignments and styles.



frame buttons
The frame buttons are used to create different kinds of data boxes and to create screen text.

Adds card text in the deck designer. Adds a text frame in the report designer.

Adds a data box in the deck designer. Adds a data box frame in the report designer.

Adds a notes box in the deck designer.

Adds a system frame in the report designer.

Adds a box frame in the report designer.



get outside line
Choosing the Get Outside Line check box causes buttonFile to send the prefix entered when 
configuring for dialing--usually 9 for most PBX systems.



group selection
Group selection lets you select a group of elements (data boxes or frames) that are physically next to 
each other or that are adjacent to each other in access order.



header
The topmost area of the page. Generally this is the area where you might print things like a title, 
column headings, dates, etc. Headers are only available on Report Forms.



import
Importing data means bringing information into buttonFile that comes from a file on disk that was 
created by a different program in a different format than buttonFile uses. Importing    is most 
commonly used when you want to transfer a large amount of information from another program, or 
when you want to convert another program's data for use with buttonFile.



index
The index is what causes your cards to be sorted (ordered) in the sequence you see on the screen. 
For example, indexing on the last name will cause buttonFile to display your cards in alphabetical 
sequence according to last name. You can choose whether to sort the contents of a data box in 
ascending order (A to Z) or descending order (Z to A). buttonFile sorts spaces first; non-letter, non-
numeric characters second, letters third, and numbers last.

Up to three of the data boxes can be used to sort the cards. Those data boxes display on the index 
line in the order they are sorted in. The leftmost data box on the index line is the first level the cards 
are sorted by, for example, Last Name. The middle data box is the second level the cards are sorted 
by, for example, First Name. The rightmost data box is the third and last level the cards are sorted by, 
for example, Middle Initial. 



index buttons
The lettered and numbered buttons displayed below the menu bar when a deck window is open are 
called index buttons.

Clicking on an index button displays the first card in the group that begins with that letter or number. If
there is no card that begins with the letter you clicked, buttonFile displays the first card of the next 
group it finds following that letter. For example, if you click on the M index button, but the deck has no 
M, N, or O cards, the first P card is displayed. The blank index button on the left end calls up the first 
card in the deck. 

The keyboard equivalent to clicking on an index button is 

 + letter.
The index buttons are not displayed if Show Button Bar is not checked on the Configure menu.



index font
The font in which Index Text on the index line is displayed



index line
The top line of each card is called the index line. The index line shows how the cards are sorted, like 
the top line of a card in a library card file. The data boxes used to make the index display on the index
line. The leftmost data box on the index line is the first level the cards are sorted by, for example, Last
Name. The middle data box is the second level the cards are sorted by, for example, First Name. The 
rightmost data box is the third and last level the cards are sorted by, for example, Middle Initial. 



index text
The text that appears on the index line.



initialization
This is a set of characters used to reset your modem and send it the proper information so that it will 
dial phone numbers correctly.



item selection
Item selection lets you select multiple elements (data boxes or frames) one at a time regardless of 
whether the elements are next to each other or not.



landscape
This refers to the orientation in which you're printer will print on the page. In most printers, landscape 
orientation is means "sideways".



line style
Line style determines the thickness and number of lines displayed by a line or box frame in the report 
designer.



line/box frame
Line/box frames can print vertical lines, horizontal lines, or boxes with a choice of line styles. With 
boxes you also have the choice of a fill pattern and rounded corners.



LOG file
Choosing the Log This Call check box causes buttonFile to save a record of phone call in a phone 
call log file. This file has the same name as your deck file, but its extension is LOG instead of BTN.



long distance
Choosing the Long Distance check box causes buttonFile to send the prefix entered when 
configuring for dialing--1 for most long distance carriers.



match whole word only
Select the Match Whole Word Only check box if you want buttonFile to find exact matches for the 
search text. For example, if you are using a Begins With search on "Smith" and choose the Match 
Whole Word Only option, only "Smith" entries will be found.    However, using the same search text 
with the Match Whole Word Only option turned off will find "Smith," "Smithers," "Smithson," and so on.



maximize
Maximizing a child windows expands it so that it fills the entire buttonFile work space. You can also 
maximize the main buttonFile application window so that it fills your entire Windows screen.



maximums
Decks

Item Maximum
simultaneous open decks

windows
Limited only by available 
memory and system resources

simultaneous open deck 
design windows

Limited only by available 
memory and system resources

simultaneous open report
design windows

1 per deck

indexes per deck 1
data boxes per index 3
cards per deck Limited only by disk space 

(recommended limit is 200,000)

Deck Designs
Card Element Max. Characters Max. per Card
data box 256 40 (including notes box)
data box name 16 --
notes box 8192 (8K) 1
notes box name 16 --
text 64 40
total characters 

(no notes box)
-- 10240

total characters 
(including notes
box)

-- 18176

Report Designs
Report 
Element

Max. Enterable 
Characters

Max. Printable 
Characters

Max. per 
Report

data box frame 100 9000 50
text frame 100 256 50 (combined 

text, system and
line/box frames)

system frame 100 256 50 (combined 
text, system and
line/box frames)

line/box frame n/a n/a 50 (combined 
text, system and
line/box frames)

form size 22" x 22"

MDI (multiple document interface)
buttonFile lets you open more than one window at a time within the work space, much like the 
Windows Program Manager or File Manager lets you run multiple applications at the same time. 
Microsoft refers to this kind of Windows program as a Multiple Document Interface (MDI). The 
windows that reside within the main (parent) application window are referred to as child windows. 

In buttonFile, each of the child window types perform different functions. As a result, the options on 
the menu bar and the button bar will change depending on which kind of child window is active. For 
example, there is no Tools menu when a deck window is active, and the Edit menu has different 
options depending on what kind of child window is active. 



merge
Merging allows you to combine the cards in one buttonFile deck with the cards in another deck. 
Essentially, it adds a copy of the cards in the "source" deck to the cards in the "target" deck, but it 
does not combine information to produce a composite card. Also note, that the "source" deck remains
unaffected by the merge.



minimize
You can reduce any child window to an icon on the buttonFile work space. This is called minimizing. 
This allows you to have several windows available, without cluttering the work area with overlapping 
or hidden windows.



multi-selection
buttonFile also allows you to select, copy, and paste more than one element or data box. When multi-
selecting data in data boxes, you can only select the entire contents of each selected data box.



name font
The font for Data box and Notes box name text (when using Show Name)



name text
The text used to display a data box or notes box name (when using Show Name)



name text box
The name text box which appears on the button bar when a data box is selected in the deck 
designer is used to specify the active data boxs name.



navigating
Navigating refers to any of the various methods of browsing through a deck. Methods of navigating 
include:

The options on the Navigate submenu on Search menu

The navigation buttons and index buttons on the button bar

The navigation short-cut keys.



notes box
A buttonFile card can have one scrolling, multi-line notes data box. You can enter up to 8,192 (8K) 
characters (including spaces) in a notes data box. Notes data boxes have a scroll bar on the right 
side for scrolling through the contents of the data box.

A Notes box is used to contain longer passages of text like memos or long descriptions. A card can 
have only one Notes box. A Notes box can hold up to 8192 characters (8K) of informationyou can not 
change this length. Notes box text wraps to the width you define when sizing the Notes box. Like a 
data box, a notes box normally shows its name to the left, but this can be turned off.



notes box frame
A notes box frame prints either all or part of your decks notes box data.

Because notes data boxes can contain over 8000 characters, the report designer creates a special 
type of frame to accommodate printing this much text. Notes box frames say either "entire" or "partial"
in them to indicate how much of the notes box data will print in the frame.



OR searches
An OR Search will find any card that contains either one or both of the search items. Searching for 
"Cooper" in Last Name and "Maine" in State as an OR search, will find all cards with the last name 
"Cooper" regardless of the entry for State, and all cards with the State as "Maine" regardless of the 
entry for Last Name.



page size
The dimensions of the page or sheet you will be printing on.



password
A password can contain any keyboard characters, except for spaces, and can be up to 8 characters 
long. Letter characters are not case-sensitive. For example, if you type in an uppercase "A" as part of 
your password definition, a lowercase "a" will be accepted later. However, all non-alphabetic 
characters are case-sensitive. For example, on a U.S. keyboard, an "8" is treated as a different 
character from the "*" (asterisk), even though they are located on the same key.



paste
Pasting places the information that is currently stored on the Windows Clipboard and places it in the 
current application window, usually beginning at the cursor or the selection.



path
The path is the location of a file(s) in the directory tree--the location of a file on the hard disk. For 
example, if you accepted all the defaults when installing buttonFile, the path where buttonFile is 
located is designated as "\BUTNFILE". See your DOS manual for further information on paths.



phone number data
If you want to be able to use buttonFiles dialing feature to dial phone numbers stored in a data box, 
you must first specify that the particular data box will be used as a phone data box. The data box 
must have the "Phone" check box selected.



portrait
This refers to the orientation in which you're printer will print on the page. In most printers, portrait 
orientation is the default (upright) mode.



print entire
When you add a notes box frame to a report, the Print Entire check box option is added to the button
bar. By default, the Print Entire option is turned off. The Print Entire check box is also available when 
displaying the Data Box Attributes dialog box.

If you leave Print Entire off, (partial) is displayed inside the frame following the notes box name. When
printing a partial notes box frame, buttonFile prints as much data box information as will fit within the 
frames dimensions. Frames sized more than one line high wrap data box information to additional 
lines. If a frame is not sized large enough to print all of a data boxs information, the extra information 
is truncated (chopped off).

If you turn on Print Entire, (entire) is displayed following the notes boxs name. The entire contents of 
the notes box will print continuously for as many pages, labels, or cards as required. The printed 
information is wrapped to the width of the notes box frame. The height of the frame has no effect on 
the how much of the notes box information will print. A shaded band displays below the frame and 
extends to the bottom of the form . The shaded band indicates that the length of the data printed may 
fill the balance of the form and beyondnotes boxes can contain as many as 8192 characters. As a 
general rule, you should not place any frames below a notes box when the Print Entire check box is 
turned on.



printer font
Printer fonts are fonts either that are part of your printer's memory, or they are "soft" fonts that are 
sent to your printer before printing a document. Printer fonts may appear different on the screen than 
they do when printed, because Window's may not have all the information to display the font correctly.
Printing documents using printer fonts is usually faster than using other fonts.



quick dial
A phone number which you can store and dial at any time. Quick dials are available at any time, 
regardless of which deck is current. Use quick dials to store your most commonly dialed phone 
numbers.



redefine
Redefining a deck allows you to change the visual appearance of a deck without actually changing its 
structure. You can change the size of the card, rearrange and resize data and notes boxes, and add 
or delete text.



report data font
The report data font is the font that will be used to print data from data and notes boxes--the contents 
of data box frames.



report text font
The report text font is the font that will be used to print all constant text--the contents of text frames 
and system data frames.



restoring
Restoring a window or icon returns the window to its previous state. When a child window is 
minimized, buttonFile remembers whether the window was fully maximized or, if the window was not 
maximized, the size and location of the window within the work space is remembered. Also, if a 
window is maximized, the original size and location of the window is remembered. And, if an icon is 
maximized, the location of the icon is remembered.



rulers
The top and left edges of the report designer workspace have rulers marked in inches. The rulers are 
there to aid in placing and aligning frames, and in determining sizes and proportions. When you select
a frame(s), the rulers show where the outer edges of the frame are on the report form.



selection frame
Clicking and holding on a point outside the elements you want to select creates an anchor point. 
Dragging the mouse forms a selection box. Releasing the mouse button selects all elements the 
selection box is touching. This means you don't have to be very accurate when selecting multiple 
elements--as long as the selection box is touching the elements bordering the group you want select, 
those elements and any others within the box will be selected. 



sheet size
The dimensions of the page or sheet you will be printing on.



shift-clicking

Pressing and holding the  key, then clicking on elements or data boxes with the mouse pointer.



show name
You can specify whether to show a data or notes box's name on the card you are designing. The 
default is to show the name. If you dont show the name, the data will still be accessible for printing, 
searching, sorting and other operations, using the name stored internally.



single selection
Selecting one element in a designer window, or selecting some or all the data in just one data box in a
deck window.



smart paste
The Smart Paste on the Edit menu pastes the copied information into data boxes that are named 
identically to the data boxes on the card you copied from. This works for all data boxes when smart 
pasting within the same deck, but may only copy into some or no data boxes when smart pasting into 
another deck. The Smart Paste option will not be available if the information on the clipboard was not 
copied from a buttonFile deck.



sounds like
Checking the Sounds Like check box will search for data that sounds like the data you entered for 
your search text. For example, if you entered "Johnson", cards containing "Jonson" and "Johnston" 
will also be found.



source deck
When Merging decks, the deck that card information is read from is called the source deck. 



system data
System data is used to print system information such as the current date and time, page numbers, or 
the report name. Each time you print a report with system data frames, such as date or time, the 
frames will print the current information.



system font
System fonts are a type of Screen font. System fonts are the fonts Windows uses to display menus, 
messages, and dialog box text. They are designed for displaying on the screen. Your printer may be 
able to print a system font accurately, or it may have to find a substitute font for printing.



system frame
Prints system data such as page numbers, the current date, or the report name.



table view
Table View displays and allows you to edit your decks information in a rows and columns, much like a
spreadsheet or database table. 



target deck
The deck that card information is read from is called the source deck. The deck that new card 
information is merged into is called the target deck.



template
A buttonFile template is a pre-defined design which determines the overall dimensions of a deck's 
cards; the size and location of each data box and how they are labeled; and how much information 
can be entered into each data box. Each template is available by name when using the New option 
on the File menu.



text box
Using the Text button or the Text option on the Tools menu allows you to define a string of up to 64 
characters on your card. Text wraps to the width you define when sizing the text frame. You can place
up to 40 text elements. You can use text to label a group of data boxes that dont show their names. 
For example, you could place First Name, Middle Initial, and Last Name data boxes without showing 
their names and then place text to label the group Name. You can also place text for other purposes: 
a title, data entry instructions, and so on. 



text font
The font for card text placed using the Text option on the Tools menu in the Deck designer.



text frame
Use text frames to print text and information not stored as data in your deck.

A text frame displays and prints as much text as will fit within its dimensions--up to 100 characters. 
Frames sized more than one line high wrap text to additional lines. If a frame is not sized large 
enough to show all the text you entered, the additional text is truncated (chopped off).



tiling
Tiling rearranges and resizes all open windows so that they entirely fill the work space with no 
overlapping. The Tile Vertical option arranges the tiled windows vertically (top to bottom). The Tile 
Horizontal option arranges the tiled windows horizontally (right to left). If all windows are open (not 
minimized as icons), the entire work space will be filled. If any windows are minimized (icons), a 
space is left at the bottom of the work space and icons are arranged in a row in that space. All 
windows, open or minimized will be visible.



title bar
The title bar contains the title and other information about that window or dialog box.

buttonFile's title bar contains the buttonFile program name and version number. buttonFile child 
window title bars list the deck's, deck design's, or report design's name and description.



TrueType font
TrueType fonts are fonts that can be made any height. When printed, they look the same as they do 
on the screen.



undo
Choosing Undo reverses the most recent action you performed. Usually the action is listed to the right
of Undo on the menu so you know what will happen if you choose the Undo option. You can only 
undo an action immediately after doing it. Most, but not all buttonFile options are undo-able.



wildcard
Entering wild card characters in search text tells the program to accept any character in that position. 
buttonFile provides two wildcard characters: the question mark (?) and the asterisk (*).

The question mark (?) wildcard character is used to indicate any single character is accepted in that 
position. For example, if you type: t?o as your search text, cards containing two, too, tao, and so on, 
would be found. You can use more than one question mark wildcard in any position in the search text

The asterisk (*) wildcard character is used to indicate any group of characters is accepted in that 
position. While you can use the asterisk wildcard character anywhere in a search string, it only really 
makes sense to use it at the beginning or in the midst of your search text. For example, if you type: 
*ing, cards containing data ending with ing will be found: changing, raining, and so on. An example 
using the asterisk wildcard between other characters in the search text: r*g would find raining, rug, 
rag, and so on. You can even use more than one asterisk wildcard if you wish: r*g*d would find 
ragged, rugged, raged, and so on.





The New Deck Dialog Box
When you choose New on the File menu displays the New dialog box. This dialog box is used for 
creating new decks .

Click on an area for an explanation of its function

Related Topics...

Creating Decks with Templates 

Designing Your Own Decks 



Template list box
This list box contains a list of all the available predefined templates . Just choose the template you 
want, and press OK to create a new deck based on that template.

Related Topics...

Template Definitions 



Source drop-down list box
Pulling down the Source list box displays three options in addition to "Create Deck from Template":

Design Deck From Scratch

This option lets define a new deck from scratch by defining each element of the new 
deck. See Designing a Deck From Scratch here 

Design Deck Patterned After Deck

This option lets you start defining your new deck using the same layout as a previously 
created deck. See Designing a Deck Patterned After Another Deck .

Design Deck Patterned After Template

This option lets you start defining your new deck using the same layout as one of 
buttonFiles templates. See Designing a Deck Patterned After a Template .





The Open Dialog Box
When you choose the Open or Merge options on the File menu, the Open dialog box displays. This 
dialog box is used for selecting a deck or other file to open or import.

Click on an area for an explanation of its function

If you choose to open a file type other than buttonFile or TakeNote files, the Import Examine dialog 
box displays after you press the OK button on the Open dialog box. At this point in the importing 
process, buttonFile will "pre-scan" your file if necessary to determine the proper lengths to make all 
the data boxes. This ensures that you data will not be truncated or lost (within the limitations of 
buttonFile).

Using this dialog box, you can edit or change the name of the data box using the Name text box. You 
can also modify its data length using the Length text box. And you can change the data box to a notes
box by choosing the Notes Box check box (NOTE: You can only have one notes box per deck. If 
another data box is already designated as a notes box, choosing this option for another data box will 
turn it off for that data box.). The data displayed next to Sample: comes from the first record scanned 
in the import file, and is intended to aid you in giving data boxes appropriate names. If you prefer, you 
can change the data box name after the import process is complete using the Redefine option on the 
File menu instead.

Click on an area for an explanation of its function



Related Topics...

Importing 

Opening a Deck 



File Name list box
The File Name list box shows all the buttonFile deck files for the currently selected drive and 
directory. To select a file you can either type in the name in the edit box, or click on a file name in the 
list box.



Drives list box
To open a file on a different drive, choose a new drive using the Drives list box. 



Directories list box
To open a file in a different directory, double-click on the desired directory in the Directories list box. 
The Files list box will be updated to show all the buttonFile decks available in the new location. To 
move up a level in the directory tree of the current drive, double-click on the open file folder icon 
above the current directory in the Directories list box. For example, if the current directory is c:\
butnfile, and you want to open a file from another directory off the root directory of the C drive, 
double-click on the open file folder icon to the left of c:\ in the Directories list box.



List Files of Type list box
The options in this list box allow you to choose what type of file you want to open or import . The 
default is buttonFile deck files (type BTN).

NOTE: If you are Merging decks, this list box only lists buttonFile (BTN) files.

The options available include:

File Type Default Extension
TakeNote .TN
dBase III or PC-File .DBF
Comma-delimited (mail merge) .CSV
Microsoft Cardfile .CRD
WordPerfect 5.1 Secondary Merge .WP

Use the List Files of Type list box to tell buttonFile what kind of data file to open. Scrolling through the 
List Files of Type list box displays four options in addition to the buttonFile and TakeNote options. 
Each import type defaults to searching for all files with a standard the standard extension listed 
above. You can change the extension to search for in the File Name text box, or type the full file name
in directly.

After an import file is selected, buttonFile scans the file and prepares to create a simple card layout 
for each field it detects. Since dBase files contain an internal header that defines each fields name 
and length, buttonFile is able to read this information and create appropriately named data boxes with
the correct lengths. When importing Comma Delimited and WordPerfect 5.1 Merge file formats, 
buttonFile assigns arbitrary data box names (box_1, box_2, and so on) for each field it detects. 
Additionally, each record is scanned to determine the appropriate data box length to use for each 
field.

During the scanning process, the Import - Examine dialog box will appear after you press the OK 
button on the Open dialog box.

Related Topics...

Importing 





Examining File
This information line lists the path and name of the file being examined (pre-processed) for importing. 
This is the file you chose on the Open dialog box.



Records Examined
The Records Examined number tells you how many "records" have been examined.    The number is 
constantly updated to inform you of the progress.



Stop button
The stop button was provided so that you can abort the examine process before it is finished. 

Generally you should only stop the examine process if you are importing a file with a lot of data (over 
10,000 records.) If you are importing a large file, and you can see the data box lengths shown in the 
New Deck Structure list box aren't changing, click on the Stop button. Then you can Modify any of the
names and lengths, or press OK to proceed with importing. 



Continue button
Press the Continue button if you accidentally pressed the Stop button, or if you want to resume pre-
processing the file before importing.



New Deck Structure list box
The New Deck Structure list box lists the proposed deck structure for the new deck that will be 
created to hold the data you are importing. Names and Lengths are listed. If you want to change data 
box names or lengths , you can do so at this time by highlighting an item in the New Deck Structure 
list and choosing the Modify button.



Modify button
Clicking on the Modify button after you have selected an item in the New Deck Structure list box 
brings up the Edit Data Box Structure dialog box.

Using this dialog box, you can edit or change the name of the data box using the Name text box. You 
can also modify its data length using the Length text box. And you can change the data box to a notes
box by choosing the Notes Box check box (NOTE: You can only have one notes box per deck. If 
another data box is already designated as a notes box, choosing this option for another data box will 
turn it off for that data box.). The data displayed next to Sample: comes from the first record scanned 
in the import file, and is intended to aid you in giving data boxes appropriate names.





The Merge Dialog boxes
Use the Merge option on the File menu to combine the data from two or more decks into one deck. 
Merging reads all or selected card information from a selected deck and copies it as new cards into 
the deck that was current when you chose the Merge option.

To start the merge process, you must first open the target deck or make its window active. Then, 
when you choose Merge from the File menu, the Open dialog box displays to allow you to select the 
source deck to merge data from:

Click on an area for an explanation of its function

After choosing the source deck, the Merge Mapping dialog displays:

Click on an area for an explanation of its function



The Merge Mapping dialog box lets you map information from data boxes in the source deck into data
boxes in the target deck . Mapping determines which data boxes in the target deck will be filled with 
information from data boxes in the source deck. 

You can choose to map all information from the source deck into the target deck or only some. For 
example, you may not want to copy some information from the source deck, there may be too few 
data boxes in the target deck to contain all information, or some data box contents may not 
correspond with data boxes in the merge deck. 

Related Topics...

Merging Decks 



Merge Which Cards
The option to merge all or selected cards allows you to merge a subset of the source decks cards 
with the target deck.

If you choose Selected cards, after you choose OK to continue the merge process the Find dialog box
displays to allow you to select which cards to include.



Map From list box
All the data box in the source deck are listed in the Map From list box. Plus, there are some 
"separators" listed below the data boxes which can aid you when mapping more than one source data
box into a    target data box.

Choose a data box whose data you want to go into a data box in the target deck. Then click on the on
the Map button to map it to the currently selected data box in the Map To list box.

If you double-click on a data box in the Map From list box, it will automatically be mapped to the data 
box currently selected in the Map To list box.

Related Topics...

Mapping Data Boxes 



Map To list box
All the data boxes in the target (current) deck are listed in the Map To list box. When you map a data 
box from the Source deck into a data box listed in the list box, the source data box appears to the 
right.

The data box that is highlighted in this list box will receive the data from the Map From data box when
the Map button is chosen.

If you double-click on a data box in the Map To list box, it will automatically "Remove" its mapping.

Related Topics...

Mapping Data Boxes 



Map button
When you press the Map button, the data box currently selected in the Map From list box will be 
mapped to the data box currently selected in the Map To list box.



Map All button
Choosing the Map All button simply maps each list from top to bottom. Generally, this will only give 
you the desired results if the structure of both decks matches for all data boxes. However, if many of 
the data boxes match, this may be a good way to start. After mapping all, you can undo only the 
incorrect mappings and proceed from there.



Remove button
If you make an error or change your mind while mapping, you can highlight that line in the Map To list 
and choose the Remove button to undo the mapping.



Remove All button
Choosing the Remove All button undoes all mappings. The dialog is reset to what it looked like when 
it first appeared.



Map Description
The description of the current mapping selection appears in the description area. Use this area as a 
helpful reminder if you get confused about what pressing the Map button will do.





The Save/Save As Dialog Box
The first time you choose to Save a deck, the dialog box below will appear to allow you to give the 
deck a name. Each time you save after the first time, the deck will be saved to the name you gave it 
originally.

If you want to create an identical deck with a new name, use the Save As option. Choosing Save As 
also allows you to export your data to other file formats.

Click on an area for an explanation of its function

If you to choose to Save As a file type other than buttonFile, the Export dialog box displays.

Click on an area for an explanation of its function

Related Topics
Saving a Deck or Deck Design 



Exporting 



File Name text box
The name you enter into the File Name text box must be a valid DOS file name: no more than 8 
characters, containing only alphabetic, number or underscore characters. Spaces, commas, 
backslashes, and periods arent valid. buttonFile automatically supplies the default extension .BTN.

If you want to save the file to a different drive or directory, you can type in the full path and filename. 
Or you can change the settings in the Directories and Drives list boxes. Alternatively, you can indicate
the drive and subdirectory by typing it in front of the file name in the File Name text box. For example: 
c:\data\myfile



Directories list box
The drive and directory displayed immediately below the text Directories is where the new deck will 
be saved. If you want to save the deck in a different location, choose a different directory by double-
clicking on the file-folder icons in the Directories list box.



Drives list box
To save the file on a different drive, choose a new drive using the Drives list box.



List Files of Type list box
The options in this list box allow you to choose what type of file you want to export your data to. The 
default is buttonFile deck files (type BTN).

The options available include:

File Type Default Extension
TakeNote .TN
dBase III or PC-File .DBF
Comma-delimited (mail merge) .CSV
Microsoft Cardfile .CRD
WordPerfect 5.1 Secondary Merge .WP

Each type defaults to searching for all files with a standard extension. You can change the extension 
to search for in the File Name text box, or type the full file name in directly.

If you choose one of these export formats, buttonFile will allow you to choose which data boxes and 
which cards to export on the Export dialog box.





Export Which Cards
To export the data from all cards, choose the All Cards option button. When you start exporting, 

all cards from the current deck will be included in the export file.

To export selected cards, choose the Selected Cards option button. After you specify the export 
order and choose OK to start exporting the Find dialog box displays. The options on this dialog box are 
essentially the same as the Find dialog box .



Data Box Name list box
This list box lists the names of all the data boxes in the deck you're exporting. Choose each files in 
the order want it's data to go into the export file, and press the Add button to place it in the Export 
Order list box. You can choose to export all or only some of the data boxes in your deck.

Alternatively, you can double-click on a data box name, and this will add it to the Export Order list box,
shortcutting the Add button.



Export Order
This list box lists the names of the data boxes whose data will go into the export file. The order in 
which they are listed is the order in which they will be written to the file.

Double-clicking on a data box name in this list box will remove it from the list.



Add button
Pressing the Add button, adds the currently selected data box in the Data Box Name list box to the 
Export Order list box at the highlight. If there is no highlight in the Export Order list box, the data box 
is added at the bottom.



Add All button
Choosing the Add All button, adds all the remaining data boxes in the Data Box Name list box to the 
Export Order list box.



Remove button
Pressing the Remove button, removes the currently selected data box from the Export Order list box. 
If there is no highlight in the Export Order list box, the Remove button is grayed out.



Remove All button
Choosing the Remove All button, removes all the data box names from the Export Order list box



Export Format and File
The top line in this area of the dialog box lists the type of file that will be created.

The second line list the path and name of the file that will be created.





Using The Available Reports Dialog Box

Choosing the Print Report option on the File menu, or clicking  on the button bar displays the 
Available Reports dialog box. The Available Reports dialog box is the main pathway into buttonFiles 
printing and report designing features.

Click on an area for an explanation of its function

Related Topics...
The Available Reports Dialog 



Close button
Choose the close button to exit the dialog and return to the main program area.



Available Reports list box
The list box on this dialog lists all the reports available for the current deck. The reports are listed 
alphabetically by type (card, label, or report), and then by their name.

Select a report, and then choose the Modify, Delete, or Print button to perform that action on the 
selected report. If you double-click on a report, it is the same as selecting it and pressing the Print 
button.





The Forms Dialog Box
Choosing New Report from the File menu, the New button on the Available Reports dialog box, 

Change Form on the tools menu in the Report designer, or clicking on the  button brings up the 
Forms dialog box. This dialog box allows you to choose what type of form your report will print on:

Click on an area for an explanation of its function

Related Topics...
Choosing a Pre-defined Form 



Option buttons
The Card, Label, and Report option buttons on the top of the Forms dialog box specify which kind of 
form shows in the list box below.

Choosing the Card option button displays a list of cards and envelopes including Avery stock.

Choosing the Label option button displays a list of labels including a large variety of Avery and 
Dennison labels.

Choosing the Report option button displays a list of standard paper sizes in both portrait or 
landscape orientations.



Forms list box
Forms are sorted alphabetically by name and then by dimensions--the width of the card, label, or 
page is always listed first, followed by the height. 

The rightmost column in Card and Label lists contains additional information: either the kind of printer 
each form is appropriate for (dot matrix or laser), or a part numberunless indicated otherwise, this is 
an Avery part number.





The Print Dialog Box

Choosing Print from the Available Report dialog box, or clicking on the  button when in the 
Report Designer brings up the Print dialog box:

Click on an area for an explanation of its function

Related Topics...
Printing Reports 



Printer
This line displays which printer the report will be printed to. To change this setting, choose the Printer 
Setup button.



Report
This line displays which report you have selected to print. To change the report, press the Cancel 
button, and choose a different report on the Available Reports dialog box.



Copies spin box
The copies spin box specifies the number of copies for each card printed. If the This Card option 
button is selected, this specifies the number of copies to print of the current card. If the All Cards 
option button is selected, this specifies the number of copies to print of each and every card in the 
deck. If the Selected Cards option button is selected, this specifies the number of copies to print of 
each of the selected cards.



Which Cards option buttons
The three option buttons to the right of the copies spin box determine which of the decks cards will be
printed:

This Card:    The card that was on top of the deck when you started the print operation will be 
printed.

All Cards:    Every card in the deck will be printed.

Selected Cards:    Every card selected by the search entered using the Define Search button will 
be printed. The Define Search button will only become active after this option button is selected.



Summary of Selected Cards
A summary of which cards you have selected to print appears in this area. If you have chosen to print 
Selected Cards, the parameters of the search you defined after pressing the Define Search button 
appear here.





The Print Preview Dialog Box
The Print Preview button on the Print dialog box displays a reduced-size representation of each page 
that is about to be printed. This gives you a chance to see if you are getting the desired results before
you start printing.

Click on an area for an explanation of its function

Related Topics...

Using Print Preview 



Print button
If you are satisfied with the results, choosing the Print button prints your report on the current printer.



Next Page button
If you are printing no more than one page, the Next Page button will be unavailable. Otherwise, 
choosing the Next Page button displays the next page. The current page number is displayed in the 
upper left corner.



First Page button
Choosing the First Page button returns to the first printed page.





The Printer Setup Dialog Box
Using the Printer Setup button on the Print dialog box, you can configure options for the current 
printer, and if you have configured Windows to use more than one printer on different ports, you can 
choose a printer other than the default printer. The same options are available by choosing the Printer
Setup option on the File menu.

Click on an area for an explanation of its function

Related Topics...

Setting Up Your Printer 



Choosing a Printer
On the Printer Setup dialog box, the printer listed below the Default Printer option is your Windows 
default printer. Choosing the Specific Printer option activates the drop-down list box which shows all 
the printers you currently have installed for Windows. Choosing a printer from this list redirects 
buttonFiles output to that printer.

You cannot connect a printer to a different port or install a new printer using the Print Setup dialog 
box. You must use the Printers option of the Windows Control Panel to do this. Refer to your Windows
documentation for details on using the Control Panel.



Orientation
The options in the Orientation area of the dialog box will be active, if the current printer supports both 
portrait and landscape printing. Choose the Portrait option button to print in the standard orientation 
across the shorter dimension of the page. Choose the Landscape option button to print sideways 
across the longer dimension of the page.



Paper
The options in Paper area of the dialog box reflect the paper size and paper source options supported
by the current printer. These options will not be available for all printers.



Options button
Choosing the Options button on the Print Setup dialog box displays further settings available for the 
current printer. The options available are determined by the Windows printer driver you have loaded. 
For example, you may be able to control whether the printer prints in Draft or Letter Quality mode, or 
you may be able to choose which font cartridge to use. In most cases, there will be a Help button that 
will give you information on how to use the options that are available.





The Find Dialog Box
As your deck grows, you may find it easier to locate specific cards by having buttonFile search for 
specific data. Searching also allows you to specify a subset of data to print, export , or merge. You 
enter the criteria for searching on the Find dialog box:

Choosing either the And option button or the Or option button under Additional Comparisons expands 
the Find dialog box. Enter additional search text in the second Search for text box, choose the data 
box to search in, and choose the other search options as desired.

Click on an area for an explanation of its function

If you are in Card View when searching, the first card found that meets your search criteria displays at
the front of the deck. If you are in Table View when searching, that cards row displays. The text you 
searched for is highlighted. If no card is found, an information box will be displayed.

Related Topics...

How to Search 



Search For text
Type the text you want to search for in the Search For text box. You can type all or only part of the 
string of characters you want to find. You can also type wildcard characters into your search text. 
buttonFile provides two wildcard characters: the question mark (?) and the asterisk (*).

buttonFile keeps track of the last five search entries youve made in the current session. Clicking on 
the down arrow button to the right of the Search For text box displays a list of the five most recent 
search entries. Choosing a search entry from the list lets you reuse it.

How buttonFile will use the text you enter is determined by your choices for the other options on the 
Find dialog box.





The Replace Dialog Box
Choosing the Replace option on the Search menu displays the Replace dialog box. Use the Replace 
option on the Search menu to replace data in selected records. The options in the Search For 
grouping work identically to the same options used for a normal search.

The Replace feature works much like the a word processors search and replace feature: you enter 
the data to search for and the data to replace with -- then buttonFile lets you choose whether to 
confirm every replacement or to automatically replace all occurrences found. The Replace feature 
always searches starting from the card that was current when you initiated the Replace operation.

Click on an area for an explanation of its function

Related Topics...

Performing a Search and Replace 



Replace With text
Type in the text you want to replace the Search For text with.



Current Data
The matching data that is about to be replaced displays in the Current Data text box and the Replace 
button becomes active.



Find Next button
Choose Find Next to search forward from the current card. Or when a match is found, choose Find 
Next to skip to the next matching card. buttonFile stops when it finds a match to allow you to confirm 
whether to perform the replacement.



Find Previous button
Choose Find Previous to search backward from current card. Or when a match is found, choose Find 
Previous to skip to the previous matching card. buttonFile stops when it finds a match to allow you to 
confirm whether to perform the replacement.



Replace button
When a match is found, choose the Replace button to replace the data--buttonFile will continue to the
next match.



Replace All button
If you decide you want buttonFile to continue making replacements without interruption, you can 
choose Replace All. Choosing Replace All starts searching forward from the current card and does 
not stop for you to confirm replacements.





The Custom Form dialog box
If the form you want to print on is not available on the Forms dialog, you can create a custom form . 
You can only create a custom form by clicking the custom button on the Forms dialog box.

Click on an area for an explanation of its function

Related Topics...

Defining a Custom Form 





The Font Configuration Dialog Box
Choosing Fonts on the Configure menu displays a submenu to the right of the main menu. buttonFile 
gives you independent control over the screen fonts for the following elements:

Data Font 

Name Font 

Text Font 

Index Font 

Or..

Report Data Font 

Report Text Font 

The window that is active    when you invoke one of the submenu options is affected by the font 
choices you make--this can be either a Deck window, a Deck Designer window, or a Report Designer 
window. 

Choosing any one of the submenu options displays a font configuration dialog box. The Font dialog 
box provides control over the font, font style , and font size .

Click on an area for an explanation of its function

Related Topics...
Configuring Deck Fonts 

Configuring Report Fonts 



Font list box
All of the fonts available to your system are displayed in this list box. You can type in the name of the 
desired font in the text box, or click on a font name in the list box.



Sample Area
The Sample shows an example of text in the font, style, and size currently selected.





The Deck Colors Configuration Dialog Box
buttonFile lets you configure what colors are used for various card elements. The Colors option on the
Configure menu gives you control over the colors for the following card elements:

The window that is active when you invoke the Deck Colors dialog is affected by the color choices 
you make. This can be either a Deck Designer window or a Deck window. 

Click on an area for an explanation of its function

Related Topics...

Configuring Deck Colors 



Card Element list box
This list box contains a list of all the elements you can configure colors for. Choose an element from 
the list box, then choose a color from the Basic Colors area.



Card Element example
This is a sample card which reflects the current color configuration. You can also click on the different 
areas on this example instead of using the list box to select card elements. When you click on a card 
element, the list box will update to reflect the current choice. After you have chosen a card element, 
choose a color from the Basic Colors area.



Basic Colors
The Basic Colors area displays all the available colors. Choose a card element first, then click on the 
color you want that element to be.



Use Windows Control Panel Colors check box
You can use the Use Windows Control Panel Colors check box on the Colors dialog box to make your
deck colors match the settings used for Windows. By default, the Use Windows Control Panel Color 
check box is on. The card elements are assigned to your Windows colors as follows:

Name Text.....assigned to.....Window Text

Other Text.....assigned to.....Window Text

Card Background.....assigned to.....Window Background

Data Box Text.....assigned to.....Menu Text

Data Box Background.....assigned to.....Menu Bar

Index Text.....assigned to.....Button Text

Index Background.....assigned to.....Button Face





The Phone Dialer Configuration Dialog Box
After you have all required equipment hooked up, you need to configure buttonFile to recognize the 
kind of hardware youre using.

When you choose Phone Dialer from the Configuration menu, the Phone Dialer Configuration dialog 
box displays. Listed below are the different sections of the dialog box.

Click on an area for an explanation of its function

Related Topics...

Configuring the Phone Dialer 



Long Distance
The Long Distance check box determines whether the corresponding Long Distance check box on the
Phone Dialer dialog box defaults as checked. When dialing, you can turn the check box on the Phone
Dialer dialog box on or off regardless of the default you set here.



Get Outside Line
The Get Outside Line check box determines whether the corresponding Get Outside Line check box 
on the Phone Dialer dialog box defaults as checked. When dialing, you can turn the check box on the 
Phone Dialer dialog box on or off regardless of the default you set here.



Log the Call
This check box determines whether the corresponding Log This Call check box in the Phone Dialer 
dialog box defaults as checked. When dialing, you can turn the check box on the Phone Dialer dialog 
box on or off regardless of the default you set here.

When you choose to log a call, buttonFile writes a log file recording the date, time, phone number and
the person called. buttonFile will create a file with the same name as the decks file name with a .LOG 
extension. For example, if your decks file name is PHONE.TN, its phone log file would be named, 
PHONE.LOG.

Each line in the log file will be in this format:

Date, Time, Phone number, xxx 
where xxx is the data from the three data boxes on the index line of the card you dialed. This would 
be the persons name you dialed in most cases. See Printing Your Phone Log later in this chapter for 
instructions on how to print a list of your phone calls.



Long Distance Prefix
The Long Distance Prefix text box contains the number that is sent when the Long Distance check 
box on the Phone Dialer dialog box is checked. buttonFile supplies a default of 1, which is used by 
most long distance carriers. Type a different number or numbers in the text box if your long distance 
carrier requires a long distance prefix other than 1.



Outside Line Prefix
The Outside Line Prefix text box contains the number that is sent when the Get Outside Line check 
box on the Phone Dialer dialog box is checked. buttonFile supplies a default of 9, which is used with 
many office phone systems. Type a different number in the text box if your phone system requires a 
number other than 9.

The comma following the 9 causes the modem to pause briefly (two seconds on most modems) 
before dialing the phone number that follows. This gives the phone system a moment to activate the 
outside line before dialing begins. You may need to add additional commas if your phone system 
requires more time to activate an outside line.



Local Area Code
Type your local area code in the Local Area Code text box. If you enter area codes for all phone 
numbers in your deck (including local numbers), the area code will not be dialed if the long distance 
check box is off when dialing local numbers. For example, if a phone number data box contains (206) 
555-1212 and you have 206 entered in the Local Area Code text box, only 555-1212 will be dialed if 
the Long Distance check box is off. This lets you make your phone number decks portablewhen you 
are within the local dialing area, leave the Long Distance check box off; when you are outside the 
local dialing area, turn the Long Distance check box on.



Add button
Click on this button to add a quick dial phone number to the list of available quick dials.



Modify button
Clicking on this button allows you to modify the currently selected quick dial in the Quick Dials list box.



Delete button
Clicking on this button allows you to delete the currently selected quick dial in the Quick Dials list box.





The Change Deck Index Dialog Box
The order the cards in your deck are displayed is determined by the data boxes that show in the index
line on the top row of each card. Choosing Index from the Configure menu displays the Change Deck 
Index dialog box:

Click on an area for an explanation of its function

Related Topics...

Configuring the Index 



Level 1
The field listed in this list box is the first or "primary" field in the index. For example, if you want to sort
your deck alphabetically by last name, choose the "Last Name" entry in the Level 1 list box. Each 
card's index line will display the data from this data box on the very left.



Level 2
The field listed in the Level 2 list box is the second field used in the index. This means that if there are
two cards with identical data in the Level 1 list box, those cards will be sorted additionally according to
the data in the Level 2 list box. For example, the data in Last Name is sorted first. Then First Names 
data is sorted within the Last Name grouping. You do not have to choose a data box for Level 2, if you
don't want to.



Level 3
The field listed in the Level 3 list box is the third field used in the index. This means that if there are 
two cards with identical data in the Levels 1 and 2 list boxes, those cards will be sorted additionally 
according to the data in the Level 3 list box. For example, you could sort Level 1 on Last Name, Level
2 on First Name, then Level 3 on Middle Initial. As a result, Smith, Albert E. would come before Smith,
Albert Q., followed by Smith, Balthazar B. and so on. You do not have to choose a data box for levels 
2 or 3, if you don't want to. But you must have a Level 2 entry if you want a Level 3 entry.



Reverse Order check box
The Reverse Order check box following each levels list box determines whether that level will be 
sorted in forward or reverse order. For example, with the Reverse Order check box off, the data on 
that level would be sorted A to Z. With the Reverse Order check box selected, the data on that level 
would be sorted Z to A.

When indexing in default forward order, buttonFile sorts space (blank) characters first; non-alphabetic,
non-numeric characters (such as !,@,#, etc.) second; alphabetic characters (letters) third; and 
numbers last. 





The Add Security Dialog Box
With the Add Security option on the Configure menu, you can password-protect your deck, so that 
only people who know that password can use the deck. You can add or remove either of the file 
security features at any time. If a deck has been previously password-protected, you must know the 
current password before you can remove or change it.

WARNING: Be VERY careful with these featuresif you add a password and forget it, you will not be
able to get back into your deck. Choose a password you can easily remember, or write it down and 
put it somewhere secure.

Click on an area for an explanation of its function

Related Topics...
Configuring Deck Security 





The Phone Dialer Dialog Box
If your computer has a modem and phone attached to it, buttonFile can dial your phone for you. 
buttonFile will find any phone number in the current card and display a list for you to choose from. 
buttonFile can also dial a phone number you type directly into the dialing dialog box. Plus, you can 
enter a list of up to 100 commonly used numbers which can be dialed any time you have buttonFile 
running. And if you want, buttonFile will even keep track of the phone calls you make in a disk file.

Note: You cannot use buttonFiles dialing features to connect to another computer, such as a BBS or 
communications service, or to a fax machine. buttonFiles dialing features can only be used for normal
voice connections.

Click on an area for an explanation of its function

Related Topics...

Using the Phone Dialer 



Phone Number text box
The Phone Number text box displays the phone number that will be dialed when you choose the 
Place Call button.

There are several ways of choosing a phone number:

Make a selection in the Card Numbers list box

Make a selection in the Quick Dials list box

Type a telephone number directly in to the list box



Card Numbers list box
The card numbers that appear in this list box come from the data boxes on the current card which 
have been configured to contain phone number data. Select the number you want to do dial to place it
in the Phone Number text box.



Quick Dials list box
The phone numbers that appear in this list box are the number you added using the Phone Dialer 
Configuration dialog box. Select the number you want to dial to place it in the Phone Number text box.



Get Outside Line check box
When this item is checked, buttonFile sends the Outside Line Prefix configured on the Phone Dialer 
Configuration dialog box before sending the actual telephone number. This feature is mostly 
commonly used in offices with telephone systems which require you to dial a number to be connected
with an external telephone line.



Long Distance check box
When this item is checked, buttonFile sends the Long Distance Prefix configured on the Phone Dialer 
Configuration dialog box before sending the actual phone number. This is the number required by 
your long distance carrier--in most cases "1".

NOTE: If the phone number begins with the local area code and the Long Distance check box is not 
checked and the local area code has been entered into the Phone Dialer Configuration dialog box, 
the area code will not be dialed.



Place Call button
Pressing this button tells buttonFile to accept all the settings and dial the number contained in the 
Phone Number text box.

NOTE: In order for dialing to work properly, the phones handset MUST be down until buttonFile is 
finished dialing the number.





The Button Bars
The button bar makes common menu options easy to perform with a mouse. The button bar can be 
turned off by un-checking the Show Button Bar option on the Configuration menu. Note: Buttons on 
the button bar cannot be accessed from the keyboard, but they are equivalent to menu selections and
accelerator keys which can. There is a separate kind of button bar for each kind of window:

Deck Window 

Deck Designer Windows 

Report Designer Windows 
Click on a window type to find out more about its button bar



Deck Window Button Bar
The first three buttons on the left lets you open, create, and save a deck. The next four buttons let you
navigate (browse) through the cards in the deck. The next two buttons let you add and delete cards. 
The next two buttons let you search for cards. The final two buttons let you use the phone dialer or 
print a report. The area to the right of the buttons displays the current card's number and how many 
cards are in the deck.

Click on a button to find out more about it.



Deck Designer Button Bar
The first button on the left lets you save your deck design. The next three buttons let you add different
card elements. Once you start designing your card, the area to the right of these buttons is used for 
additional buttons and controls. 

Additional text boxes, check boxes, and buttons display on the right side of the button bar as soon as 
you use the text, data box, or notes box buttons; and whenever a card element is selected. What 
displays on the button bar varies according to what kind of card element is selected in the designer 
window below. For example, when you add or select a data box, the button bar displays a text box to 
edit the name and a spin box to specify the length.

Click on an item to find out more about it.



Report Designer Button Bar
The first two buttons on the left let you save and print your report. The next four buttons let you add 
different report elements. The last button lets you change to a different form

Once you start defining your report, the area to the right of these buttons is used for additional buttons
and controls. The options available on the button bar will vary depending on what kind of frame is 
selected.

The Name drop-down list box in the center of the button bar is only active when placing or selecting a 
data box frame. This is replaced by a text box when defining the contents of a text frame. Different 
options replace the Style and Alignment buttons when defining lines and boxes.

Click on an item to find out more about it.



Open button

Pressing  is the same as choosing the Open option on the File menu.

The keyboard shortcut is  + 

.
Click here for more information... 



New button

Pressing  is the same as choosing the New option on the File menu.
Click here for more information... 



Save button

In a deck window or deck design window, pressing  is the same as choosing the Save option on 
the File menu. In a report design window, it is the same as choosing the Save Report option on the 
File menu.

The keyboard shortcut is  + 

.
Click here for more information... 



Browse Previous Windowful button

Pressing  is the same as choosing the Navigate option on the Search menu, and then on the 
Navigate submenu pressing Previous Windowful.

The keyboard shortcut in Card View is  + 

.
The keyboard shortcut in Table View is 

.
Click here for more information... 



Browse Previous Card button

Pressing  is the same as choosing the Navigate option on the Search menu, and then on the 
Navigate submenu pressing Previous Card.

The keyboard shortcut in Card View is .
The keyboard shortcut in Table View is 

.
Click here for more information... 



Browse Next Card button

Pressing  is the same as choosing the Navigate option on the Search menu, and then on the 
Navigate submenu pressing Next Card.

The keyboard shortcut in Card View is .
The keyboard shortcut in Table View is 

.
Click here for more information... 



Browse Next Windowful button

Pressing  is the same as choosing the Navigate option on the Search menu, and then on the 
Navigate submenu pressing Next Windowful.

The keyboard shortcut in Card View is  + 

.
The keyboard shortcut in Table View is 

.
Click here for more information... 



Add Card button

Pressing  is the same as choosing the Add option on the Card menu.

The keyboard shortcut is  + 

Click here for more information... 



Delete Card button

Pressing  is the same as choosing the Delete option on the Card menu.

The keyboard shortcut is  + 

Click here for more information... 



Find button

Pressing  is the same as choosing the Find option on the Search menu.

The keyboard shortcut is  + 

Click here for more information... 



Find Next button

Pressing  is the same as choosing the Find Next option on the Search menu.

The keyboard shortcut is  + 

Click here for more information... 



Phone button

Pressing  is the same as choosing the Dial option on the Phone menu.

The keyboard shortcut is 
Click here for more information... 



Print button

Pressing  is the same as choosing the Print Report option on the File menu.

The keyboard shortcut is  + 

.
Click here for more information... 



Add Text button

Pressing  is the same as choosing the Add Text option on the Tools menu.

The keyboard shortcut is  + 

.
Click here for more information about this button's use in the deck designer... 
Click here for more information about this button's use in the report designer... 



Add Data Box button

Pressing  is the same as choosing the Add Data Box option on the Tools menu.

The keyboard shortcut is  + 

.
Click here for more information about this button's use the deck designer... 
Click here for more information about this button's use the report designer... 



Add Notes Box button

Pressing  is the same as choosing the Add Notes Box option on the Tools menu.

The keyboard shortcut is  + 

.
Click here for more information... 



Add System Data button

Pressing  is the same as choosing the Add System Data on the Tools menu.
Click here for more information... 



Add Line or Box button

Pressing  is the same as choosing the Add Line or Box option on the Tools menu.

The keyboard shortcut is  + 

.
Click here for more information... 



Forms button

Pressing  is the same as choosing the Change Form option on the Tools menu.

The keyboard shortcut is  + 

.
Click here for more information... 



Bold button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing
the Bold check box on the frame's Attributes dialog box.

The keyboard shortcut is  + 

.
Click here for more information... 



Italic button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing
the Italic check box on the frame's Attributes dialog box.

The keyboard shortcut is  + 

.
Click here for more information... 



Underline button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing 
the Underline check box on the frame's Attributes dialog box.

The keyboard shortcut is  + 

.
Click here for more information... 



Align Left button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing
the Left alignment option button on the frame's Attributes dialog box.

The keyboard shortcut which toggles between the three alignment buttons is  + 

. 
Click here for more information... 



Align Center button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing
the Center alignment option button on the frame's Attributes dialog box.

The keyboard shortcut which toggles between the three alignment buttons is  + 

. 
Click here for more information... 



Align Right button

Pressing  is the same as choosing the Frame Attributes option on the Tools menu, then choosing
the Right alignment option button on the frame's Attributes dialog box.

The keyboard shortcut which toggles between the three alignment buttons is  + 

. 
Click here for more information... 



Box button

The  button only appears if a Line/Box frame is add or selected. Pressing it is the same as 
choosing the Frame Attributes option on the Tools menu, then choosing the Box option button on the 
frame's Attributes dialog box.

The keyboard shortcut which toggles between the box, horizontal line, and vertical line buttons is  + 

. 
Click here for more information... 



Horizontal Line button

The  button only appears if a Line/Box frame is add or selected. Pressing it is the same as 
choosing the Frame Attributes option on the Tools menu, then choosing the Horizontal Line option 
button on the frame's Attributes dialog box.

The keyboard shortcut which toggles between the box, horizontal line, and vertical line buttons is  + 

. 
Click here for more information... 



Vertical Line button

The  button only appears if a Line/Box frame is add or selected. Pressing it is the same as 
choosing the Frame Attributes option on the Tools menu, then choosing the Vertical Line option button
on the frame's Attributes dialog box.

The keyboard shortcut which toggles between the box, horizontal line, and vertical line buttons is  + 

. 
Click here for more information... 



Deck Designer Text edit box
The Text edit box only appears if a Text frame has just been added or selected. Click in the edit box, 

or press  + 

 to edit the text.
Click here for more information... 



Deck Designer Name edit box
The Name edit box only appears if a Data Box or Notes Box frame has just been added or selected. 

Click in the edit box, or press  + 

 to edit the name.
Click here for more information... 



Data Box Length spin box
The Length spin box only appears if a Data Box frame has just been added or selected. Click in the 

edit box, or press     + 

 to edit the length. Or click on the arrows to adjust the length up or down.
Click here for more information... 



Text Frame edit box
The Text edit box only appears if a Text frame has just been added or selected. Click in the edit box, 

or press  + 

 to edit the text.
Click here for more information... 



Name drop-down list box
The Name edit box only appears if a Data Box or Notes Box frame has just been added or selected. 

Click on the down arrow, or press  + 

 then press 

 + 

 to select a different data box.
Click here for more information... 



Line Style drop-down list box
The Line Style drop-down list box only appears when a Line or Box frame has just been added or 

selected. Click on the down arrow, or press  + 

 then press 

 + 

 to select a different line style
Click here for more information... .



Fill Pattern drop-down list box
The Fill Pattern drop-down list box only appears when a Box frame has just been added or selected. 

Click on the down arrow, or press  + 

 then press 

 + 

 to select a different fill pattern.
Click here for more information... .



Corner Radius spin box
The Corner Radius spin box only appears when a Box frame has just been added or selected. Click in

the edit box, or press     + 

 to edit the length. Or click on the arrows to adjust the length up or down.
Click here for more information... .





Hints On Using Help
Here are some quick hints that will help you understand and get the maximum benefits from 
buttonFile Help. NOTE: For complete information on how to use Windows Help, choose the Help 
menu item on the buttonFile Help menu bar.

buttonFile Help Conventions & Hints
Keyboard keys appear as keys (for example, 

)

Keyboard combinations appear as keys with a plus sign between them (for example, 

 + 

 and 

 + 

)

To use keyboard combinations, hold down the first key and press the second key. For 

example, to issue the  + 

 command, hold down the 

 key and press the 

 key)

Each procedure heading is marked by an arrow bullet (

). This makes it easy for you to locate procedures in the Help file.

Procedure steps are given in numbered lists (1, 2, 3, ...) unless a procedure only has one step, in 
which case the step begins with a bullet (

). When there are alternative methods to perform a procedure, each alternative is preceded with 
"Or..."

Procedures that are specific to the mouse are marked by a 

. Procedures specific to the keyboard are marked by a 

.

List items that provide information are marked by bullets (

). This list of conventions is an example of a bulleted list.

Special information and notes about using buttonFile are preceded with "NOTE:"

"Click-able" text is green and has a single underline or a dotted underline.

Clicking on green text with a single underline "jumps" to a related help topic. Example:

Clicking on green text with a dotted underline "pops-up" a term or definition for the text. Example:

A "Related Topics..." section is located at the end of most topics and procedures. This section 
contains "jumps" which you can click on to go to those topics.

Whenever your mouse cursor changes into a hand (

), you can click on that text or area of a picture to get more information on that topic. Try moving your 



cursor over different areas of a picture to see if any of the areas cause the cursor to change to hand. Most
of the dialog boxes shown in the help file will allow you to click on specific areas to find out more 
information.




